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USING THIS TEXT IN THE CLASSROOM

The Textbook in Digital Photography Project was established by
ShortCourses.com to develop and distribute high-quality yet affordable
materials in digital photography for both classroom and independent

study. With photography texts from traditional publishers reaching $80 or
more, it is time to try a new approach more attuned to the digital era—full-
color, fully searchable PDF eTexts that can be displayed on any computer
using Adobe’s free Acrobat reader. eTexts and PDF files are revolutionizing
the publishing and printing businesses in many ways including the following:

■ Timeliness. Since large quantities of inventory aren’t required, we can
revise and update materials as needed instead of on a fixed schedule every 2
or 3 years. In a rapidly evolving field such as digital photography these
frequent revisions are often required to keep materials up to date.

■ Distribute and print. Textbook publishers work on a print and distribute
basis. This means they take enormous risks, tie up massive amounts of
capital, and bear high marketing, sales, warehouse, shipping, and billing
costs. All of these costs are passed on to students. The emerging model, used
by this eText, is called distribute and print. Using this model, materials are
distributed around the world electronically and then printed where needed.

■ Print on demand. Textbook publishers print in large runs, increasing their
risks and prices. The print on demand model is to print only when a copy is
ordered, eliminating warehousing expenses. This same model applies to using
this eText. You only print selected pages or chapters when they are needed.
You no longer have to carry a backpack full of books, and if you loose your
materials, you just print another copy.

The materials included in The Textbook in Digital Photography Project
introduce you to all aspects of the rapidly emerging world of digital photogra-
phy. The project materials currently available include the following:

■ The core text—The Textbook of Digital Photography—introduces the entire
panorama of digital photography and includes the following topics:

● Introduction to the digital camera and digital images (Chapter 1)
● Introduction to the digital darkroom (Chapter 2)
● Camera controls and creative photography (Chapters 3–6)
● Flash and studio lighting (Chapter 7–8)
● Sharing and displaying digital images (Chapter 9–10)
● Exploring beyond the standard still image (Chapter 11)
● Understanding pixels and image sizes (Chapter 12)
● Caring for your camera, scanning, and shooting RAW images (Appen-
dix)

■ Lab manuals on photo-editing present Photoshop and Photoshop Ele-
ments. These comprehensive, yet easy to follow guides, can be used with or
without the core text.

■ Supplements are published periodically between editions to keep materials
more timely or to expand coverage in selected areas. Be sure to frequently
visit the project’s Web site (www.photocourse.com) for an up-to-date listing
of what’s available. For additional information on digital photography, visit
the publisher’s Web site at www.shortcourses.com.

Special discounts are
offered on copies of our
texts shipped to school
addresses. For more
information, e-mail
Peggy at peggy
@shortcourses.com.

If you are using this
text in a class, you
must have a personal
copy of the printed and
spiral book or the CD
that contains the text in
PDF format and also
acts as your license
agreement. If you do
not have such a book or
CD, you may be using
an illegal copy. To see
how to qualify for
classroom copies or to
determine if you are
using a legal copy, visit
our site at
www.photocourse.com.

USING THIS TEXT IN THE CLASSROOM
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PREFACE

Photoshop CS is the undisputed leader in photo-editing software.
Widely used by photographers, graphic artists, printers, designers, and
other creative professionals, it has something for everyone. It’s this

breadth that lies at the heart of its complexity—there are tools for everyone
and everything.

Our goal in this book is to simplify your introduction by focusing on those
aspects of Photoshop that are most useful to digital photographers. From this
single perspective, the program becomes much easier to master because you
follow a single main road through the program. Detours along the many back
roads of the program are left for another time and another book.

We recognize that digital images can be edited in a wide variety of ways. In
some cases you’re a photographer trying to improve an image by eliminating
or reducing its flaws. In other cases you are a graphic artist taking an image
to a new place, making it something it never was, or incorporating it as one
element in a larger project. In this book we focus on the photographic as-
pects, but in the process introduce you to many of the same tools you need to
combine photography and the graphic arts.

This book is divided into eight chapters and an appendix.

■ Chapter 1 Getting Started introduces you to the Photoshop CS screen
display and tools. This chapter lays the foundation for the rest of the book.

■ Chapter 2 Working with Image Files introduces you to basic procedures
such as opening, saving and printing images.

■ Chapter 3 Fixing Your Images shows you how to evaluate tones, colors,
sharpness, and other characteristics of an image and how to select the tools
you use to fix or improve it.

■ Chapter 4 Working with Selections shows you how to select areas of an
image to copy, move, or enhance.

■ Chapter 5 Working with Layers discusses how you use layers to adjust
your images.

■ Chapter 6 Painting & Drawing shows you how to use the program’s
painting, drawing, and erasing tools used to improve selected areas of an
image.

■ Chapter 7 Creating and Using Masks shows how you work on specific
channels or areas of your images.

■ Chapter 8 Automating Tasks shows you how to automate processes
involving more than one image. These processes include printing contact
sheets and picture packages, creating a Web gallery, stitching images into
panoramas, creating PDF presentations including slide shows, and batch
renaming files, creating actions and batch processing files.

■ Chapter 9 Color Management discusses how to make sure your prints
match what you see on the screen.

Photoshop CS runs on both Mac and PC systems and you will find minor
differences between the two platforms. These differences are limited to a few
keys on the keyboard and a few menu commands. Although this book fea-
tures the PC version of the program, you should be able to master the Mac
version using this book.

PREFACE
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IMAGEREADY

■ Photoshop CS
comes with a
companion pro-
gram, ImageReady,
that is not dis-
cussed in this book.

TIPS

■ Ctrl on PCs often
performs the same
functions as
Command (key
with symbol) on
Macs.

■ Alt on PCs
performs the same
functions as Option
on Macs.

■ Enter on PCs
performs the same
role as Return on
Macs.
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CHAPTER 1. GETTING STARTED
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Photoshop is a powerful program suitable to even the most technically
oriented photographer. Because it can do so much, it initially looks
complicated, and in many ways it is. However, since it’s a program you

won’t outgrow, it’s worth the time it takes to master it. In this chapter we lay
the foundation for everything to come. You’ll learn about the screen display,
help system, the toolbox, palettes, basic commands and undoing mistakes.
Once you understand this material, you will be ready for the chapters that
follow on viewing, opening, printing and editing your images.

Photoshop runs on both Windows and Macintosh systems. The major
differences are the names of a few keys on the respective keyboards, a few
menu names, and operating system level dialog boxes used for basic opera-
tions such as opening, saving, and printing images. This book features the
Windows version from which all of our screen illustrations are taken. How-
ever, if you are familiar with the Mac, you should have no difficulty following
the discussion presented here.

Chapter 1
Getting Started

CONTENTS

■ Developing a Process ■
Starting and Quitting
Photoshop ■ Learning
Photoshop ■ Using the
Toolbox ■ Using Palettes
■ Basic Commands ■
Undoing Changes

AA30470C
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DEVELOPING A PROCESS—YOUR WORKFLOW

When working with digital photos it helps to have your own process for
storing and backing up your photos. This process—often called a work-
flow—is simply a series of steps that you consistently follow to save time
and reduce anxiety in the long run. The more methodical you are, the
easier things are down the road. Here is one approach developed over the
years by experienced photographers.

Step 1. Take the pictures. This is the fun part, but if there is one secret it’s
“take a lot of them.” The more you take the more the law of averages works
in your favor, but the more time you’ll have to spend sorting and selecting
the best.

Step 2. Create a folder system on your hard drive into which you copy the
photos that you have taken.

Step 3. Copy the images to the computer, and after checking that they
copied correctly, delete them from the camera’s memory card. The best
way to check that they copied correctly is to look at them with a thumbnail
image viewer or asset manager. To be really cautious, don’t delete images
from the memory card until you have completed the next step, or even
better—until you need the card for other photos.

Step 4. Copy the images from your camera’s memory card or the com-
puter to a CD/DVD or other storage device so you have a backup of
everything you shot. This is the most important backup you will make
because it protects the original images. If you don’t make any additional
backups, you may have to redo a lot of work, but at least your original
images won’t be lost. To be really cautious, make two backups and store
them so the same accident can’t happen to both.

Step 5. Delete bad photos from the computer’s hard disk since they are just
taking up space that you can use for other photos. You can be fairly aggres-
sive, because you already have a backup of the original photos should your
definition of “bad” ever change.

Step 6. Create a project folder and copy into it all of the photos you may
want to include in the current project. A project may be as small as a series
of photos to be printed or e-mailed, or as large as a DVD slide show with
background music. Use the same project folder for all project-related files
including those created by other programs. This keeps everything together
and easy to backup.

Step 7. Make your final selection of photos. Go through all of the project
photos and delete any that you don’t want included.

Step 8. Edit the photos if any of them need it. You may want to remove red-
eye, boost saturation, or adjust levels and sharpness. Many digital photos
can be improved dramatically with just a little tweaking.

Step 9. Copy the final photos to a project CD/DVD or other storage
device. You’ve invested effort in selecting and editing these photos so
backing them up at this point would be prudent.

Step 10. Assemble the final project, whatever it may be.

Step 11. Copy the final project files to a CD/DVD or other storage device.
In some cases this might be a master disc that you make copies from for
distribution. In other cases it’s a backup disc to put away in a safe place.

As unlikely as it seems,
disasters do happen.
Rick Ashley, my
coauthor on “The Digital
Desktop Studio” book
took a short vacation
during which he got a
phone call that his
studio was on fire. It
contained a lifetime of
work—negatives, prints,
letters, equipment. All
was lost. Rick was
reduced to just the
camera he had with him
at the time and a few
things he’d loaned to
others. In this photo by
Rick, his studio is in that
floorless and ceilingless
space on the third floor.

TIP

■ To manage a
collection of
images, you need a
program called an
asset manager that
stores filenames,
thumbnails, and
other information
about each image
in a database.
Leading programs
in this area are
Cumulus from
Canto and Portfolio
from Extensis.

DEVELOPING A PROCESS—YOUR WORKFLOW
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STARTING AND QUITTING PHOTOSHOP

You start Photoshop just as you start other programs. When the program
loads you may first see a welcome screen.

THE WELCOME SCREEN
The Welcome Screen has a number of clickable elements described on page
11. Click the Close button to close the Welcome screen so you can use
Photoshop itself.

PHOTOSHOP’S WORK AREA
The work area contains menus, buttons, palettes, and tools that you use to
edit your images.

TIPS

■ If you have
problems launch-
ing the program, or
if other users have
changed settings,
rebuild your
Photoshop prefer-
ences file. To do so,
as you start the
program, hold
down Shift+Ctrl+
Alt. When asked if
you want to delete
the settings file,
click Yes.

■ If you click the
Welcome screen’s
Show this dialog at
startup check box
to turn it off, you
can still display the
Welcome screen by
choosing Help>
Welcome Screen.
To then see it each
time you start up
the program, click
the check box to
turn it back on.

The toolbox has three
icons that change the
screen mode when an
image is open. From left
to right they are
Standard Screen Mode,
Full Screen Mode with
Menu Bar, and Full
Screen Mode.

The dialog box that
appears when you
restore settings to their
default settings.

HTTP://WWW.PHOTOCOURSE.COM
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1. Menu bar displays the main menu listing the names of menus that you
click to pull down so you can choose from groups of related commands. For
example, the Help menu lists many of the help commands you can use to
learn more about the program.

2. Options bar displays options for the tool that’s currently selected in the
toolbox (page 13). This bar can be displayed or hidden with the Window>
Options command.

3. The palette well, at the far right end of the options bar, organizes and
keeps handy the palettes you use to edit your images (page 16). This well isn’t
displayed when the screen is set to a resolution of 800 x 600 or less.

4. Palettes used to monitor and modify images are displayed when you select
commands from the Window menu (page 16).

5. Active image area displays images you have opened to view, edit or print.

6. Toolbox holds the various tools you use when editing images (page 13).

7. Status Bar at the bottom of the application window displays information
arranged in three sections when an image is open. This bar can be displayed
or hidden with the Window>Status Bar command.

● The leftmost section displays the current magnification of the image
(page 32).

● The middle section displays the document size but you can click the
triangle to select other information to be displayed here.

● The rightmost section displays information about the currently selected
tool and a progress bar that helps you follow the progress of an operation.

MANAGING THE WORK AREA
When editing images, there are ways to manage your work area so you have
access to the necessary tools, but not so many that the image is obscured.

■ To hide or display the toolbox, status bar, or options bar, pull down the
Window menu and click Tools, Status Bar, or Options.

■ To open a palette, click its tab in the palette well, drag it into the image
area by its tab, or pull down the Window menu and click its name.

■ To show or hide all open palettes, the options bar, and the toolbox, press
Tab. To show or hide just palettes, press Shift+Tab.

■ To return the toolbox, palettes and the options bar to their default posi-
tions, select Window>Workspace>Reset Palette Locations.

GRID
Displaying a non-printing grid over the image provides a guide when per-
forming operations such as selecting or rotating an image. When turned on,
the menu commands you use have check marks in front of them.

■ To turn the grid on or off, select View>Show>Grid.

■ To have things snap to the grid lines, select View>Snap To>Grid.

■ To change the grid settings, select Edit>Preferences>Guides, Grid &
Slices.

The grid lets you align
tools and selections
more accurately.

Gripper bar

TIP

■ The options bar
is usually “docked”
at the top of the
application window
and palettes are
often docked in the
palette well. You
can drag and drop
them into the
image area where
they “float.” Drag
the option bar by
its gripper bar and
palettes by their
tabs. To return
them to their
default positions,
select Window>
Workspace>Reset
Palette Locations.

STARTING AND QUITTING PHOTOSHOP

Clicking the triangle on
the status bar lets you
select what’s displayed.

HTTP://WWW.SHORTCOURSES.COM
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RULERS & GUIDES
Rulers along the left and top of the image window help you precisely posi-
tion the cursor, selections, shapes, type, and other tools and image elements.
You can turn these rulers on and off by selecting View>Show Rulers or
View>Hide Rulers.

As you move the mouse pointer about the screen, markers on the rulers
track its position. You can use these markers to measure the width or height
of any area of an image, or precisely position tools. The ruler is initially set
to inches, but you can change to another unit of measurement by double-
clicking either ruler to display the Preferences dialog box.

The ruler’s origin—the place where the two rulers intersect and numbering
starts at zero (0)—is initially aligned on the top left corner of the image. At
times you may want to move the origin so you can measure from a different
point on the image. To move it, point to the intersection of the rulers in the
upperleft corner of the window, and drag diagonally down into the image
area. A set of cross hairs lets you position it precisely and the new zero
origin is set where you release the mouse button. To reset the ruler origin to
its default value, double-click the upperleft corner where the rulers inter-
sect.

The ruler origin determines the grid’s alignment. If you drag the origin to a
new position, the grid will shift so one intersection aligns with the origin.

When the rulers are displayed, you can point to them with any tool and drag
a guide into the work area. You can use guides to align elements added to a
photo or to indicate an area to be cropped.

MANAGING THE WORKSPACE
The positions of all open palettes and movable dialog boxes are saved when
you exit the application. By saving a screen layout as a workspace, you'll be
able to return to it, even if you move a palette or close the toolbox. Saved
workspaces also work with the File Browser (page 25), allowing you to save
your preferred File Browser setup.

■ To save the current workspace layout, select Window>Workspace>Save
Workspace to display the Save Workspace dialog box. Enter a descriptive
name for the workspace, and click Save.

■ To choose a previously saved workspace, select Window>Workspace and
select any workspace listed at the bottom of the submenu.

■ To delete a workspace, select Window>Workspace>Delete Workspace to
display the Delete Workspace dialog box. Click the Workspace drop-down
arrow to select the workspace you want to delete, and click Delete. When
asked to confirm the deletion, click Yes.

QUITTING THE PROGRAM
When you are finished with Photoshop, you exit the program by clicking the
application’s close button or by selecting File>Exit. If you do so while there is
an unsaved image open, you will be asked if you want to save it. Click Yes to
save the file or No to exit without saving it.

The rulers’ origin is in
the upperleft corner of
the image.

The Window>
Workspace menu.

The dialog box that
appears when you exit
with unsaved changes.

TIP

■ Check out the
View>Extras and
View>Show
commands that
hide and display
various screen
elements such as
guides.

Icons on Photoshop’s
window include (from
left to right) Minimize,
Restore Up/Down,
Maximize, and Close.

HTTP://WWW.PHOTOCOURSE.COM
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LEARNING PHOTOSHOP

Photoshop provides you with many forms of help including tool tips, a
searchable help system, detailed step-by-step instructions, and tutorials.

THE WELCOME SCREEN
The Welcome Screen lists many resources and is displayed when you first
start Photoshop (unless you have turned it off), or you can display it at any
time by selecting Help>Welcome Screen. The screen gives you access to the
following:

■ Tutorials include Learning the Basics from the help system, Advanced
Techniques on Adobe’s Web site, and Working with What’s New that de-
scribes the training video included with the program.

■ Tips and Tricks opens a 56 page PDF file with many interesting techniques
you can try.

■ Color Management Setup displays help on a number of topics related to
making colors in a print match those displayed on the screen and in the
original scene.

■ What’s New has sections for New Features at a Glance (a 2-page PDF file),
New Feature Highlights (a 10-page PDF), and a What’s New Movie com-
mand that takes you to the Adobe Web page listing Flash animations.

■ Show this dialog at startup check box has to be on (containing a check
mark) for the Welcome Screen to appear when you start the program.

■ Close button closes the Welcome Screen so you can use Photoshop itself.

USING HELP
To display help, select Help>Photoshop Help or press F1 to open help in your
browser’s window. It has two sections, bookmarks on the left and contents on
the right. You navigate through it just as you would navigate a Web site. At
the top of the bookmarks section are links to Using Help, Contents, index,
Site Map, and Search (Find on Acrobat 5).

■ Using Help lists topics on how to use the help system.

■ Contents lists topics much like the contents page in a book.

■ Index lists letters you can click to find topics listed alphabetically.

■ Site Map contains links to all topics in Help and all entries in the Index.

■ Search displays a text box into which you can type any term and click the
Search button to find related topics.

Once you locate a topic or section of interest, you can use your browser's Find
command to search the page, or its Print command to print it. You can also
click Next, Previous, and Top links to move through pages in sequence.

OTHER RESOURCES
In addition to the Welcome Screen and help system, there are many other
resources you can draw on to learn more about Photoshop.

The Help menu lists
commands and at the
bottom of the menu,
tutorials.

Using Help contents
screen.

LEARNING PHOTOSHOP

The Welcome Screen.

HTTP://WWW.SHORTCOURSES.COM
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■ The entire on-line help system is also available as a 750 page PDF file.
The file PhotoshopCSHelp.pdf is on the application’s CD in a folder named
Help. Copy it to your desktop so it’s readily available.

■ The Adobe Studio site at www.studio.adobe.com has tips, tutorials, and
free downloads.

■ Video Workshop CD that accompanies Photoshop contains more than 60
minutes of video tutorials that you can view on your computer. For a descrip-
tion of this CD, click the Working with What’s New icon on the Welcome
screen (page 11).

■ Tool tips are displayed when you point to a tool, button, or some other
screen elements, and pause. (Tool tips are usually not available in dialog
boxes.)

■ Adobe Online gives you access to updates that correct bugs, enhance
features, or provide additional help. With your computer connected to the
Internet, try these:

● To go to Adobe Online’s Photoshop site, click the feather icon at the top
of the toolbox or select Help>Photoshop Online.

● To download updates when available, select Help>Updates.

■ Some dialog boxes have a Help button indicated by a question mark icon,
To learn about elements in the dialog box, click this button to add a question
mark to the mouse pointer, then click the element you want to know more
about. A descriptive panel will be displayed. To close the panel click any-
where or press any key.

■ Photoshop CS does not include a quick reference card, but you can print
one of the shortcut commands that let you operate the program without
using menus. To do so select Edit>Keyboard Shortcuts to display the Key-
board Shortcuts dialog box. Click the Summarize button to display the Save
dialog box. Click Save, then OK to replace the file and a complete list of
keyboard shortcuts is displayed in your browser where you can view or print
it.

A dialog box help button
indicated with a
question mark icon.

Right-clicking the help
topics displays your
browser’s pop-up menu.
It varies depending on
what you click and what
browser you use.

SYSTEM PROBLEMS

■ Photoshop uses disk space, called a cache, to store thumbnail and file
information to make loading times quicker when you return to a previ-
ously viewed folder. If your system slows or you need to free up room on
your hard disk drive you can purge the cache although this also deletes
ranking, flag, and stored thumbnails from the File Browser (page 28). To
purge the cache for the selected folder, select File>Purge Cache from the
File Browser’s menu (not the main menu on the menu bar). To purge the
entire cache select File>Purge Entire Cache. For other cache commands
search for the term “cache” in Help.

■ If you have problems launching the program, or if other users have
changed settings, rebuild your Photoshop preferences file. To do so, as
you start the program hold down Shift+Ctrl+Alt. When asked if you want
to delete the settings file, click Yes.

■ If your prints look different from the image on the screen, you have to
use color management (page 182).

The first time you start
Photoshop after
installing it or restoring
its default settings
(page 8), a dialog box
appears asking if you
want to customize color
settings.
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USING THE TOOLBOX

When Photoshop starts, the toolbox is displayed in the work area. You can
hide and reshow it at any time with the Window>Tools command. The
toolbox contains icons representing tools you use to edit photos, although
there are actually more than you see because some are hidden.

SELECTING TOOLS
Point to any tool in the toolbox and its name and keyboard shortcut are
displayed in a tool tip. The currently selected tool is highlighted.

■ To select a tool, click it in the toolbox, or press the tool's keyboard short-
cut (page 19) given in its tool tip.

■ To display hidden tools when a tool has a small triangle, point to the tool
and hold down the mouse button then click the tool you want to select. A
small square indicates which tool is currently selected. To cycle through the
hidden tools, hold down Alt as you repeatedly click the tool, or hold down
Shift and repeatedly press the tool's shortcut key.

■ To move the toolbox, drag it by its title bar (which has no title).

■ To display or hide the toolbox, select Window>Tools.

■ To set tool preferences select Edit>Preferences>General. Choices include
showing or hiding tool tips or resetting all tools.

TYPES OF TOOLS
The tools from which you can choose are briefly described below along with
the keyboard shortcut you can press to select them. Page references indicate
the section where each tool is discussed in the most detail in this book. For
tools that have hidden tools, all versions are listed with the default tool
boldfaced.

1. Adobe Online takes you to Adobe’s Photoshop Web site (page 11).

2. Rectangular (M), Elliptical, Single Row, and Single Column marquee
tools select regularly shaped areas of your image by dragging or clicking the
mouse (page 88).

3. Move (V) moves guides, selections and layers by dragging (page 10, 96,
111). To temporarily switch to this tool while using another tool, hold down
Ctrl.

4. Lasso (L), Polygonal Lasso (straight-edged), and Magnetic Lasso (snap-
to) draw around an irregularly shaped area to select it (page 90).

5. Magic Wand (W) selects areas of the image with pixels of exactly the
same or similar colors (page 92).

6. Crop (C) selects a rectangular area of the image for cropping (page 54).

7. Slice (K) creates slices and Slice Select selects the slices.

8. Healing Brush (J) paints with a sample or pattern to repair imperfec-
tions in a image, Patch repairs imperfections in a selected area of an image
using a sample or pattern, and Color Replacement replaces a selected color
with a new color (page 137).

To display hidden tools,
point to any tool with a
small triangle in its
lowerright corner and
hold down the mouse
button.

The toolbox.

USING THE TOOLBOX
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9. Brush (B) paints brush strokes and Pencil paints hard-edged strokes
(page 129).

10. Clone stamp (S) and Pattern stamp copy an area of the image, or a
pattern, to other areas of the image (page 137).

11. History Brush (Y) tool paints a copy of the selected state or snapshot
into the active image. Art History brush tool paints with stylized strokes that
simulate the look of different paint styles, using a selected state or snapshot
(page 137).

12. Eraser (E), Background eraser, Magic eraser erase pixels you drag over
(page 134).

13. Gradient (G) fills areas with a gradual blend of selected colors and Paint
Bucket fills areas with a color or pattern (page 141).

14. Blur (R) blurs edges you drag over, Sharpen sharpens them, and
Smudge smudges them (page 137).

15. Dodge (O) lightens areas in an image, Burn darkens them, and Sponge
changes the color saturation (page 137).

16. Path selection (A) selects paths or path components showing anchor
points, direction lines, and direction points. Direct Selection tool selects a
path segment.

17. Horizontal Type (T), Vertical type, Horizontal type mask, and Vertical
type mask enter text on an image (page 120).

18. Pen (P), Freeform Pen, Add Anchor Point, Delete Anchor Point, and
Convert Point draw freehand lines on an image.

19. Rectangle (U), Rounded Rectangle, Ellipse, Polygon, Line and Custom
shape tools draw shapes (page 143).

20. Notes (N) tool make notes and Audio Annotation tool adds audio
annotations to images.

21. Eyedropper (I) sets foreground or background colors (page 126), Color
Sampler places up to four Color Samplers in the image that display color
information in the Info palette (page 67), and Measure measures distances,
locations, and angles.

22. Hand (H) moves an image within its window when it’s too large to
display completely in the window (page 32). To use this tool when another
tool is selected, hold down the spacebar.

23. Zoom (Z) zooms the image in and out (page 32).

24. Foreground and background colors show the currently selected
colors and display the color picker when clicked so you can change the colors
(page 126).

25. Edit in Standard Mode (G) and Edit in Quick Mask Mode let you
create masks that select an area to be affected by a command (page 149).

26. Standard Screen (F) includes icons for (from left to right) Standard
Screen Mode, Full Screen Mode with Menu Bar, and Full Screen Mode. The
same commands are also available on the View menu.

27. Edit in ImageReady (Shift+Ctrl+M) is not covered in this book.

TIPS

■ When you select
a tool the mouse
pointer changes,
sometimes to cross
hairs, sometimes to
a circular brush
shape, and some-
times to an icon
matching the tool’s
icon.

■ Each pointer has
a different hot spot
where actions
begin and end.

■ You can custom-
ize pointers by
selecting Edit>
Preferences>Display
& Cursors.

■ For more on
toolbox tools,
search help for
toolbox overview.

■ When you select
a tool, a brief
description of its
function is dis-
played on the
status bar.

■ When you right-
click an image, a
menu pops up. The
menu choices
depend on what
tool you have
selected.
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THE OPTIONS BAR
When you select many tools, such as those you use to type, select, paint,
draw, sample, edit, move, annotate, and view images, the options bar below
the menu bar displays settings specific to the selected tool. To learn about a
tool and its options search for the tool’s name in help.

■ To display options on the options bar, click a tool that has options.

■ To display or hide the options bar, select Window>Options.

■ To display a tool tip, hold the mouse pointer over any element on the
options bar.

PRESET TOOLS
Adobe provides presets for all tools (the default settings), but for some it
provides more than one set.

■ To display the tool preset picker, click the tool preset picker icon at the far
left end of the options bar or select Window>Tool Presets to display the Tool
Presets palette, scroll through the list of preset tools and click the one you
want to use. (Not all tools have extra presets.)

■ To limit the listed presets to those for the currently selected tool, turn on
the Current Tool Only check box.

■ To return the selected tool or all tools to default settings, click the triangle
icon to display the picker’s or palette’s menu, and then select Reset Tool or
Reset All Tools.

You can create and edit tool presets, and save and load them for future use.
This is not difficult since all of the necessary commands are listed on the tool
presets picker’s menu, but a detailed discussion is outside the scope of this
book.

Here the Move tool was
selected in the toolbox,
then the tool preset
picker button was
clicked on the options
bar to display the tool
preset palette. Finally
the palette’s triangle
was clicked to display
the palette menu.

You can use the gripper
bar at the far left end of
the options bar to drag
it anywhere in the work
area. To redock it at the
top of the screen choose
Window>Workspace>
Reset Palette Locations.

USING THE TOOLBOX

The Tool Presets palette
is almost identical to the
tool preset picker.

TIP

■ When you point
to a label for a text
box containing a
value the mouse
pointer changes to
indicate you can
drag left or right to
change the value.
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USING PALETTES

As you edit images, you’ll find many controls and much information orga-
nized into compact and convenient palettes. All of these palettes are listed on
the Window menu and some are stored in the palette well on the right end of
the options bar. (The palette well isn’t displayed when the screen resolution
is set to 800 x 600 or below.)

■ To open a palette, pull down the Window menu and click its name. (Those
that are already open have check marks in front of their name.)

● If the palette is in the palette well, it is pulled down.

● If the palette isn’t already open or in the palette well, it opens in the
work area—usually accompanied by other palettes in a group window.

● If the palette is in a group that is already open, it moves to the front of
the group.

■ To close a palette group, click its close (X) button or the palette’s name on
the Window menu.

THE PALETTES
■ Actions palette (page 172) records and manages commands so they can be
played back to automate repetitive procedures.

■ Brushes palette (page 129) lets you select preset brushes and design
custom brushes.

■ Channels palette (page 58) lets you create and manage channels and
monitor their effects on editing.

■ Character palette (page 120) provides options for formatting text.

■ Color palette (page 126) displays the color values for the current fore-
ground and background colors and lets you change them.

■ File Browser (page 26) displays thumbnails of the images in the currently
selected folder and helps you manage the images on your system.

■ Histogram palette (page 57) displays tonal and color information about
your images.

■ History palette (page 21) lets you return to a previous state of an image,
or periodically capture snapshots you can return to.

■ Info palette (page 67) displays color, distance, and size information about
the pixels you point to or select.

■ Layer Comps palette creates and manages layer comps so you can view
multiple versions of a layout.

■ Layers palette (page 105) lists all layers, layer sets, and layer effects in an
image and provides buttons to create, hide, display, copy, and delete layers.

■ Navigator palette (page 32) displays a thumbnail of the active image and
has controls you can use to zoom and scroll around it.

■ Paragraph palette (page 120) sets formatting options for paragraphs in a
type layer.

■ Paths palette lists the name and a thumbnail image of paths and vector
masks and lets you select and manage them.

The Window menu on
the menu bar lists all of
the palettes and clicking
the name of one opens
or closes it. Those
preceded by check
marks are open.

Palettes are usually
stored together with
other palettes in groups.
Here are the History
and Action palettes in a
group window.
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■ Styles palette (page 120) lets you choose preset layer styles.

■ Swatches palette (page 126) displays colors from which you can select a
foreground or background color.

■ Tool Presets palette (page 15) lets you load, edit, and create libraries of
tool presets. You can also save and reuse your own tool presets.

THE PALETTE WELL
You can store frequently used palettes in the palette well at the right end of
the options bar. This makes it easy to access them when needed and to get
them out of your way when finished.

■ To open a palette in the palette well, click its tab or pull down the Window
menu and click its name. To close it, click its tab, click another tab, or click
anywhere outside the palette in the work area. You can also select the
palette’s name on the Window menu.

■ To move a palette from the palette well into the work area, drag it by its
tab and drop it where you want it to float.

■ To dock a palette floating in the work area in the palette well, drag it (and
not the entire group) by its tab into the palette well so the well is highlighted
and drop it, or click the triangle in the upperright corner of the palette to
display the palette menu and then click Dock to Palette Well.

■ To remove a palette from the palette well, drag it by its tab into the work
area so it floats and then click its close (X) button.

PALETTE ICONS
Most palettes have icons along their bottom border such as a trash can. Point
to these icons for a tool tip describing what they are used for. These buttons
are not displayed when a palette is minimized.

PALETTE MENUS
Palette menus list commands specific to the palette. The only exception is the
Dock to Palette Well command that appears on all palette menus. To display
a palette’s menu, click the triangle icon in the upperright corner of the
palette. (If the palette is in the palette well, first click its tab to display the
triangle.)

TIPS

■ To see the
palette well, the
options bar must
be displayed. If it
isn’t, select
Window>Options.

■ The palette well
isn’t displayed
when the screen is
set to a resolution
of 800 x 600 or
less.

USING PALETTES

The palette well.

TIP

■ Some palettes
display scroll bars
when the palette’s
contents can be
scrolled.

Many palettes have
icons at the bottom of
the palette. Point to
each and pause to
display a tool tip.

Clicking a palette’s
triangle icon displays
the palette menu.
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GROUPING PALETTES
When floating in the work area, palettes are always contained in a group
window. This makes it easy to view and use multiple palettes and also move
them as a group. To make your work even easier, you can drag palettes from
one group to another, to a new group window, or to the palette well. The only
rule is that you have to drag them by their tabs, one at a time. If you create
your own groups and have favored locations for your palettes, you can save
these settings by saving the workspace (page 10).

■ To move a palette from one group window to another, drag a palette's tab
to another palette so the target palette is highlighted, then drop it. (Not all
palettes can be grouped.)

■ To remove a palette from a group, drag its tab and drop it outside of any
existing group to create a new group.

■ To move a palette to the front of its group, click its tab or select its name
on the Window menu.

DISPLAYING AND HIDING PALETTES
Palettes can easily cover and obscure parts of the image you want to see
while editing. However, there are ways to temporarily hide their group
windows without closing them.

■ To show or hide open palettes, the options bar, and the toolbox, press Tab.

■ To show or hide all palettes, press Shift+Tab.

SIZING AND ARRANGING PALETTES
Since palettes often cover part of the image area, there are times when you
want to move their group windows or even change their size.

■ To move a group window elsewhere on the screen, drag the group’s title
bar. To move it to the closest side of the screen, hold down Shift as you drag
and release it.

■ To collapse a group window to display palette titles only, click the group
window’s Minimize button, or double-click a palette's tab.

■ To expand a group window to see the palette’s contents, click the group
window’s Maximize button, or click a palette's tab.

■ To change the size of a group window, drag one of its corners. Not all
palettes can be resized.

USING PALETTE DEFAULT POSITIONS
After rearranging palette groups, their positions are remembered when you
exit Photoshop and restart it later. However, you can return everything to its
default position.

■ To reset palettes to their default positions, select Window>Workspace>
Reset Palette Locations.

■ To specify palette locations when you start Photoshop, select Edit>
Preferences>General, and then turn the Save Palette Locations check box on
or off. When off, the default settings are used.

A palette group that
includes the Layers,
Channels, and Paths
palettes.

The Minimize button
(top) collapses a palette
group window and the
Maximize button
(bottom) expands it to
display all of its options.

A palette group window
without this size box in
the lowerright corner
cannot be resized.
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BASIC COMMANDS

This book assumes some computer background because Photoshop works in
many respects just as hundreds of other programs do. However, there are a
few things to be aware of that may be new to you. Here are some of them.

LAYERS AND SELECTIONS
When learning Photoshop, you will often encounter the terms layer and
selection before they are discussed in detail. When first learning how to edit
digital photos you can safely ignore these terms because all commands affect
the entire digital photo when you first open it. However, if you add layers or
make a selection, the effect of many commands are limited to just areas of
the image. Here is an advance look at what these two terms mean.

■ Layers (page 104) are like panes of glass laid over an image to make
adjustments, add type, draw shapes, or copy one image into another. If you
want to delete the effects a layer has on the image beneath it, you just delete
the layer. The image itself remains unaffected.

■ Selection (page 86) refers to using tools to draw a selection border around
one or more areas in an image. When you first open an image no areas are
selected so the effects of commands are not restricted to a specific area.

CANCELLING AN OPERATION
Some of the operations that you perform on an image take time, and when
the operation is in progress, you can’t perform other tasks. You can keep
track of its progress by checking the progress bar on the status bar at the
bottom of the screen. To have a beep alert you when a process is complete,
select Edit>Preferences>General, and turn on the Beep When Done check
box. To cancel process before it has finished, hold down Esc.

MENUS
Photoshop has a variety of menus you use to execute commands.

■ Menu bar at the top of the work area lists names of menus that pull down
to list commands. In this book we use the style “....choose Image> Adjust-
ments> Levels” to guide you through the menu commands. In this example,
the first name in the sequence, Image, is the name of a menu on the menu
bar. After clicking that menu name, you then click the second command,
Adjustments, to display a submenu displaying the Levels command that you
click to display a dialog box.

■ Drop-down or pop-up menus are displayed when you click drop-down
arrows or triangle icons on the options bar, in dialog boxes, or on palettes.

■ Context-sensitive menus or palettes appear when you right-click in the
image window. What menu appears depends on what tool is selected.

■ Palette menus are displayed when you click a palette’s triangle icon.

KEYBOARD SHORTCUTS
In some cases, you have to work through 2 or 3 menus to get to the setting
you want. When learning the program, or when only a casual user, this is a
good way to work because it’s easier to remember how to do things. How-
ever, there is a much faster way to work that you can adopt over time. As you

TIP

■ The Preview
check box in many
dialog boxes, when
on, lets you see the
effects of your
changes.

TIPS

■■■■■ To adjust the
entire image, make
sure nothing is
selected (page 86).

■■■■■ To adjust only a
single layer, select
that layer in the
Layers palette
(page 105).

■■■■■ To adjust just a
portion of your
image, select that
portion (page 86).

Icons that indicate drop-
down or pop-up menus
are always triangular.

BASIC COMMANDS

TIP

■ When you point
to a label for a text
box containing a
value the mouse
pointer changes to
indicate you can
drag left or right to
change the value.
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work through menu commands, you’ll see that some command names are
followed by keyboard shortcuts such as Alt+Ctrl+Z to undo changes. The plus
signs connecting the keys means you press them together, not one after
another. Pressing these shortcut keys bypasses the menus. To work faster,
begin by memorizing the keyboard shortcuts for the commands you use most
often.

MODIFIER KEYS
In many situations, tools work one way when you use them alone and an-
other way when you hold down a key as you use them. These modifier keys
on PCs include Ctrl, Shift, and Alt; and on Macs, Command, Shift and
Options.

■ When keys are used in combination, they are shown connected by a plus
sign. For example, Shift+Ctrl+Alt.

■ When a key should be held down when you click or drag the mouse, it is
indicated by +click added to the key as in Alt+click or Alt+drag.

■ At times, when you press a key is important. For example, you may need
to start dragging and then press a key. Pressing it before you drag won’t have
the same result.

DIALOG BOXES
When you select many commands, particularly menu commands followed by
an ellipsis (...), a dialog box is displayed. Although some dialog boxes have
many settings, in most cases you’ll probably only adjust a few. The rest can
be left set to the defaults that Adobe has chosen because they work with most
images, most times.

■ To select the entire entry in a text box, click in the text box and press
Shift+Enter.

■ To increment the value in numeric text boxes:

● Click in the text box then press the up or down arrow keys to change the
value in increments of 1, or hold down Shift while you press the arrow keys
to increment the value in steps of 10.

● Point to the title of the box and drag left or right to change the value in
the box just as if you were dragging a slider.

■ To display menus, click the drop-down arrows or triangle buttons.

■ To turn square check boxes and round option buttons (sometimes called
radio buttons) on and off, click them.

■ To move between text boxes, when the cursor is already in one text box,
press Tab or Shift+Tab.

■ To close a dialog box without applying your adjustments to the image,
click Cancel. Hold down Alt and the button often changes to Reset so you can
click it to restore the default settings and try again.

■ To see the effects of your changes as you make them, turn on the Preview
check box. Sometimes, clicking the check box on or off, or even clicking the
preview itself, toggles the change on and off so you can see it more clearly.

■ To apply your changes to the image and close the dialog box, click OK.

TIPS

■ Ctrl on PCs often
performs the same
functions as
Command (key
with symbol) on
Macs.

■ Alt on PCs
performs the same
functions as Option
on Macs.

■ Enter on PCs
performs the same
role as Return on
Macs.

Dialog boxes can appear
complicated because
they offer so many
choices. In most cases,
however, you need to
change only a few
settings and leave the
others set to their
default values.

Many tools are adjusted
by dragging sliders
along a slider bar.
Sometimes you can
point to the name of the
slider and drag to
change the setting.

When you see a Cancel
button in a dialog box,
hold down Alt to see if it
changes to a Reset
button that lets you
start over.
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UNDOING CHANGES

One of the most reassuring things about editing images is how many ways
there are to undo mistakes short of closing a file without saving it.

UNDO COMMANDS
■ The Edit>Undo... command undoes the most recent change and
Edit>Redo... redoes it.

■ The Edit>Step Forward and Edit>Step Backward commands scroll
through changes so you can select a stage from which to continue.

■ The File>Revert command restores the image to the last saved version.
This is the same as closing the file without saving it and then reopening it.

THE HISTORY PALETTE
The History palette, displayed by selecting Window>History, lists both states
and snapshots that you can use to undo changes:

■ States are changes you have made to the image. They are added to the
history palette automatically as you make them, with the most recent change
at the bottom of the list. By default, up to the last 20 changes made in the
current session are listed.

■ Snapshots can be taken to record an image exactly as it is at any point. By
default, a snapshot of the original image is displayed at the top of the
palette, but you can take others. Snapshots have a number of advantages:

● You can name a snapshot so it’s easy to identify.

● Snapshots are stored for an entire work session.

● If you take snapshots before and after a procedure you can switch back
and forth between them to more easily see the changes.

You can delete any changes and restore the image to a previous state by
deleting states or selecting a snapshot. It’s as if you backed up to a previous
point to start over from there.

■ To take a snapshot of the image, click the palette’s Create New Snapshot
button or select New Snapshot from the palette menu.

■ To select a state or snapshot, click it or drag the slider to it.

■ To delete a state or snapshot, and all states that follow, select it and click
the Trash can icon, drag and drop it on the icon, or select it and then choose
Delete from the palette menu. (If you don’t like the results, select
Edit>Undo.)

■ To return to the image as it was when you took a snapshot, select the
snapshot to undo all changes that followed it.

■ To delete a state or select a snapshot without deleting all states that
follow, display the palette’s menu, select History Options and turn on Allow
Non-Linear History.

■ To clear all states, without undoing the changes they represent, display the
palette’s menu and select Clear History. This cannot be undone.

■ To create a new document from the selected state or snapshot, drag it
onto the Create new document from current state button.

The History palette
displays a list of the
changes you made to
the image in the current
session.

TIP

■ It’s important to
note that the undo
command and
history palette only
undo changes
made during the
current session.
Once you close an
image and reopen
it, you can no
longer undo
changes. To be sure
you don’t irrevoca-
bly change an
image, always work
on a copy, not the
original. To be able
to undo changes at
a later date, use
adjustment layers
(page 116) and
layer masks (page
150).

The History Options
dialog box.

Right-clicking a state
displays a menu.

UNDOING CHANGES
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Your digital camera (or scanner) stores images in files that are then
copied to the computer for editing. As your collection grows, managing
images so you can find them later becomes very important. To assist

you, Photoshop has a File Browser that displays thumbnails of images and
lets you manage the collection using features such as keywords, ranking,
flagging, and sorting. In this chapter you learn how to use the File Browser
and other methods to organize, view, open, print and save images. These are
important procedures that support the main functions of a photo-editing
program—editing and improving images—discussed in the chapters that
follow.

Chapter 2
Working with Image Files

CONTENTS

 ■ Opening and Closing
Image Files ■ The File
Browser—Introduction ■
The File Browser—
Viewing, Opening &
Managing Files ■ The File
Browser—Organizing and
Finding Files ■ The File
Browser—The Metadata
Palette ■ Zooming
Images and Image
Windows ■ Working with
Multiple Images ■ Saving
Image Files ■ Printing
Images ■ Optimizing
Images for the Web
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OPENING AND CLOSING IMAGE FILES

To work on an image the first step is to open it. To be safe, always open a
duplicate of the image rather than the original so if anything goes wrong, you
haven’t permanently altered or lost the image. If you haven’t already made a
copy to work on, one way to do so is to open the image, then immediately
save it in the Photoshop (PSD) format with the File>Save As command (page
35). This ensures that you are working on a duplicate image in a format that
preserves all of the file’s characteristics. Repeatedly opening, saving, and
closing JPEG images degrades them slightly each time.

OPENING IMAGE FILES
You can open an image file by selecting File>Open to display the Open dialog
box where you select a file and then click the Open button. The dialog box
offers the following settings:

1. Look in displays the name of the selected folder. Click its drop-down
arrow to display a tree so you can select another drive or folder. Buttons to
the right include Go To Last Folder Visited, Up One Level, Create New
Folder, View Menu, and off to the right, Favorites. (Point to any button
except Favorites, to display its name.)

2. File area displays files in the selected folder. Since most image filenames
are meaningless, you can click the View Menu drop-down arrow and click the
Thumbnails command to see what each image looks like.

TIPS

■ To change the
displayed size of
the photo you’re
editing (not its
actual size), hold
down Ctrl and
press the plus (+)
and minus (-) keys
on the numeric
keypad.

■ When editing an
image, are you
working on a copy?
If not, immediately
save the image in
the Photoshop PSD
format using the
File>Save As
command.

When opening an
image, you may see an
Embedded Profile
Mismatch dialog box.
This box is explained on
page 185.

Clicking the Favorites
button displays a menu
you use to add, remove,
or jump to favorite
folders.

The Open dialog box
buttons include Go To
Last Folder Visited, Up
One Level, Create New
Folder, View Menu, and
Favorites.

OPENING AND CLOSING IMAGE FILES
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CLOSING IMAGE FILES
When you are finished with an image file, you close it. When you do so
without first saving it, you will be asked if you want to save it. Click Yes to
save the file or No to close the file without saving it. Closing a file without
saving it is a good way to abandon any changes you don’t want to keep.

■ To close the active image, click the close (X) button on its window or select
File>Close from the main menu.

■ To close all images, select File>Close All from the main menu.

3. File name text box displays the name of the file that will open when you
click the Open button. Click any image file to enter its name in this box or
click the drop-down arrow to select from a list of the most recently opened
files.

4. Files of type is normally set to All Formats so all files are displayed. To
list just those files in a specific format, click the drop-down arrow and select
a file type.

5. Thumbnail of the selected file, and it’s file size, is displayed at the bottom
of the dialog box when you select a file and pause a moment.

After opening a file and then closing it, you can reopen it by selecting
File>Open Recent to display a list of the 10 files you have worked with most
recently. You can change the number of files listed on the menu by choosing
Edit>Preferences>File Handling.

Keyboard commands
can select any
groupings of files to
open.

TIP

■ One way to open
a group of image
files is to select
them in Windows
Explorer and drag
them to the
Photoshop icon on
the task bar. If you
then pause a
moment, the
program opens and
you can drop them
into the working
area. SELECTING MULTIPLE FILES

Whenever a dialog box opens for you to select files, you can select more
than one file so they open together. Many of these procedures work in
combination with each other.

■ To select or unselect a single file, click it.

■ To select or unselect multiple files, click the first then hold down Ctrl
while you click other files to select or unselect them.

■ To select a series of consecutive files, click the first image in the series
and hold down Shift when you click the last.

■ To select more than one set of consecutive files, click the first image in
the first set and hold down Shift when you click the last image in that set.
Then, hold down Ctrl to select the first image in the second set, and
Ctrl+Shift while you click the last image in that set.

The dialog box that
appears when you close
a file with unsaved
changes.

Icons on image
windows include (from
left to right) Minimize,
Restore Up/Down,
Maximize, and Close.
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The File Browser window is divided into several sections.

1. Toolbar lists menus and shortcut buttons used to work with your files.

2. Palette triangle icons display a palette’s menu when clicked.

3. Palettes, of which there are four, are used to navigate through the folders
on your computer (Folders), view enlarged thumbnails (Preview), view
information embedded in image files (Metadata), and search for files (Key-
words).

4. Toggle Expanded View double arrow button hides or displays the palette
area.

5. The main window displays thumbnails of images in the selected folder.

6. Location bar displays the current folder and its drop-down arrow lets you
select other folders including favorites.

7. Show drop-down arrow lets you specify if flagged images, unflagged
images, or both (the default) are displayed in the main window (page 29).

You can adjust the size of various sections, perhaps to make the Preview
palette display thumbnails almost full-screen. You can also dock palettes, and
minimize or maximize them just as with other palettes. You cannot, however,
move palettes outside of the palette area. Photoshop remembers any changes
until you change them again. To prevent this, save the original workspace
(page 10) before making changes. You can then save other workspaces with
different File Browser setups and switch among the original and customized
layouts with the Window>Workspace command.

The Toggle File Browser
button is to the left of
the palette well on the
options bar.

THE FILE BROWSER—INTRODUCTION

The File Browser makes it easy to locate, view, select, open and manage your
images. To display the File Browser, click the Toggle File Browser button on
the options bar or select Window>File Browser or File>Browse from the
main menu.

TIPS

■ File Browser
uses an area on the
hard disc called a
cache to store
thumbnail and file
information. If
your system slows
down or you need
additional
memory, you can
purge the cache
(page 12).

■ When the File
Browser is open,
two menus are
displayed. To avoid
confusion we refer
to them as
Photoshop’s main
menu and the File
Browser menu.

THE FILE BROWSER—INTRODUCTION

The File Browser
shortcut buttons include
(left to right) Rotate
Counter-clock Wise,
Rotate Clock Wise, Flag,
Search, and Delete File.
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THE FILE BROWSER—VIEWING, OPENING & MANAGING FILES

When you select a folder in the File Browser’s Folders palette, the contents of
the folder are displayed in the main window. When you then select an image
in the main window, a preview of it is shown in the Preview palette and
information about it is displayed in the Metadata and Keywords palette.

VIEWING FOLDERS AND IMAGES
The File Browser’s View menu lists a number of commands that specify how
files are displayed. (The main menu also has a View menu that list different
commands.)

■ To show or hide subfolders in the main window along with files, select
View>Folders. Double-clicking any displayed folder then opens it.

■ To view files that Photoshop can’t open (spreadsheets, for example), select
View>Unreadable Files.

■ To select the selected folder in Windows Explorer, choose View>Reveal
Location in Explorer.

■ To refresh the view to be sure you have the most recent list of images and
folders after adding, deleting, or renaming files or folders, choose
View>Refresh. Closing and reopening the File Browser also refreshes the
view.

■ To change the view, select one of the thumbnail sizes or Details from the
View menu.

SELECTING AND OPENING IMAGES
The File Browser makes it easy to select and open one or more image files
just by opening a folder and then pointing and clicking.

■ To select files in the File Browser’s main window, do any of the following:

● Click the thumbnail of a file. (Clicking the name selects it so you can
rename the file.)

● Shift+click to select contiguous images.

● Ctrl+click to select noncontinuous images.

● Choose Edit>Select All from the File Browser menu bar to select all of
the files in the current folder.

■ To open the selected file(s) in the File Browser’s main window, do one of
the following:

● Press Enter.

● Double-click any one of the selected files to open all of them.

● Select Open from the palette menu.

MANAGING IMAGES
You use the File Browser’s Folders palette and File and Edit menus to
manage your image files. (The main menu also has File and Edit menus that
list different commands from those discussed here.)

File Browser’s View
menu.

TIPS

■ Once you have
the File Browser
arranged the way
you like it, you can
save the layout by
saving the
workspace (page
10).

■ If you return to
the same folder
repeatedly, you’ll
save time by
making it a favorite
folder (page 29)

HTTP://WWW.PHOTOCOURSE.COM
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Many commands are
available when you
select one or more
images and right-click
the selection to display
the context menu.

■ To create a new folder, select the drive or folder in which you want to
create it, then select File>New Folder, type a name, and press Enter.

■ To delete files or empty folders, select them and then click the Trash
button on the toolbar, drag and drop them on Trash button, press the Delete
key, or select File>Delete.

■ To copy files, select them and then Alt+drag them to the same or a differ-
ent folder.

■ To move files, select them and then drag them to a different folder.

■ To attach an image to an e-mail message, drag the image from the File
Browser and drop it into the e-mail message.

■ To rotate files, select one or more and then click the rotation buttons or
select Edit>Rotate and select one of the rotate commands. These commands
only rotate an image in Photoshop. To have the rotation also apply when the
image is opened in other applications, such as a slide show program or Web
browser, open the rotated image in Photoshop and save it, or select
Edit>Apply Rotation from the File Browser menu.

■ To rename a file or folder select it and then click its filename, or right-click
the file or folder to display the context menu, then choose Rename. Type a
new name, and press Enter. To display the next filename for editing, press
Tab. To display the previous filename for editing, press Shift+Tab.

The File Browser’s
Preview window can be
enlarged to fill most of
the screen just by
dragging borders.

If a thumbnail in the File
Browser has a lock icon,
it means the image is
read-only and can’t be
edited. To change this,
you use Windows
Explorer to change its
properties.

THE FILE BROWSER—VIEWING, OPENING & MANAGING FILES

The File Browser
shortcut buttons include
Rotate Counter-clock
Wise (far left) and
Rotate Clock Wise
(second from left).
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THE FILE BROWSER—ORGANIZING AND FINDING FILES

As your collection of photos gets larger it becomes harder to find the images
you want to edit or print. To help, the File Browser offers you a variety of
ways to manage your collection. The more images you have, the more impor-
tant these tools become.

WORKING WITH KEYWORDS
The Keyword palette lets you attach keywords to image files and locate them
later by searching for the keywords. Unlike techniques discussed later in this
section, these keywords travel with the file you attach them to so they can be
used by others to whom you distribute images. Keywords are organized into
sets and you can assign individual keywords or entire sets to one or more
selected files. Although Photoshop comes with a few keywords listed in the
Keywords palette, the chances are that eventually you will want to create you
own. To begin, with File Browser displayed, click the tab for the Keywords
palette.

■ To expand or collapse a set of keywords, click the triangle to its left.

■ To attach or detach a keyword or keyword set to or from selected files,
click the box to the left of the keyword or keyword set in the palette, or
double-click the keyword or keyword set. A check mark is displayed in the
box next to any keywords added to a file that’s been selected.

■ To add a new keyword to a set, select the set’s heading marked with a
triangle or select any keyword in the set, and then click the New Keyword
button, type the keyword, and then click OK. (You can also right-click the
selected set or display the palette menu and select New Keyword.)

■ To create a new keyword set, click the New Keyword Set button, type the
name of the set, and then click OK. (You can also right-click the selected set
or display the palette menu and select New Keyword Set.)

■ To rename a keyword or set, select it then click the palette’s triangle icon
(not a set’s triangle icon) to display the palette menu. Select Rename on the
menu and type a new name. The previous keyword remains attached to files
and doesn’t change automatically. However, it is listed in a set named <Other
Keywords>. To attach the renamed keyword to images, you have to select the
images and then click the box to the left of the keyword.

■ To move a keyword to another set, drag and drop it there.

■ To delete a keyword, select it by clicking its name, and then click the
Delete Keyword button. The deleted keyword remains attached to the files to
which it is attached and is listed in a set named <Other Keywords>.

SORTING FILES
The File Browser’s Sort menu lets you sort files in a variety of ways, for
example, by filename, rank, size and type. To sort in ascending or descending
order select Sort>Ascending Order as needed. A check mark indicates that
files are sorted in ascending order. No check mark indicates that the current
sort is in descending order.

File Browser’s Sort
menu.

To manage keywords,
use the New Keyword
Set, New Keyword, or
Delete Keyword buttons
at the bottom of the
palette (bottom) or click
the palette’s triangle to
display its menu (top).

The File Browser’s
Keywords palette.

A triangle indicates if a
set of keywords is
collapsed (left) or
expanded (right).
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RANKING FILES
Ranking files lets you use your own criteria to sort files. For example, you
can rank files as A, B, or C to indicate three levels of interest and then sort
the images by those ranks so the most important files are listed first.

■ To rank one file, click the Rank text box below the image thumbnail,
type a rank containing letters or numbers, and press Enter, or to assign a
rank to the next or previous image, press Tab or Shift+Tab. To edit a rank,
use this same procedure. If the rank box isn’t displayed, choose View>
Show Rank from the File Browser menu bar (View>Large Thumbnail
must be selected to access the command.)

■ To rank more than one file, select them, then choose Edit>Rank from
the File Browser menu, enter a rank, and press Enter.

■ To sort by rank, choose Sort>Rank.

■ To clear rankings, select the files and then choose Edit>Clear Ranking.
If prompted to confirm the removal of rankings, click Yes.

FLAGGING FILES
Flagging is a fast way to separate out a few important files. For example,
when downloading and reviewing new images, you can flag those you want
to keep or use first. You can then use the Show menu to display just
flagged, unflagged, or both (the default).

■ To flag or unflag files, select the files and click the Flag File button on
the toolbar or right right-click one of the files and select Flag from the
context menu. When flagged, a flag icon is displayed at the bottomright of
the thumbnail.

■ To specify how flagged files are displayed, click the Show drop-down
arrow or select View>Flagged Files from the File Browser menu and select
Flagged and Unflagged (the default), Flagged Files, or Unflagged Files.

USING FAVORITE FOLDERS
If you use a folder frequently, you can use the File Browser’s File menu to
add it to a list of favorite folders so you can switch to it more quickly.

■ To add a selected folder to Favorites, select File>Add Folder to Favor-
ites. You can also right-click the folder and select the same command from
the context menu. The folder is listed in the Folders palette under a new
heading Favorite Folders marked with a gold star, and on the Location
drop-down menu under the heading Favorite Folders.

■ To jump to a favorite folder, click its name in the Folders palette, or
click the Location bar’s drop-down arrow and it will be listed under the
Favorites section heading. There is also a Favorites button on the Open
dialog box displayed with the main menu’s File>Open command.

■ To remove a folder from Favorites, select the folder in the Folders
palette under the heading Favorite Folders and select File>Remove Folder
from Favorites. You can also right-click the folder and select the same
command from the context menu.

File Browser’s Flag icon.

TIPS

■ You can’t add
keywords to open
files.

■ Purging the
cache (page 12)
deletes ranking,
flag, and thumbnail
information.

■ To add copyright
notices to your
images see the
Metadata palette
(page 30).

The Location menu lists
a tree you can navigate
through or favorite and
recent folders you can
jump to directly.

The Show menu.

THE FILE BROWSER—ORGANIZING AND FINDING FILES
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■ Look in displays the currently active folder. Click the Browse button to
navigate to any folder you want to search. The drop-down arrow lists selected
folders and the Results folder.

■ Include all Subfolders check box, when on, expands the search into any
subfolders stored in the Look in folder.

■ Criteria drop-down arrows let you specify criteria for your search:

● Select what you want to search for from the leftmost menu.

● Select a limiter from the center menu. The choices here depend on what
you selected to search for.

● Enter text in the text box at the right, if needed.

● To add another search criteria, click the plus sign button.

● To remove a search criteria, click the minus sign button.

■ Search button initiates the search and adds a Search Results folder at the
bottom of the tree in the Folders palette. Images that match the criteria are
displayed in the main window when that folder is selected. To return to your
original view, select the folder that you searched.

ADDING A COPYRIGHT NOTICE
To add a copyright notice to your image, you first create a template and then
apply it to selected images.

■ To create a copyright template, select a photo in the File Browser, then
choose File>File Info from the File Browser menu to display the File Info
dialog box with Description highlighted.

● Copyright Status drop-down arrow lets you select Copyrighted.

● Copyright Notice text box is where you type in your name and any other
information you’d like to be able to apply to all your images.

● Copyright Info URL text box is where you can enter your Web address.

● Triangle icon in the upperright corner of the dialog box displays a menu
so you can select Save Metadata Template. Enter a name for the template,
and then click OK. Click OK to close the File Info dialog box.

■ To apply the copyright information to other images, select them in the
File Browser, and then select File>File Info from the File Browser menu.
Click the triangle icon and select the copyright template name listed at the
top of the menu. The copyright information is automatically filled in for you
in the File Info dialog box. Click OK to apply it to the selected images. It’s
listed in the IPTC section of the Metadata palette.

The limiters you can use
depend on what it is
you are searching for.
These are for File Name.

SEARCHING FOR FILES
You can search for files using up to 12 search criteria. To begin, choose
File>Search from the File Browser’s menu to display the Search dialog box.
(You can also use the Search command on the Keywords palette menu.)

The File Info dialog box.

The criteria you can
search for range from
file names to metadata.
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VIEWING AND EDITING METADATA
■ To view metadata just select a file. If more than one file is selected, only
the metadata that is common to all of the files is displayed.

■ To expand or collapse categories, click the triangles in the headings.

■ To add or edit IPTC metadata, click the pencil icon to the left of the field
you want to edit, and type in the text box. Press Tab to move through fields
and when finished, click the palette’s Apply button (the check mark).

■ To customize your view of metadata select Metadata Display Options
from the Metadata palette menu or from the File Browser’s Edit menu. In the
Metadata Display Options dialog box, select or deselect metadata fields you’d
like to view or hide. Select the Hide empty fields option if you don’t want to
view fields containing no information. When you’re done, click OK.

THE FILE BROWSER—THE METADATA PALETTE

The File Browser’s Metadata palette displays all information attached to a
selected image file. Metadata is data (information) about data (an image file).

TYPE OF INFORMATION
Metadata information is listed under a number of headings with triangle
icons that you click to collapse or expand. The categories include the follow-
ing:

■ File Properties describes such characteristics as size, creation, and modifi-
cation dates.

■ IPTC, the only category of editable metadata, lets you add a caption for
your files, as well as copyright information (page 30). This information is
attached to the image file and travels with it.

■ Camera Data (Exif) is added when you capture a photo and includes
information about the camera settings used to capture it.

■ GPS displays navigational information captured with a digital camera
equipped with GPS technology.

■ Camera Raw displays information about files in the Camera Raw format.

■ Edit History displays a list of changes made to images perhaps for your
records, client records, or legal purposes.

You can specify what
metadata are displayed
using the Metadata
display options dialog
box.

The Metadata palette
menu.

A triangle indicates if a
metadata category is
collapsed (left) or
expanded (right).

The IPTC Metadata
palette’s Cancel and
Apply buttons.

THE FILE BROWSER—THE METADATA PALETTE
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ZOOMING IMAGES AND IMAGE WINDOWS

When you open a digital photo, the image appears in a window that Adobe
calls a document window. While editing, you can zoom both the photo and
its window, rearrange windows, and scroll around enlarged images to
examine details or make precise selections. You can zoom the size at which a
photo is displayed a number of ways. The window’s title bar displays the
zoom percentage (unless the window is too small for the display to fit), as
does the status bar.

■ Keyboard shortcuts include holding down Ctrl while pressing the plus (+)
and minus (-) keys on the numeric keypad. Normally, when you press them
to zoom an image, the image’s window doesn’t automatically change size. To
make it do so, select Edit>Preferences>General and turn on the Zoom
Resizes Windows check box.

■ Buttons in the upperright corner of application and image windows size
or close windows or applications.

■ The View menu lists commands that zoom the image.

■ The Zoom tool quickly zooms an image up or down. To use it, click it in the
toolbox, change its settings on the options bar, then click in the image to
zoom it up to 1600%.

● Zoom In and Zoom Out buttons (to the right of the tool preset picker)
specify the direction of zoom.

● Resize Windows To Fit check box, when on, resizes the window when
you magnify or reduce the view of the image with the Zoom tool. (It has no
effect with keyboard shortcuts.) When off, the window maintains a con-
stant size regardless of the image’s zoom.

● Ignore Palettes check box, when on, allows an image window to enlarge
under any palettes close to the right edge of the screen. When off, some
commands won’t enlarge a window past these palettes.

● Zoom All Windows zooms all open images by the same amount when
you zoom any one of them.

● Actual Pixels, Fit On Screen, and Print Size buttons zoom the image to
the indicated sizes. (These choices are also available when you select the
Hand tool to scroll an enlarged image.)

■ The Navigator palette zooms and navigates the image. To display it, select
Window>Navigator.

The Navigator palette
displays a red view box
outlining the area
displayed on the
screen. You can drag
the box to scroll around
the enlarged image.

The View menu lists
zoom commands and
their keyboard
shortcuts.

Icons on image
windows include (from
left to right) Minimize,
Restore Up/Down,
Maximize, and Close.

The Zoom tool displays
Zoom In and Zoom Out
buttons on the options
bar.
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ZOOMING AN IMAGE
■ To zoom the image incrementally:

● Hold down Ctrl and press the plus (+) or minus (-) key on the numeric
keypad.

● Drag the slider in the Navigator palette or click the zoom buttons.

● Select the Zoom tool and then the Zoom in button on the options bar.
Drag over the area you want to zoom. The area inside the zoom marquee is
displayed full-screen when you release the mouse button. After selecting
an area you can move the selection border if you don’t release the mouse
button while you hold down the spacebar and drag.

● Select the Zoom tool, click the Zoom in or Zoom out buttons on the
options bar, then click the center of the area you want to size. When the
maximum (1600%) or minimum (1 pixel) zoom limit is reached, the + or -
in the magnifying glass disappears. To switch between zooming in and
zooming out without clicking the options bar, hold down Alt.

● Select View>Zoom In or View>Zoom Out. When a limit of zoom is
reached, the command is dimmed.

■ To zoom the image to a specific percentage, type the percentage into the
Zoom text box on the status bar or in the Navigator palette and press Enter.

■ To zoom the image to its actual pixel size (100%), so you can see what it
will actually look like when displayed on a monitor just like yours:

● Double-click the zoom tool.

● Select the Zoom or Hand tool and click the Actual Pixels button on the
options bar.

● Select View>Actual Pixels (Alt+Ctrl+0).

● Type 100% into the Zoom text box on the status bar or in the Navigator
palette and press Enter.

■ To enlarge the image to fill the screen:

● Double-click the hand tool.

● Select the Hand or Zoom tool and click the Fit On Screen button on the
options bar.

● Select View>Fit on Screen.

■ To zoom to the approximate printed size, as specified in the Document
Size section of the Image Size dialog box (page 51).

● Select the Zoom tool, click the Print Size button on the options bar.

● Select View>Print Size.

SCROLLING AROUND AN ENLARGED IMAGE
When the image is zoomed larger than its window, you can scroll around it.

■ Select the Hand tool and drag the image. To use the Hand tool while
another tool is selected, hold down the spacebar as you drag the image.

■ Use the window scroll bars.

■ Display the Navigator palette (page 32) and drag the red view box or click
anywhere in the thumbnail to center the view box on that point.

TIPS

■ When the Zoom
or Hand tool is
selected, right-click
in the image area
and select a zoom
setting from the
context menu.

■ The Zoom tool
pointer is shaped
like a magnifying
glass. The + or -
indicates the
direction of zoom.
When neither is
displayed, you have
reached one of the
limits.

TIP

■ Colors are
displayed most
accurately when an
image is displayed
at its actual size
(100%). You
should use this
setting when
making correc-
tions.

The toolbox has three
icons that change the
screen mode when an
image is open. From left
to right they are
Standard Screen Mode,
Full Screen Mode with
Menu Bar, and Full
Screen Mode.

ZOOMING IMAGES AND IMAGE WINDOWS
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WORKING WITH MULTIPLE IMAGES

You can open a number of different images when you want to edit, print or
compare them. But that isn’t the only reason to have more than one image
window open. One important reason is to have two views of the same image
at different levels of zoom. Another is to have two copies of the same image—
one edited and the other unedited.

TWO VIEWS OF THE SAME IMAGE
Having two views of the same image lets you see it at two levels of magnifica-
tion. For example, you can have one view zoomed to a high magnification to
work on a detail while the other view shows the effects of your changes on the
image displayed at its actual size (100%). Editing changes made to either
view are reflected in both windows because both display the same image. To
open multiple views of the same image, select Window>Arrange> New
Window for (filename).

DUPLICATING AN IMAGE
Making a duplicate image and then closing the original is one way to ensure
the original isn’t changed. However, duplicating an image also lets you
experiment with and compare before and after versions as you make
changes. The changes made to one copy don’t affect the other so it’s easier to
see the effects of your changes. To duplicate an image choose
Image>Duplicate to display the Duplicate Image dialog box. Enter a name
for the duplicated image and click OK. Although named, the duplicate image
isn’t saved unless you use the File>Save command.

ARRANGING MULTIPLE IMAGES
When two or more windows are open at the same time, you can size and drag
them as needed or select Window>Arrange to display a submenu, then
select one of the following commands:

■ Tile displays windows side by side.

■ Cascade displays overlapping windows cascading down and across the
screen.

SELECTING WINDOWS
When there is more than one image open, the title bar of the active window is
a darker blue. You can quickly switch between or among images by pressing
Ctrl+Tab, or by pulling down the Window menu and selecting one of the
images listed at the bottom of the menu.

Tiled windows (left) and
cascaded windows
(right).

The Duplicate Image
dialog box.

TIPS

■ The Zoom and
Hand tools have
options that let you
zoom or move all
windows when you
zoom or move one.

■ When duplicate
images are zoomed
to the same size,
rapidly pressing
Ctrl+Tab repeat-
edly makes them
flash by and any
changes jump out
at you.

When working with
multiple images,
commands on the View
menu match their
zooms, locations, or
both. After selecting one
of the commands,
Shift+click in one of the
images to match their
zooms or locations.
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SAVING IMAGE FILES

When saving image files, there are a few basic rules that make your life easier
and less anxious:

■ Always work on a copy and not the original. If you open an original image
to edit it, your very first step should be to save it in a new folder, under a new
name, or in a new format (ideally PSD) so you don’t inadvertently overwrite
the original file later.

■ Save your working copy in Photoshop’s native (PSD) format. This format
ensures that all of the image data are saved.

■ Save the final copy in a format fit to it’s purpose. Different file formats
cater to the needs of different applications. The file format you choose
depends on the content of your image and how you plan to use it. For ex-
ample, if you’re saving a digital photo for use on the Web, you should choose
the JPEG format. If you are going to make a print from the image, save it in
PSD format. If you are moving the image to another application such as a
desktop publishing program, you might save it as a TIFF file or even leave it
in the PSD format if the application supports that format.

THE SAVE COMMAND
The main menu’s File>Save command saves changes you’ve made to an
image using the file’s original format. If you use this command to save a new
file that hasn’t been saved before, or to which certain adjustments have been
made, the Save As dialog box described below appears. The problem with
using this command to save a JPEG image is that each time you close,
reopen, and resave a JPEG file, it is compressed again—gradually reducing its
quality over time. It’s best to first save the image in PSD format with the
File>Save As command and then use this command to save that file when-
ever you want. PSD files aren’t compressed.

THE SAVE AS COMMAND
The File>Save As command displays the Save As dialog box where you can
specify a location, filename, and format when you save a file. In the dialog
box, select one or more of the following options although not all are available
for all formats:

■ Save in displays the name of the folder in which the file will be saved. To
select another folder, click the drop-down arrow and the four buttons to the
right—Go to Last Folder Visited, Up One Level, Create New Folder, and
View Menu.

■ File name text box displays the current filename and is where you can type
a new one. (The drop-down arrow displays recently used names.) If you enter
a name that’s already assigned to another file in the same folder, you will be
asked if you want to replace it when you save the file.

■ Format drop-down arrow displays a list of formats in which to save the
image. The image’s current format is selected and selecting any other con-
verts the saved file to that format. The list of formats is significantly shorter
when saving 16-bit images such as those captured in the RAW format (page
80).

TIPS

■ The Save for
Web command is
discussed on page
43).

■ To save an image
that arrives by e-
mail or that you see
on a Web page,
right-click it to
display a menu
with a save com-
mand.

■ When working
on a JPEG image
you can save it
repeatedly during a
session without
affecting its
quality. It’s only
compressed once,
when you close it.

SAVING IMAGE FILES

The Save As command
lets you specify a
format for the file.
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■ Save Options section has a number of check boxes. The most important, As
a Copy saves a copy of the image with the settings you changed while keeping
the original file unchanged. Layers preserves all layers in the image (page
104). If this option is dimmed, the image has no layers or the format you have
chosen doesn’t save them. If you choose a format that won’t save all of the
image's features, a warning is displayed at the bottom of the dialog box. If
you see this warning, you may want to select another format such as PSD that
saves all of the image data.

■ Color has a check box for ICC Profile and, when on, the listed color profile
is saved in the image. The other choice, Use Proof Setup, is used in conjunc-
tion with the View>Proof Setup and is outside the scope of this book.

■ Thumbnail check box indicates if a thumbnail image is saved in the image
file. This check box is only available if you set Image Previews to Ask When
Saving on the Edit>Preferences>File Handling menu.

■ Use Lower Case Extensions check box, when on, makes the file’s extension
lowercase.

■ Save button completes the save using the current settings. With some
image formats, clicking this button displays a format specific dialog box. In
the following pages we discuss the most common formats—JPEG, PSD, and
TIFF. To learn more about other formats use help.

TIP

■ UNIX file
servers, widely
used on the Web,
do not always
recognize upper-
case extensions. To
ensure that your
images are trans-
ferred properly, use
lower case exten-
sions.

If you choose a format
that does not support all
of the data in an image,
this warning icon is
displayed. To save all of
your data, be sure to
save one copy in
Photoshop’s PSD
format.

The Save As dialog box
lets you save an image
in a variety of formats.
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■ Matte selects a background color for an image with transparent areas
(page 134). If there are no transparent areas, the option is dimmed.

■ Quality sets the amount of compression used between 1 (highest compres-
sion, lowest quality) and 12 (lowest compression, highest quality). To change
the setting, click the drop-down arrow, drag the slider, or type a value
between 1 and 12 into the text box.

■ Format Options section includes the following option buttons:

● Baseline (“Standard”) creates images recognizable to most Web brows-
ers.

● Baseline Optimized optimizes the image’s color and creates a slightly
smaller file that is not recognized by all Web browsers.

● Progressive creates an image that displays itself in a Web browser in
steps, the number of which you specify in the Scans text box. When
displayed in a browser the image appears first as a low-resolution image
and then gradually gets sharper and more detailed as additional scans
arrive. Files are slightly larger and are not recognized by all Web browsers
and other applications.

■ Size lists the size of the file. When the Preview check box is on you can also
click the drop-down arrow and select the speed of any Internet connection to
see an estimated download time for the image.

TIP

■ You occasionally
encounter refer-
ences to transpar-
ent areas in an
image. Digital
photos don’t have
such areas unless
you add layers
(page 104) and
then cut holes
through them or
erase areas to show
the layers below.

The JPEG Options dialog
box lets you specify how
much the image is
compressed.

SAVING PSD IMAGES
When you save an image in Photoshop’s native PSD format, the file is saved
without displaying an additional dialog box.

SAVING JPEG IMAGES
The JPEG format is the most widely used file format in digital photography.
One of it’s main features is your ability to control how much the image is
compressed—trading off its file size against its quality. When you select the
JPEG format in the Save As dialog box and click the Save button, the JPEG
Options dialog box appears with the following options:

SAVING IMAGE FILES
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The TIFF Options dialog
box lets you specify
which type of
compression is used.

SAVING TIFF IMAGES
Tagged-Image File Format (TIFF) is a high-quality format often used for
print applications and to exchange images among applications and computer
platforms. When you select the TIFF format in the Save As dialog box and
click the Save button, the TIFF Options dialog box appears with the following
options:

■ Image Compression option buttons specify which method is used to
compress the image. Since this format is usually used to retain the highest
possible quality, you would normally leave this set to None.

■ Byte Order option buttons force you to choose which byte order is use—
IBM PC or Macintosh. Luckily most applications can now read files using
either byte order.

■ Save Image Pyramid check box, when on, retains multi-resolutions if the
file contains them (few do). When opening images, Photoshop ignores all but
the highest resolution within the file.

■ Save Transparency check box, available only if the image has transparent
areas, retains transparency when an image is opened using another applica-
tion. (Transparency is always preserved when the file is reopened in
Photoshop.)

■ Layer Compression option buttons specify how layers are compressed. The
choices include the following:

● RLE (faster saves, bigger files).

● ZIP (slower saves, smaller files).

● Discard Layers and Save a Copy flattens the layers (page 104).
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PRINTING IMAGES

One of the most exciting steps in digital photography is printing your images.
When you’re ready to do so you’ll find four print commands listed on the File
menu.

■ Page Setup displays the Page Setup dialog box you use to select paper size
and orientation, set margins, and select a local or network printer. (You can
also access this dialog box by clicking the Page Setup button in the Print with
Preview dialog box.)

■ Print with Preview, the place we recommend you start from, displays a
very useful dialog box that lets you visually adjust the image’s size by drag-
ging its borders, select a profile for your paper, and use color management
options.

■ Print display options that are determined by your printer, print drivers,
and operating system. (You can also access this dialog box by clicking the
Print button in the Print with Preview dialog box.)

■ Print One Copy prints an image using the current settings without display-
ing any dialog box. (You can also access this command in the Print with
Preview dialog box by Alt+clicking the Print button.)

USING THE PRINT WITH PREVIEW COMMAND
When you want to print an image with total control over the settings, you
choose File>Print with Preview from the main menu to display the Print
Preview dialog box (confusingly labelled Print). If everything looks right, you
can click the Print button to display the Print dialog box (page 42) or change
some of the settings first. The most important ones to check are the image’s
size and layout in the preview pane and the color management settings
discussed on page 41. Here are the settings you can adjust:

When you use the Print
command, a warning is
displayed if your image
is too large for the
paper.

PRINTING IMAGES

The File menu lists the
print commands.

To see how an image
will fit on the page at its
current settings, point
to the file information
box at the bottom of the
screen and hold down
the mouse button. The
image area is indicated
by an outline with an X
through it.

The Print button takes
you to the next dialog
box—also named Print.

The Page Setup button
displays the Page Setup
dialog box.

Hold down Alt to change
Print to Print One and
click to print without
another dialog box.
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■ Preview pane on the left shows how the image will look on the page when
printed. The image is bordered by a bounding box with four corner handles
you can drag to size the image. The frame represents the printable area of the
selected paper size and the gray area represents the unprintable borders, the
width of which vary from printer to printer.

■ Position section aligns the image on the page using the following tech-
niques:

● To center the image, turn on Center Image. If the check box is dimmed,
turn off Scale to Fit Media.

● To drag the image to a new position, turn off Center Image and turn on
Show Bounding Box. If the Center Image check box is dimmed, turn off
Scale to Fit Media. Point anywhere in the image and drag it to a new
position.

● To specify offset distances, type in values for the distance from the Top
and Left edges of the paper when Center Image and Scale to Fit Media are
off. The drop-down arrows let you select your preferred unit of measure-
ment.

■ Scaled Print Size section specifies the height and width of the printed
image—not the file’s actual size in pixels. The initial settings are those set by
the camera or the Image>Image Size command (page 51). Scale the print size
of the image—being sure it fits in the printable area of the paper—using one
of the following techniques:

● To have the image fill the printable area of the paper in at least one
dimension, turn on Scale to Fit Media.

● To change the size of the image by dragging, turn on Show Bounding
Box and drag a bounding box handle. If the preview image is too large to
see the bounding box, turn off Scale to Fit Media and change the Scale to
10% or so. You can also turn off Center Image and drag the image to see a
corner that you can then drag.

● To specify a specific size, enter a value for the Scale (as a percentage),
Height, or Width. As you change one size, the others change automatically.
Drop-down arrows let you select your preferred unit of measurement. If
these boxes are dimmed, turn off Scale to Fit Media.

● To print an area of the image that you have selected (page 86), turn on
the Print Selected Area check box.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset so you can click it to
restore the original settings and try again.

■ Print, the button you click to proceed when all of the other settings have
been made, displays the Print dialog box. (Print One, displayed when you
hold down Alt, prints one copy without displaying a dialog box.)

■ Done saves the settings and closes the dialog box. Remember, displayed
when you hold down Alt, saves the print options without closing the dialog
box.

■ Page Setup displays the Page Setup dialog box where you can select the
paper size, source, and orientation of portrait (vertical) or landscape (hori-
zontal).

TIP

■ As you drag or
size the image in
the preview pane,
the text boxes
update to reflect
the changes.

The orientation of your
paper should match the
orientation of your
image—either landscape
(top) or portrait
(bottom). To change it
click the Page Setup
button.

The Page Setup dialog
box.

When you press Alt, the
buttons on the left
change to those on the
right.
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USING COLOR MANAGEMENT WHEN PRINTING
When the Print with Preview’s Show More Options check box is on, the
dialog box is expanded to show either Output or Color Management choices.
You can click the drop-down arrow to select one or the other. Color Manage-
ment displays settings used to better match the way the image looks on the
screen and in the print. Images are displayed on the screen using red, green,
and blue (RGB) colors but are printed using cyan, yellow, magenta, and black
(CMYK) inks. Color management bridges this gap by using profiles that
match screen and printer images.

PRINTING IMAGES

■ Source Space displays the color profile attached to the Document. (Proof
Setup is outside the scope of this book.)

■ Profile drop-down arrow displays a list of profiles from which to choose.

● If available, your first choice should be a predefined color profile for
your printer so colors are converted specifically for that printer and in
some cases even paper type.

● Choose Same As Source to print using the image’s color profile without
using the printer’s profile.

● Choose Printer Color Management or PostScript Color Management to
manage color conversions using the printer’s driver. PostScript Color
Management is only available when printing to a PostScript device.

■ Intent drop-down arrow displays a list of rendering intents that adjusts
how colors are converted. Perceptual is the best for photographic images
because it preserves the visual relationships among colors so they look
natural. For information on the other choices, use help.

■ Use Black Point Compensation check box should always be on so adjust-
ments are made for the differences in black points when colors are con-
verted. If turned off, your image may have shadows printed without details.

SETTING OUTPUT OPTIONS
When you turn on the Show More Options check box, the Print Preview
dialog box expands to show Output choices. Options not supported by the
selected printer are dimmed. Most are for prepress and outside the scope of
this book.

The Profile menu.

TIP

■ For the best
possible results you
need a custom
profile for your
printer and the
paper on which you
are printing. These
take time to make
and have to be
redone periodically
since equipment
ages.
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■ Background button displays the color picker (page 126) so you can print a
background color around the image. (The background does not appear in the
image file.)

■ Border button displays a dialog box where you can specify the width of a
black border that prints around an image.

■ Description check box, when on, prints any caption text entered in the File
Info dialog box (page 30) displayed when you choose File>File Info using 9-
point Helvetica plain type.

■ Labels check box, when on, prints the filename above each image.

THE PRINT DIALOG BOX
When you click the Print button in the Print with Preview dialog box (also
confusingly labelled Print, the Print dialog box appears (You can access this
dialog directly from the menu by choosing File>Print.) The dialog box has
the following choices:

TIP

■ The File>Online
Services feature
allows you to send
images from
Photoshop to on-
line photo printing
companies.

■ Name drop-down arrow displays a list of installed printers from which you
can choose. Details on the selected printer are listed below the Name head-
ing.

■ Properties button displays the dialog box for the selected printer. The
choices offered in this dialog box depend on the printer you are using but
usually include the paper type and size, the orientation of the image on the
page, and even printer adjustments and head cleaning.

■ Print range section specifies which pages are printed in multi-page
documents.

■ Copies specifies how many copies are printed.

■ OK prints the image (finally!)

The Properties button
(top) displays the dialog
box that’s part of your
printer’s driver. The
choices offered depend
on which printer you are
using.
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TOOLBOX
Tools in the upper left corner of the screen include (from top to bottom):

■ Hand tool drags an image that’s zoomed larger than the preview windows.
You can also access this tool when another tool is selected by holding down
the spacebar as you drag.

■ Slice Select tool selects a slice or multiple slices. (Slices are outside the
scope of this book.)

■ Zoom tool zooms in when you click a preview image or zooms out if you
Alt+click it. You can also specify a zoom level by typing a percentage into the
Zoom text box at the bottom of dialog box or by clicking the drop-down
arrow to select one of the preset zoom settings.

■ Eyedropper tool selects a color from the image to use for the matte—a fill
color for transparent pixels. The Eyedropper Color swatch displays the color
selected with the eyedropper. You can click it to display the color picker
(page 126) if you want to choose another color.

■ Toggle Slices Visibility tool displays or hides all slices. (Slices are outside
the scope of this book.)

OPTIMIZING IMAGES FOR THE WEB

When posting an image on the Web or e-mail it, it’s important that its file be
as small as possible so it downloads or transfers quickly. To reduce a file’s
size, you can reduce the number of pixels in the image (its pixel dimensions),
or increase its compression. When making these changes it’s important to be
able to see the impact you are having on image quality and that’s what the
Save For Web dialog box is designed to do. You can even preview download
times for various Internet connections and if they seem too long you can try
other settings until you get the results you want.

To save an image for the Web, select File>Save for Web to display the Save
for Web dialog box with the following controls.

Tools (from top down)
include the Hand, Slice
Select, Zoom,
Eyedropper, and Toggle
Slices Visibility.

OPTIMIZING IMAGES FOR THE WEB

If you open an image
that is too large, you
may see a dialog box
warning you of that
fact.
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PREVIEW AREA
The preview area has four tabs offering display options. Below the original
image is its filename and size, and below optimized images the estimated
download time is given for the Internet connection selected on the Preview
menu, and the quality—set by selecting a Preset or dragging the Quality
slider.

● Original tab displays the image with no optimization.

● Optimized tab displays the image with the current optimization settings
applied.

● 2-Up tab displays two images—the original image on the left and the
optimized image on the right. These before and after images visually guide
you as you change settings. You can use the Zoom and Hand tools in the
upper left corner of the dialog box to view all areas of the images in all
levels of detail.

● 4-Up tab (the default) displays four versions of the image—the original
and three levels of optimization. One of the images is optimized using the
specified settings and the other two are automatically generated at lower-
qualities for comparison purposes.

■ Preview Menu triangle in the upperright corner of the preview area,
displays a list of connection speeds from which you can choose. When you
select a connection, the estimated time that it will take to download the
image is displayed below the optimized image preview. This same menu has
choices that let you preview how the image will appear on different monitors
(it doesn’t change the image). Images often look darker on a Windows system
than they do on a Mac.

STATUS BAR
The status bar at the bottom of the dialog box displays color information
about the pixel under the pointer and has zoom and preview settings.

■ Zoom drop-down arrow displays a list of preset zoom levels from which
you can choose.

■ Preview in shows the currently selected browser and clicking the icon
displays the image in that browser. Clicking the drop-down arrow lets you
select a different browser if your system has more than one installed.

OPTIMIZE PANE
The optimize pane contains buttons, text boxes with drop-down arrows and
check boxes you use to optimize your image. You can try different optimiza-
tion settings as you compare the optimized and original images on the 2-up
or 4-up tabs. When using the 2-up or 4-up tab, your settings are applied to
the selected image—the one with a black frame.

The settings on the optimize pane change when you change image formats.
Here we discuss those you use when working with JPEG images.

■ Save button displays a dialog box where you enter a filename for the
optimized image and click Save. Be sure you don’t overwrite the original file.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset so you can click it to
restore the settings to the last saved version and try again.

Clicking the Preview
menu triangle (top)
displays a menu
(bottom).

The optimize pane
contains the settings
you use to optimize an
image. Point to each to
display a tool tip if you
are confused by what
each does.

When you hold down Alt
the Cancel and Done
buttons change to Reset
and Remember.
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Reducing an image by
50% actually shortens
the width and height by
that amount, but the
image is only 25% of its
original size.

■ Done remembers the current settings for use with the next image you
open and closes the dialog box. If you hold down Alt, the button changes to
Remember and clicking it remembers the current settings without closing
the dialog box.

■ Preset text box displays the preset used to optimize the selected image. The
drop-down arrow displays a list of predefined quality settings for different
types of images. In digital photography you would usually select one of the
JPEG presets as a starting point while checking the previews. If you then
fine-tune optimization by adjusting other settings, the Preset text box usually
changes to [Unnamed]. Selecting Original returns the image to its default
settings.

■ Optimized File Format and Compression Quality (the two unnamed text
boxes below Preset) initially reflect the selected preset but let you override it
by selecting another file format or quality. Turning on the Optimized check
box to the right creates a slightly smaller file size.

■ Quality text box shows the current quality. To fine-tune compression type
in a value between 0 and 100, or click the drop-down arrow and drag the
slider. Larger values give better looking images, but larger file sizes.

■ Blur text box drop-down arrow displays a slider you use to add blur to
reduce the effect of artifacts.

■ Progressive check box, when on, creates an image that displays progres-
sively in most Web browsers starting at a low resolution, and then at progres-
sively higher resolutions as the image downloads. If you chose Optimized to
create a smaller file, this option isn’t available.

■ ICC Profile check box, when on, saves the ICC profile of the original image
with the optimized file so some browsers can use it for color correction.

■ Matte selects a color that fills transparent areas of your image, perhaps to
blend in with a background color on a Web page.

■ Color table tab displays colors when the GIF or PNG-8 format has been
selected.

■ Image Size tab shows the current image size and lets you specify a New
Size by entering a Width or Height, or a Percent such as 50% to reduce the
width and height (not the area) by half. If the Constrain Proportions check
box is on, the image’s aspect ratio remains unchanged. The Quality drop-
down arrow lets you select a compression algorithm. The choices on this
menu are described in detail on page 52.

THE OPTIMIZE POP-UP MENU
Clicking the triangle icon to the right of Preset displays the Optimize menu
with some important settings.

■ Save Settings and Delete Settings lets you name, reuse, and eventually
delete your own preset optimization settings.

■ Optimize to File Size displays a dialog box where you specify a file size and
Photoshop then optimizes the image to get as close as possible to your target
using your settings or its own.

■ Repopulate Views automatically generates lover-quality versions of the
image you optimize so you have them for comparison purposes when using
the 4-up tab.

The Optimize menu is
displayed when you
click the triangle icon on
the optimize pane.

OPTIMIZING IMAGES FOR THE WEB

You can adjust quality
with a slider, text box
value, or drop-down
arrow. The icon to the
right lets you use a
channel to modify a
quality setting.

TIP

■ Using the Save
for Web command
automatically
converts 16-bit
images to 8 bits.
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It is the rare image that can’t be improved by tweaking. You’ll find that
you are often adjusting the image’s size, tonal range, colors, sharpness,
and retouching small defects or blemishes. In this chapter we start by

showing how you analyze an image to see how it can be improved. Until you
can look at your images critically, it’s hard to know what needs to be done to
make them better. You’ll see how to evaluate tones, colors, sharpness, and
details. In this same section we also help you choose the tools and procedures
you need to make needed adjustments—with the best highlighted. The rest of
the chapter covers each tool in detail, showing you how to use it and choose
among the many options you are presented with. As with most things in life,
knowing what to do and how to do it well can make all of the difference in the
outcome.

When evaluating images and making changes, it’s important that your
monitor has been properly calibrated (page 183). This is the only way to
ensure images will print the same as they look on the screen.

Chapter 3
Fixing Your Images

CONTENTS

■ Evaluating Your
Images ■ Specifying
Image Sizes ■ Specify-
ing Canvas Sizes ■
Cropping Images ■
Rotating Images ■ Using
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EVALUATING YOUR IMAGES

When you open an image on the computer, you really get to see it for the first
time. The display on the camera’s monitor is so small captured images are
hard to evaluate. So what do you look for when deciding if the image you are
looking at can be improved? In this section we’ll look at those things you
evaluate first, and then help you choose the tools to make the changes you
decide on. As you’ll see, there is almost always more than one way to adjust
an image characteristic such as tones or colors. Many people start with the
automatic adjustments because they are so easy. However, it won’t be long
before you find yourself migrating to the much more powerful tools that take
more practice, but which give results that make the extra effort worthwhile.

One thing to consider is the format you use to take photographs. All cameras
save images in the popular JPEG format. However, some let you use a RAW
format (page 80) that provides much higher quality. The reason for this is
that JPEG images use 8 bits per channel to record tones so an image can
have no more than 256 tones or colors in each R, G, and B channel. RAW
images on the other hand use 16 bits per channel so the number of colors or
tones you have to work with jumps to 65,536. This huge increase makes
gradations smoother and details sharper. When taking important photos,
consider using the RAW format and then editing them in 16-bit mode. (To
see if an image is in 8- or 16-bit mode, select Image>Mode.)

EVALUATING IMAGE SIZE AND ORIENTATION
The initial size and orientation of an image is determined by what the
camera captured. There are situations in which you may want to change
these characteristics.

■■■■■ Resizing can be done in two ways, by changing the number of pixels in the
image, called its pixel dimensions, through a procedure called resampling.
This process adds or removes pixels to make the image larger or smaller. You
might want to do this to reduce the size of images you will be sending by e-
mail or posting on the Web. You might also want to increase the size of the
image when making large prints. You can also change the size of the image
without changing the number of pixels it contains, called its document size.
You normally do this when making a print or exporting an image to another
application.

■■■■■ Cropping removes distracting or unimportant parts of an image. You
might also want to crop if the image has to fit into a specific design such as a
newsletter or greeting card.

■■■■■ Rotating an image may be necessary if you turned the camera vertically to
capture a picture, or if the horizon line is tilted.

To adjust the image size and orientation, here are some of the tools to
consider:

★★★★★ The Image>Image Size command (page 51) can add or remove pixels or
specify the document size at which the image prints.

★★★★★ The File>Print with Preview command (page 39) can change the size at
which the image prints, but not the number of pixels that it contains.

★★★★★ The Crop tool in the toolbox (page 54) crops and can also rotate an image
at the same time.

TIP

■■■■■ When evaluating
tones, colors, and
sharpness, display
the image at 100%
or Actual Size
(page 32) because
that’s where it is
displayed most
accurately.

TIPS

■■■■■ To adjust the
entire image, make
sure nothing is
selected (page 86).

■■■■■ To adjust only a
single layer, select
that layer in the
Layers palette
(page 104).

■■■■■ To adjust just a
portion of your
image, select that
portion (page 86)
or create a mask
(page 146).

★
Stars next to tools
indicate they are the
first ones you should
try, because they are
the most powerful.
Other tools may be
easier to use, but
probably won’t give the
same results.

EVALUATING YOUR IMAGES

HTTP://WWW.SHORTCOURSES.COM


48

CHAPTER 3. FIXING YOUR IMAGES

FOR INFORMATION ON CLASSROOM USE, VISIT HTTP://WWW.PHOTOCOURSE.COM

Visually, images that use the full tonal range look rich, with smooth transi-
tions in tones. Those that don’t use the full range lack contrast, often looking
flat and dull. Details may be missing in highlight and shadow areas or the
image may be too dark or light. In these cases you may want to adjust or
expand the image’s tonal range.

To adjust the tonal range of an image, here are some of the tools to consider:

★★★★★ The Window>Histogram command (page 57) displays the image’s histo-
gram so you can use it as a guide when making adjustments.

★★★★★ The Image>Adjustments>Curves command (page 64) is the best tool for
adjusting the tonal range because you can independently adjust up to 14
points along a curve that represents all 256 tones in a 8-bit image and all
65,536 tones in a 16-bit image.

★★★★★ The Image>Adjustments>Levels command (page 61) is one of the easiest
and best tools for adjusting the tonal range because you can adjust shadow,
midtone, and highlight areas independently.

★★★★★ The Dodge and Burn tools in the toolbox (page 137) lighten or darken
areas in the image that you drag over.

★★★★★ The File Browser’s Edit>Rotate commands and rotate buttons (page 56)
rotate images in 90° or 180° increments.

■■■■■ The Image>Rotate Canvas commands (page 56) rotate and flip images
and let you rotate them in fine increments.

EVALUATING THE TONAL RANGE
Dynamic range in music is the range between the faintest and loudest
sounds that can be reproduced without distortion. In photography the
dynamic range, called the tonal range or contrast, indicates the range of
brightness in an image between pure white and pure black. There are two
ways to evaluate the tonal range of an image—visually and using a histogram
(page 57). You should use both approaches because they are not mutually
exclusive.

TIPS

■■■■■ You’ll frequently
encounter the term
grayscale. It’s the
same as a black &
white photograph.
The term in used
instead of black &
white because
images are actually
created from
shades of gray
ranging from pure
white to pure
black.

■■■■■ When talking
about colors, the
term neutral is
often used. A
neutral color is
always gray and all
three components
(R, G, and B) have
the same numeric
value. If any values
are higher or lower,
the color is no
longer neutral and
has a color tint.

The Info palette
provides important
information about an
image as you edit it.

A histogram shows how
many pixels in the
image are at each level
of brightness.
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★★★★★ The Image>Adjustments>Shadow/Highlight command (page 69) can fix
photos where the main subject is silhouetted against a bright background,
where the subject was burned out from being too close to the camera flash, or
where details are hidden in dark shadow areas.

■■■■■ The Image>Adjustments>Auto Levels command (page 61) adjusts tones
automatically.

■■■■■ The Image>Adjustments>Auto Contrast command (page 60) automati-
cally adjusts the contrast in the image without affecting colors.

■■■■■ The Image>Adjustments>Brightness/Contrast command (page 60)
adjusts brightness and contrast by dragging sliders.

EVALUATING COLORS
In film photography, most photographers adjust color by visually analyzing
test prints and then making adjustments with color filters. In digital photog-
raphy, we can use the same visual approach, but back it up with an analysis
of an image’s histogram. So what do we look for? The human eye perceives
color in terms of three characteristics—hue, saturation, and brightness and
there is even a color model, called HSB. The color monitor uses a different
color model called RGB because images are displayed using varying amounts
of red, green, and blue light. When evaluating images, you can think in terms
of these two models—one to evaluate colors and the other to look for color
casts.

To evaluate colors in an image, think of them in terms of hue, saturation, and
brightness because these three aspects can be adjusted.

■■■■■ Hue is the color—what we refer to by names such as red, orange, or green.
If colors are off, color balance should be adjusted by adjusting the mix of red,
green, and blue colors in the image.

■■■■■ Saturation, sometimes called chroma, is the strength or purity of the
color. Saturation decreases as the amount of gray mixed into the pure color
increases. If colors look dull, saturation can be increased.

■■■■■ Brightness is the relative lightness or darkness of the color. Brightness is
reduced by adding black to the color mix and increased by adding white. If
colors look too dark or light, brightness can be adjusted.

A color cast is usually caused when one or more of the three color compo-
nents (red, green, and blue) are too high or low over the entire image. This
can be caused by not setting white balance correctly, by photographing a
scene illuminated by more than one type of light source, or by photographing
a subject picking up reflections from a colored surface. Color casts are very
noticeable when shooting during sunrises and sunsets—but there we usually
like the effects. It’s easiest to identify a color cast by looking at areas that
should be neutral white or gray. If these areas have any colors mixed in, the
image has a color cast that you should remove. If you use the eyedropper and
Info palette (page 68) to examine colors in an image, pure white areas should
have R, G, and B settings of 255. Gray areas should have R, G, and B settings
that are equal, for example, 128, 128, and 128 for middle gray. Pure black
areas should have R, G, and B settings of 0. If one or more of the RGB values
is higher or lower than the others, these tones won’t be neutral and will have
a color cast.

TIP

■■■■■ Auto commands
have unpredictable
results. They can
have great effects
on one image, and
strange effects on
another. Be sure to
try them, but when
you do so, remem-
ber you can select
Edit>Undo or use
any of the other
undo techniques
(page 21).

EVALUATING YOUR IMAGES

The Image>
Adjustments submenu
contains most of the
commands you use to
adjust images.
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To adjust colors in an image, here are some of the tools to consider:

★★★★★ The Image>Adjustments>Levels command (page 61) and Image>
Adjustments>Curves command (page 69) both adjust individual colors
channels (page 58).

★★★★★ The Image>Adjustments>Variations command (page 71) adjust colors
visually as you select from a possible range of adjustments. You can adjust
highlight, midtones, shadows, or saturation.

■■■■■ The Image>Adjustments>Auto Color command (page 71) adjusts colors
automatically.

■■■■■ The Image>Adjustments>Hue/Saturation command (page 71) lets you
adjust hue, saturation, and lightness with sliders.

■■■■■ The Image>Adjustments>Replace Color command (page 71) lets you
select areas and then adjust their hue, saturation, and lightness with sliders.

■■■■■ The Image>Adjustments>Color Balance command (page 71) lets you
adjust individual colors in highlight, midtone, and shadow areas with sliders.

■■■■■ The Image>Adjustments>Photo Filter command (page 71) adjusts colors
just as a filter on the camera lens would.

EVALUATING DETAILS
When examining an image, look for small imperfections that can be re-
touched. A portrait subject might have a small blemish that will be the size of
a baseball if you enlarge the image. There may be reflections, or even tele-
phone wires you want to remove. Small areas may benefit by being made a
little lighter or darker than their surroundings. Portrait subjects may have
red-eye caused by flash in a dark room. Retouching images should be done
before you make tonal and color adjustments to the image.

To retouch images, here are some of the tools to consider:

★★★★★ The Healing Brush tool makes imperfections disappear into the back-
ground (page 137).

★★★★★ The Color Replacement tool in the toolbox (page 137) removes red-eye
caused by flash.

★★★★★ The Dodge and Burn tools lighten or darken areas you drag over (page
137).

★★★★★ The Clone Stamp tool copies an area of the image to another area and is
ideal for covering blemishes or removing elements from a scene (page 137).

EVALUATING SHARPNESS
The apparent sharpness of an image depends a great deal on how much
contrast there is along edges and lines. If an image looks soft, it can often be
improved by sharpening (page 78). Many photographers sharpen almost
every image, ignoring this aspect only for images such as fog scenes that are
deliberately soft.

To adjust the sharpness of an image, here are some of the tools to consider:

★★★★★ There are a number of sharpening tools available when you select
Filter>Sharpen. By far the best is the Unsharp Mask Filter (page 78).

■■■■■ The Sharpen tool in the toolbox (page 137) sharpens areas that you drag
over.

You can make many
adjustments using
adjustment layers
instead of making them
directly to the image
(page 116).

TIP

■ Without you
even being aware
of it, your camera
is making changes
to your images that
cannot always be
undone. These
include such things
as sharpness, white
balance, and
contrast. If you
want to adjust
these yourself, use
the camera’s RAW
format if it has one
(page 80).

HTTP://WWW.PHOTOCOURSE.COM


51FOR INFORMATION ON DIGITAL PHOTOGRAPHY, VISIT HTTP://WWW.SHORTCOURSES.COM

SPECIFYING IMAGE SIZES

There are two ways you can change an image’s size—by changing the number
of pixels in the image; or by changing the size of the area in which the avail-
able pixels are printed or displayed—the document size. These two proce-
dures are separate but related.

■ Pixel Dimensions specifies the number of pixels an image contains. Ini-
tially determined by the number of pixels captured by the camera there are
times you may want to change this size by removing or adding pixels. For
example, you may want to e-mail or post an image on a Web site. For this
purpose it’s best if an image is no larger than the lowest common denomina-
tor screen, usually 640 x 480, or 800 x 600. Reducing the number of pixels
in an image also makes the file size smaller so the image can be sent or
displayed more quickly. The main reason you would increase the number of
pixels in an image is to make large prints. Since most images print best when
they are printed at 200–300 pixels per inch (ppi) you may get better results
by adding enough pixels to keep the pixels per inch from falling below 200.

To change the number of pixels in an image, you resample it to make it
smaller by removing pixels (downsampling), or larger by adding them
(upsampling). Reducing an image usually has less affect on its appearance
than does enlarging one. This is because enlarging requires the program to
add pixels using a sophisticated form of guessing called interpolation that
analyzes adjoining pixels to determine the color of the new ones it inserts.
Normally, you can double the size of an image without effects being too
noticeable. However, trial and error is the only way to be sure because
images vary so much. Look for the image becoming soft, as if it’s not sharply
focused. If you are making other changes to the image, resampling should be
done after all other changes other than sharpening (page 78). This is because
most adjustments work best when there are the maximum number of origi-
nal pixels to work with.

■ Document Size specifies how large an image is when printed or displayed,
especially in other applications. Normally you change the document size with
resampling turned off. As a result, as the size increases, the pixels per inch
decrease because the same number of pixels are spread over a wider area—
like an image expanding on a balloon as you inflate it. When printing, if the
resolution falls below 200 or so pixels per inch, you may want to consider
resampling the image. There are problems printing with less than 200 pixels
per inch just as there are with resampling to increase the number of pixels.
You’ll have to experiment to see which approach works best for a particular
image. Just be sure your image is not too large to fit on the page. Many
printers can’t print to the edge of the sheet so there is always a border. To
print the full image, it must fit inside this border area.

To change an image’s pixel dimensions or document size, select Image>
Image Size to display the Image Size dialog box having the following settings:

■ Pixel Dimensions, used to change the number of pixels in the image, shows
the image’s Width and Height in pixels and next to the heading is the size of
the image file. As long as the Constrain Proportions check box is on, and a
chain link icon connects the Width and Height settings, you can type either
dimension and the other changes automatically. You can also click the drop-
down arrow to specify changes in size as a percentage.

TIPS

■ The document
size that you
specify for an
image determines
its size if you copy
or place it into
another applica-
tion.

■ To display an
image’s size in
pixels, point to the
file information
box on the status
bar and hold down
Alt and then the
mouse button.

■ You can change
the document size
for a print by
dragging its
borders using the
Print with Preview
command (page
39).

■ Some people
swear that when
you enlarge an
image by resam-
pling it, you get
better results if you
enlarge it by no
more than 10% at a
time, and repeat as
necessary until it
reaches the size
you want.

SPECIFYING IMAGE SIZES
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■ Document Size indicates the current Width and Height of the image in
inches, centimeters, or any other unit of measurement you select with the
drop-down arrow and Resolution displays the image’s pixels per inch. When
changed with Resample Image off, these settings affect only the document
size. With Resample Image on both the document size and pixel dimensions
change.

■ Scale Styles check box, when on, adjusts the scale of effects added using
layer styles (page 122). This keeps the effects in proportion to the image.

■ Constrain Proportions check box determines if one of the photo’s dimen-
sions will adjust automatically when you change the other. If you turn this
off, the image’s aspect ratio (page 88) changes and the image is stretched in
one direction. Unless you are after a special effect, you normally leave this
check box on. Chain link icons connecting the Width and Height settings
indicate when this setting is on.

■ Resample Image check box determines if the number of pixels in the
image will change when you change the size. When specifying a size for
printing you usually turn this off. When you resample an image to add or
subtract pixels, you can turn it on and use the drop-down arrow to select a
process that trades off quality versus speed.

● Nearest Neighbor is fast but doesn’t give the best results. This method
is recommended for use with illustrations to preserve hard edges and
produce a smaller file.

● Bilinear is a medium-quality method.

● Bicubic is slow but produces the smoothest tonal gradations and is
recommended as the best starting point.

● Bicubic Smoother is good when enlarging an image.

● Bicubic Sharper is good when reducing an image. It maintains detail,
but may oversharpen some areas.

■ OK applies the specified dimensions to the image.

■ Cancel closes the dialog box without applying changes to the image. Hold
down Alt to change the button to Reset and click it to restore default settings
so you can try again.

TIPS

■ If you make any
mistakes in the
dialog box, hold
down Alt to change
the Cancel button
to Reset and click it
to start over.

■ You can resize an
image with the
File>Automate>Fit
Image command.

TIP

There are a num-
ber of third-party
programs available
for resizing images.

■ pxl SmartScale
from Extensis
(http://
www.extensis.com).

■ S-Spline from
Shortcut Software
(http://www.s-
spline.com).

■ Genuine Fractals
from LizardTech
(http://www.
lizardtech.com).

The size you specify for
a print is independent of
the number of pixels in
the image although it
determines the
resolution or pixels per
inch used to make the
print.

Clicking the Auto...
button displays the Auto
Resolution dialog box
used when printing
using a halftone screen.
This is beyond the scope
of this book.
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SPECIFYING CANVAS SIZES

When you first open a digital photo, the image and the canvas on which it is
placed are both the same size. However, you can enlarge the canvas and it
will be filled with the color you select. (If you decrease the size of the canvas
so it’s smaller than the image, the image is cropped to fit the new size.) There
are a number of reasons why you might want to increase the size of the
canvas.

■ To make room for other images that you copy and paste to create a collage.

■ To put a border about the image.

■ To add an area outside of the image where you can enter your name, the
image’s title, or a copyright notice.

To change the canvas size, select Image>Canvas Size to display the Canvas
Size dialog box having the following settings:

■ Width and Height indicate the current canvas size in pixels, centimeters,
or any other unit of measurement you select with the drop-down arrows. If
you select Columns, width is measured in terms of the columns specified in
the Units & Rulers section of the Edit>Preferences dialog box.

■ Relative check box, when on, lets you enter a positive or negative number
by which you want to increase or decrease the size of the canvas. For ex-
ample, if you want to add a 30 pixel wide border around the image, turn on
Relative and enter 30 in both the Width and Height text boxes with them set
to pixels.

■ Anchor specifies where on the new canvas you want to position the image.
Click the square representing where you want to image to be positioned
within the new canvas. For example, if you want the image in the upperright
corner of the enlarged canvas, click the upperright square in the graphic.

■ Canvas extension color drop-down arrow lets you choose a color for the
added canvas. Selecting Other on the menu, or clicking the color swatch,
displays the color picker (page 126).

Some images seem to
have no edge. Adding a
border to these images
shows where the image
area ends. You can do
this by enlarging the
canvas slightly or
selecting all and then
using the Edit>Stroke
command.

TIPS

■ You can enlarge
the canvas area
with the Crop tool.
Use it to select the
entire image, then
drag the corners or
edges of the
bounding box
larger than the
image. Hold down
Alt as you drag to
keep the image
centered in the new
canvas. When
finished selecting,
click the Commit
button on the
options bar.

■ If you select the
image and cut it,
then enlarge the
image and paste it
back in, it’s on its
own layer.

SPECIFYING CANVAS SIZES
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CROPPING IMAGES

Many photographers strive to compose, capture, and print images full-frame.
However, editors and others love to crop images to fit unusual shapes in
layouts, or to make an them more dramatic. It's like looking for a better
photograph within a photograph. At other times, you crop for more practical
reasons, perhaps to remove the tilted sides from a rotated image or to remove
distracting elements. There is one drawback. Cropping reduces the number
of pixels in the image and that reduces the largest possible size at which you
can get a good print. However, reducing an image’s size isn’t always bad. If
you plan on e-mailing an image or posting it on a Web site, a smaller size is
an advantage. In these cases, it’s almost always better to crop before reducing
the image size because you may not need to reduce it as much. Although you
can crop images in a number of ways (see the Tips box) the Crop tool is a
good way to start. It not only crops an image visually, but can also rotate it as
you do so.

SETTING CROP OPTIONS
When you select the Crop tool from the toolbox, the options bar displays
settings you can make:

■ Width, Height, and Resolution text boxes specify the aspect ratio—the
shape or proportions of the image (page 88) and resolution of the cropped
image.

● If you enter a width and height, you will only be able to select areas with
the same aspect ratio. For example, if you enter a width of 1.5 and a height
of 1, your selections will always be 1.5x wider than they are high. If you
leave the width and height blank you can select any aspect ratio. (To
reverse the width and height numbers, click the Swaps height and width
button between them.)

● To resample the image during cropping, enter the desired width, height
and resolution of the cropped image. To crop without resampling, leave
the Resolution blank.

■ Front Image button enters the values of the currently active image into the
Width, Height, and Resolution text boxes. When you want to crop the image
while retaining it’s current aspect ratio and resolution, this is the perfect way
to do so.

■ Clear button clears entries from the Width, Height, and Resolution text
boxes.

After you drag to make a selection, the choices on the options bar change.

■ Cropped Area lets you choose to delete or hide the cropped out area. When
hidden, you can see the cropped out area by dragging the image with the
Move tool. This option is not available for images that contain only a back-
ground layer. To use it on such a layer, first convert the background to a
regular layer (page 104) before cropping.

Many film photogra-
phers feel so strongly
that you should com-
pose images in the
viewfinder that they file
their negative carriers
to show a black border,
proving it’s a full frame
image.

The Crop tool icon

TIPS

■ You can use the
rectangular or
elliptical marquee
tools to select the
area of an image
you want to retain
(page 88) and then
select Image>Crop
to crop away the
rest.

■ If your image is
surrounded by a
field of uniform
color, you can
remove the uni-
form color with the
Image>Trim
command.

■ The Automate
menu’s Crop and
Straighten com-
mand fixes images
that were scanned
at an angle.
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■ Shield check box, when on, covers the part of the image that will be
cropped out with the color shown in the Color swatch. Clicking the swatch
displays the color picker (page 126) so you can change the color.

■ Opacity text box displays the opacity or “see-through” of the shield.
Clicking the drop-down arrow displays a slider so you can adjust the opacity.

■ Perspective check box, when on, lets you drag the corners of the crop
marquee to correct for perspective distortion (page 101).

■ Cancel icon cancels the selection.

■ Commit icon crops the image.

CROPPING AN IMAGE
To select the area to be retained, click the Crop tool in the toolbox:

■ To select from a corner, start in one of the corners of the area you want to
save and drag the tool.

■ To select from the center point and expand outward, Alt+drag.

■ To constrain the selection to a square shape (when there is no width or
height entered), Shift+drag.

■ To reposition the selection border, without releasing the mouse button
press the spacebar and drag it.

The part of the image that will be removed is covered by the shield color.
When you release the mouse button, the area that will be retained is indi-
cated by a bounding box with handles at the corners and sides that you drag
to adjust the selection.

■ To move the bounding box, point inside it and drag.

■ To change the shape or size of the bounding box, drag a handle.

● To retain the current proportions when no width or height has been
specified, Shift+drag a corner handle. If you specified a height and width
on the options bar you can only drag corners. If you left those text boxes
blank, you can also drag the sides.

● To change the size of the selection without moving the center point,
Alt+drag a handle.

■ To rotate the bounding box so the cropped image is rotated, point outside
of the box so the pointer turns into a curved arrow, and drag. You can also
drag the center point to change the point around which the selection rotates.

■ To complete cropping, double-click within the selection, click the Commit
icon on the options bar, select a different tool in the toolbox, press Enter, or
select Image>Crop.

■ To cancel cropping, click the Cancel icon on the options bar or press Esc.

The shield (right) covers
the area of the image
that will be cropped
away (above). This
helps you visualize what
the cropped image will
look like.

TIP

■ The Opacity
setting is common
to many tools.
While cropping,
you can get a good
feeling for what it
does by selecting
an area and then
clicking the Opac-
ity drop-down
arrow to display a
slider. Drag it to
see the effects of
opacity on the
shield covering the
part of the image to
be cropped away.

The Cancel and Commit
icons.

CROPPING IMAGES
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Click the CW (clockwise) or CCW (counterclockwise) option button and enter
the Angle of rotation in degrees. One technique is to guess at the degrees of
rotation needed and use that as a starting point. After evaluating the results,
select Edit>Undo Rotation to try again with a revised number. Through a
process of trial and error, you’ll find the exact angle of rotation needed.
When you use this command, the canvas size increases to accommodate the
angled image and the blank space takes on the background color (page 126).
You'll always loose a part of the image when you crop the image back to a
rectangular shape.

■ To straighten an image that’s been scanned at an angle, select File>
Automate>Crop and Straighten Photos command from the main menu. This
command behaves badly with some photos, so remember the Edit>Undo
command.

■ To rotate an image while you are also cropping it, select the Crop tool
(page 54), select the area to be cropped, point outside the bounding box so
the pointer turns into a curved arrow, and then drag. To move the center
point, around which the selection marquee rotates, drag the circle at the
center of the bounding box. When finished, click the Commit button on the
options bar.

ROTATING IMAGES

There are a number of reasons why you might want to rotate an image.
Perhaps you rotated the camera into a vertical position when you took the
photo, the horizon or other strong horizontal or vertical line is tilted, or the
image was scanned at an angle.

■ To rotate an image in 90° increments, for example, to rotate an image
taken with the camera rotated into portrait mode, do one of the following:

● To rotate from the main menu, select Image>Rotate Canvas and select
one of the rotation commands.

● To rotate from the File Browser, select one or more photos, and use the
Rotate buttons or rotate commands on the File Browser’s Edit menu (page
22). You can also right-click the image and select a rotation command
from the context menu.

■ To rotate by a specific amount, perhaps to straighten a horizon, select
Image>Rotate Canvas>Arbitrary to display the Rotate Canvas dialog box.

TIPS

■ To guide you
when rotating,
select View>Grid
to display a non-
printing grid over
the image. Use the
same commands to
hide it when
finished.

■ If you under or
over rotate you can
select Edit>Undo
to return to the
starting point.

■ Selecting
Image>Rotate>
Free Rotate Layer
lets you drag the
image to rotate it.

■ You can rotate a
selection by
dragging (page
101).

The Image>Rotate
Canvas command
displays a submenu with
rotation commands.
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USING THE HISTOGRAM PALETTE

A histogram gives you a quantified look at an image’s tonal range. The
histogram is a bar graph with the horizontal x-axis representing the full tonal
range with pure black on the left and pure white on the right. Along this axis
are 256 levels of brightness ranging from 0 (black) on the left to 255 (white)
on the right. The vertical bars show you how many pixels in the image have
each of the 256 tones. Many photos, but not all, look best when there are
some pixels at every position because these images are using the entire
available tonal range. In many images, however, pixel values are grouped
together and occupy only a part of the available tonal range. These images
lack contrast because the difference between the brightest and darkest areas
isn’t as great as it could be. The histogram also indicates if the image is low-,
average-, or high-key because the pixels will be clustered in the left, center, or
right part of the histogram. Unless you like the effect, you may want to
spread or redistribute the pixels so they cover the entire available tonal
range. As you will soon see, there are many tools designed to do just this.

To display the Histogram palette, select Window>Histogram and it opens
in Compact View displaying the tonal range of the entire image. To display
histogram data for a section of the image, select that section—page 86. If the
Preview check box is on in a dialog box you are using to adjust an image, the
Histogram changes to reflect any adjustments you make to the image’s tonal
scale.

■ Triangle icon displays the palette menu where you specify the level of
detail displayed. Choices include Expanded View, Compact View (the
default), All Channels View. The settings that follow are available only when
you have selected Expanded View or All Channels View.

■ Channel text box (page 58) indicates what the topmost histogram
represents and clicking the drop-down arrow lets you select one of the
following:

● RGB displays a histogram of the composite image.

● Red, Green, or Blue displays a histogram of a single channel. All three
channels plus the composite channel are shown when you select Expanded
View from the palette menu.

● Luminosity displays a histogram of the luminance of the composite
channel.

● Colors displays a color histogram of the individual color channels and
luminosity.

■ The Uncached Refresh button is clicked to update the histogram when the
Cached Data Warning icon is displayed to warn you that the histogram
doesn’t accurately represent the image—perhaps because you have made
changes to it. You can also update the histogram by clicking the Cached Data
Warning icon or double-clicking the histogram.

■ Statistics are displayed for any pixel value you point to on the histogram.
To view statistics for a range of values, drag in the histogram to highlight the
range.

■ Source menu, available only when the image has more than one layer
(page 104) lets you display a histogram of the Entire Image or the Selected
Layer. The last choice, Adjustment Composite, displays a histogram of a
selected adjustment layer and all layers below it.

If you expand the
histogram palette and
point to any bar on the
histogram, its
brightness (Level) and
the number of pixels at
that level (Count) are
displayed below.
Percentile is the
cumulative number of
pixels at or below that
level expressed as a
percentage of all the
pixels in the image.

The Histogram palette
menu lets you display
various levels of detail.

The Histogram palette
in the default compact
view.

The Cached Data
Warning icon (left) and
the Uncached Refresh
button (right).

USING THE HISTOGRAM PALETTE
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USING THE CHANNELS PALETTE

Digital photos that you capture are almost always full-color. It may surprise
you then, that we adjust colors by adjusting gray tones ranging from pure
white to pure black. The reason for this is that images have a grayscale
channel for each of its 3 colors. Each channel, which is actually a grayscale
image, controls the brightness of one of the three colors—red, green, or blue.
It’s only when these three separate channels are combined into a single
composite RGB channel, that we see a full-color image. Channels are created
automatically when you open an image and you add others if you save
selections (page 99).

TYPE OF CHANNELS
Channels are 8-bit grayscale images that store one of three kinds of informa-
tion:

■ Color information channels are created automatically when you open a
new image. Digital photos initially have three color channels:

● A composite channel, usually called RGB in digital photography, shows
the full-color image with all other channels combined.

● Red, Green and Blue channels display the brightness of the red, green,
and blue colors making up the composite image.

■ Alpha channels are created when you store selections (page 99) or masks
(page 146).

■ Spot color channels can be created to specify additional plates when
printing spot color inks on a commercial press. (This is beyond the scope of
this book)

An image can have up to 56 channels and each adds to the file’s size. You can
check the uncompressed size of a file, including alpha channels and layers, on
the status bar at the bottom of the window when Document Sizes has been
selected from the pop-up menu.

When you open a digital photograph, most editing commands affect the
composite RGB channel because it’s the default channel. This means that
changes you make affect all of the colors in the image. For more precise
control, or to correct color casts, you can select individual color channels so
your commands affect only one color. For example, as you will soon see, you
can adjust the tonal range, hue, saturation, and brightness of the overall
composite image or just the red, green, or blue channels.

USING THE CHANNELS PALETTE
The Channels palette lists all channels in the image—the composite channel
first, followed by individual color channels, spot color channels, and finally
alpha channels. A thumbnail to the left of each channel’s name displays the
channel’s current contents.

You can use the palette to view any combination of individual channels. For
example, you can view an alpha channel and the composite channel together
to see how changes made in the alpha channel relate to the entire image. By
default, individual channels are displayed in grayscale.

■ To display the Channels palette, select Windows>Channels, or click the

TIPS

■ Turning off the
display of thumb-
nails can improve
performance.

■ Smaller thumb-
nails make the
palette smaller and
reduce the space
required by the
palette—helpful
when you’re
working on smaller
monitors.

The Channels palette
displays the composite
channel and channels
for red, green, and blue
colors.

The Channel palette
buttons include (from
left to right) Load
channel as selection,
Save selection as
channel, Create new
channel, and Delete
current channel.
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Channels palette tab. If necessary, use the scroll bars or resize the palette to
see additional channels.

■ To select a channel, click it. To select multiple channels Shift+click them.

■ To show or hide a channel click in the eye column next to the channel to
show or hide that channel. When a channel’s effects are shown in the image,
an eye icon is displayed to the left of its thumbnail.

● To quickly display all default color channels, click the eye space next to
the RGB channel. This shows all hidden channels because the composite
channel is only displayed whenever all the color channels are visible.

● To show or hide multiple channels, drag through the eye column.

■ To display individual color channels in color rather than grayscale select
Edit>Preferences>Display & Cursors, select Color Channels in Color, and
click OK.

■ To resize or hide channel thumbnails choose Palette Options from the
Channels palette menu, select a display option and then click a thumbnail
size. Click None to turn off the display of thumbnails.

The Channels displayed
in color with large
thumbnails.

USING THE CHANNELS PALETTE

The Channels palette
shows channels as
thumbnails. When you
select one of the
channels, the image
changes to that
channel’s gray scale
image. Here is an image
with red, green and blue
sections. These colors,
and the colors they form
when they mix, are
shown in grayscale on
the corresponding
channel and in full color
on the composite RGB
channel.

■ To delete an alpha or spot color channel (you can’t delete the color
channels), select it and click the palette’s Delete current channel button or
drag and drop it on that button.

USING CHANNELS IN DIALOG BOXES
Many dialog boxes let you edit the composite color channel (RGB) or you can
click a drop-down arrow to select just one of the individual color channels for
adjustment.

■ If you previously selected one channel in the Channels palette, some dialog
boxes then don’t list channels assuming you have already selected the one
you want to adjust.

■ If you Shift+click to select two color channels, only those channels are
listed on the menus with the combined one abbreviated.

If you select two color
channels, they are all
that’s listed on the
Channel menu in a
dialog box.

The Channel drop-down
arrow in many dialog
boxes lets you select
which channels are
adjusted.
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Decreasing contrast
makes colors in the
image look more muted
and “flatter” (left) while
increasing it makes it
look sharper and crisper
(right).

Decreasing brightness
darkens an image (left)
while increasing it
lightens it (right).

ADJUSTING BRIGHTNESS AND CONTRAST

As you’ll soon see, it’s hard to beat the Levels (page 61) and Curves (page 64)
commands for adjusting tones. However, the Auto Contrast and Brightness/
Contrast commands are so simple, they make it easy to see how adjusting
brightness and contrast affects an image. As you explore these commands,
you’ll find they work better on some images than they do on others. One
major drawback is that they only adjust the composite image. You can’t use
them to adjust the red, green, or blue channels individually as you can with
the Levels and Curves commands. Since the commands don’t adjust indi-
vidual channels, they won’t create or remove color casts.

ADJUSTING CONTRAST AUTOMATICALLY
The Image>Adjustments>Auto Contrast command automatically adjusts the
overall contrast and mixture of colors in an image. It does so by increasing
the tonal range—shifting the lightest and darkest pixels in the image to pure
white and pure black so highlights are lighter and shadows darker.

ADJUSTING BRIGHTNESS AND CONTRAST MANUALLY
If your image is too dark, too light, or too flat-looking, you can adjust it using
slider bars in the Brightness/Contrast dialog box. The only drawback of these
adjustments is that they adjust all pixels in the image by the same amount. A
better tool is the Levels command that lets you adjust shadows, midtones,
and highlights independently of each other or the Curves command that let’s
you adjust up to 14 points. To adjust brightness and contrast, choose
Image>Adjustments>Brightness/Contrast to display the Brightness/
Contrast dialog box with the following settings:

■ Brightness slider decreases brightness when dragged to the left and
increases it when dragged to the right. You can adjust the setting from -100
to +100 and the current value is displayed above the right end of the slider
bar.

■ Contrast slider decreases contrast when dragged to the left and increases it
when dragged to the right. You can adjust the setting from -100 to +100 and
the current value is displayed above the right end of the slider bar.

■ Preview check box, when on, displays the effects of your adjustments on
the underlying image.

■ OK button applies the changes to the image. (Edit>Undo will undo them.)

■ Cancel closes the dialog box without applying your changes to the image.
Hold down Alt to change the button to Reset so you can click it to return all
settings to their defaults so you can try again.

TIP

■ When using
these commands
it’s much better if
you do so using a
Brightness/
Contrast adjust-
ment layer (page
116).

When exploring these
commands, display the
Histogram palette (page
57) so you can see how
your changes affect the
distribution of pixels.
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ADJUSTING LEVELS

One of the best tools Photoshop provides to adjust image tones is the Levels
command. Unlike the brightness and contrast commands (page 61) that
affect every pixel by the same amount, this command lets you adjust
highlights, midtones, and shadows independently of one another. Remem-
ber when using these tools that you can try various settings and at any point
undo them if you don’t like the results. Keep in mind that not every image
benefits from adjusting its levels. This is especially true for images that
already have pixels distributed at each level of brightness.

ADJUSTING LEVELS AUTOMATICALLY
When an image lacks contrast, but otherwise looks good, you can expand
the tonal range to make highlights lighter and shadows darker while
intermediate tones are shifted proportionately. To do so, select
Image>Adjustments>Auto Levels to redistribute the existing tones so they
cover the entire available tonal range. Because Auto Levels adjusts the red,
green, and blue color channels individually, the command may add or
remove color casts. If it introduces an undesirable color cast, undo the
command, and adjust the levels of individual color channels using the
Levels dialog box described below.

ADJUSTING LEVELS MANUALLY
When manually adjusting levels, you drag sliders as you watch the effects
you’re having on the image. This gives you a “what you see is what you get”
form of control that most photographers prefer.

The first step is to drag the outer two sliders so they are directly under the
tones on the histogram that you want to be pure white and pure black
without details—known as setting the white and black points. You can then
adjust the middle tones to make them lighter or darker. To begin, select
Image>Adjustments>Levels to display the Levels dialog box with the
following settings:

TIPS

■ With the Levels
dialog box open,
you can access the
scroll bars in the
image window,
select commands
on the View and
Window menus,
and zoom using the
keyboard shortcuts
Ctrl+ and Ctrl-.

■ When adjusting
levels it’s much
better to use an
adjustment layer
(page 116) so you
don’t change the
actual image.

■ Clipping refers
to pixels that are
shifted to the
lowest and highest
levels—0 and 255
where they become
pure black or pure
white without
details.

ADJUSTING LEVELS

The Color Sampler tool
can be used to place
color samplers in
neutral shadow and
highlight areas so you
can watch their values
as you make
adjustments to levels.
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■ Channel drop-down arrow lets you adjust the composite RGB image or
select individual red, green, and blue channels (page 58). Adjusting each
channel separately helps you remove color casts from images (page 68).

■ Input Levels text boxes on the left and right show the starting positions of
the black and white point sliders below the histogram. Initially the black
point slider is pointing to level 0 on the histogram and the white point is
pointing to level 255. The middle text box shows adjustments to the midtones
with the unadjusted value starting at 1.00. You can adjust levels by changing
the values in these boxes in one of three ways:

● Drag the input sliders located below the histogram.

● Type in values or click in the text box and press the up and down arrows
to change the value. (Hold down Shift while doing so to adjust by 10s.)

● Use the eyedropper tools (page 67).

■ Histogram shows the distribution of brightness in the image.

■ Input levels sliders adjust the image’s shadows, midtones, and highlights
so you can expand the tonal range of the image and make midtones lighter or
darker.

● Black point slider can be dragged directly under a tone that you want to
become pure black with no detail (0). As you drag it, visualize a line
dropping down from the pointer to the output levels gradient below. Any
tone from the imaginary line to the left will turn pure black without
details.

● Midtones slider (sometimes called gamma) adjusts itself automatically
as you drag the other two sliders but you can drag it to the left to lighten
the image or to the right to darken it. The shade on the gradient below the
pointer will become 50% gray. Using this control you can lighten or
darken the overall image without affecting the black and white tones and
the details they contain.

● White point slider can be dragged directly under a tone that you want to
become pure white with no detail (255). As you drag it, visualize a line
dropping down from the pointer to the output levels gradient below. Any
tone from the imaginary line to the right will turn pure white without
details.

■ Output levels text boxes and sliders set where the black and white points
fall on the grayscale. For example, when the input level for black is set to 0,
the black pixels will print as pure blacks. However, if you then change the
output level to 5, they will print as a very dark gray. This compresses the 256
tones into a smaller range so they will print on printing presses that aren’t
able to hold shadow or highlight detail at the extreme ends of the gamut.

■ Eyedroppers directly set the black, gray, and white points in an image.
Select the Set black point, Set gray point, or Set white point eyedropper and
click the area of the image you want to set with the chosen eyedropper and all
values in the image are immediately adjusted. For example, click the black
point eyedropper to select it and then click the area of the image you want
pure black. The black point eyedropper turns the clicked tone, and all darker
tones, into a brightness value of 0 and the white point eye dropper turns its
clicked tone, and all lighter tones to 255.

■ Preview check box, when on, lets you watch the image change as you
adjust levels.

The eyedroppers in the
Levels dialog box are
used to set black, gray,
and white points.

Some histograms have
tail-like pixels at the
black and white ends of
the histogram. These
indicate that few pixels
have those
brightnesses. Many
people like to drag the
sliders past these tails
to force them to pure
white or black.

The original histogram
(top), the sliders moved
(middle), and the tonal
range expanded
(bottom).

TIP

■ The output
sliders are not
usually used on a
fully color man-
aged system
because the
printer’s driver
makes the same
adjustment.
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■ OK applies your changes to the image and closes the dialog box.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset and you can click it
to restore levels to their original settings so you can try again.

■ Load/Save buttons display the Load and Save dialog boxes so you can save
settings for use with other images.

■ Auto applies either an Auto Color, Auto Contrast, or Auto Levels
correction, depending on the settings in the Auto Color Correction Options
dialog box displayed when you click the Options button.

■ Options displays the Auto Color Correction Options dialog box that sets
options for the Auto button above and other Auto commands.

USING THRESHOLD MODE
While positioning the input sliders to adjust the tonal range, you can see the
levels where black or white details begin to emerge in the image if you
Alt+drag the sliders.

■ As you hold the key down, drag the black point slider all the way to the left
so the image becomes totally white (or as close to it as possible). As you drag
it back to the right, colored specs emerge in the black field indicating the
locations of the darkest areas of the image.

■ While holding the key down, drag the white point slider all the way to the
right so the image becomes totally black (or as close to it as possible). As you
drag it back to the left, colored specs emerge in the white field indicating the
locations of the lightest areas of the image.

As you do this, you’ll find that there are often a number of places where you
can position the pointer. How do you choose among them? The best place for
the pointer is often at a point just after some black or white specs emerge but
before significant detail does because all of the areas that have emerged will
become pure white or black. You usually don’t want to force too many grays
to pure white or black because those areas will have no detail.

If you select a single color with the Channel drop-down arrow, the first black
areas to emerge against the color field indicate where none of the selected
color exists.

EVALUATING THE RESULT
After adjusting levels, you should reopen the Levels dialog box (Ctrl+L) to see
how the histogram changed. You’ll see that the pixels have been redistributed
over the entire tonal range.

■ In some cases there may be gaps between bars but these only indicate a
problem if they are large, perhaps 2 or more tones wide. These gaps are there
because adjusting levels can’t produce new tones, just redistribute the 256
that it already has. When gaps are too wide, the image looses smooth transi-
tions between some tones, an effect called posterization. If you look at the
gradient below the gap you can see which tones are missing. The gaps are not
nearly as bad when editing 16-bit images because they have so many more
tones to distribute.

■ Spikes at either end of the histogram (0 or 255) usually indicate that you
have forced too many pixels to pure black or white. This may indicate that
you have lost detail in the image because tones have been clipped.

Gaps in the histogram
indicate missing tones
that will affect the
smooth gradations in
the image.

The spikes at both ends
of the histogram
indicate detail has
probably been lost
because too many
pixels were forced to
pure white or black
(clipped).

The black threshold
(top) and white
threshold (bottom).

Clicking Auto displays
the Auto Color
Correction Options
dialog box.

ADJUSTING LEVELS
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ADJUSTING CURVES

The Curves command gives you the most control over tones, because you can
adjust up to 14 different point instead of the three that you can adjust with
Levels. To begin choose Image>Adjustments>Curves to display the Curves
dialog box with the following settings:

■ The Channel drop-down arrow lets you adjust the color balance of the
composite (RGB) or individual color channels.

■ The Curve is initially a straight diagonal line with the top representing
highlights, the middle midtones, and the bottom shadows. The two tone bars
graphically display the intensity values from 0 to 255 for RGB images with
black (0) at the bottom left corner. (You can flip the intensity values by
clicking the double arrow on the bar below the curve.)

● The horizontal axis of the graph represents the original intensity values
of the pixels (Input levels)

● The vertical axis represents the new color values (Output levels).

■ Input/Output readouts indicate the position of the pointer in the curve
window or of the selected control point on the curve.

■ Adjust curve by adding points button is on by default, but you can click
the Draw a curve with the pencil button to draw a curve. If you do draw one,
you can click the Smooth button to smooth it out.

■ OK applies your changes to the image and closes the dialog box.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset so you can click it to
restore levels to their original settings and try again.

■ Load/Save buttons display the Load and Save dialog boxes so you can save
settings for use with other images.

■ Smooth smooths a curve drawn with the Draw a curve with the pencil
button selected.

TIP

■ To edit a combi-
nation of color
channels at the
same time,
Shift+click the
channels in the
Channels palette
(page 58) before
opening the Curves
dialog box. The
selected channels
will be listed on the
Curves dialog box
Channel menu by
abbreviations —for
example, CM for
cyan and magenta.

TIP

■ When adjusting
curves it’s much
better to use an
adjustment layer
(page 116) so you
don’t change the
actual image.

The Adjust curve by
adding points and the
Draw a curve with the
pencil buttons.
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■ Auto applies either an Auto Color, Auto Contrast, or Auto Levels
correction, depending on the settings in the Auto Color Correction Options
dialog box displayed when you click the Options button.

■ Options displays the Auto Color Correction Options dialog box that sets
options for the Auto button above and other Auto commands.

■ Eyedroppers (from left to right include Set black point, Set gray point,
and Set white point. Eyedroppers are discussed on page 67.

■ Preview check box, when on, applies adjustments to the image as you
make them.

■ Size button enlarges and shrinks the Curves dialog box.

ADDING CONTROL POINTS TO THE CURVE
To adjust an image, you add up to 14 control points to the curve and then
drag them to adjust the tones they represent.

■ To add a control point along the curve, click directly on the curve.

■ To select a control point, click it so it is black. Shift+click to select multiple
points, and click in the grid or press Ctrl+D to deselect all points. Press
Ctrl+Tab to move forward through control points and Shift-Ctrl+Tab to move
backwards.

■ To move a selected control point (selected points are black), drag it, press
the arrow keys on the keyboard or type values into the Input or Output text
boxes.

■ To adjust or preserve a specific tonal area of the image, Ctrl+click a pixel
in that area of the image to add a control point to the curve and then don’t
move that point.

■ To see where a pixel in the image falls on the curve, Alt-click it.

■ To locate the lightest and darkest areas in an RGB image, hold down the
mouse button as you drag over the image. The intensity values of the area
under the pointer, along with the corresponding location on the curve, are
displayed in the dialog box.

■ To change the fineness of the grid, Alt+click it.

■ To remove a control point, drag it off the graph, select it and press Delete,
or Ctrl+click it. You cannot delete the endpoints of the curve.

■ To draw a curve, select the pencil at the bottom of the dialog box, and
drag to draw a new curve. You can Shift+click to add straight segments.
When you’re finished, click Smooth to smooth the curve.

ADJUSTING THE CURVE
Changing the shape of the curve adjusts the tones and colors in the image. In
most cases only small adjustments are needed—larger ones occasionally
cause bizarre effects. As you make changes, watch the effect on the image. If
you want to start over, hold down Alt and click Reset. As you add points to
the curve, you can drag those representing areas you want to change and
leave alone those you want to remain as-is. Since points on the curve remain
anchored until you move them, you can make an adjustment in one tonal
area while other areas remain unaffected. Below are listed ways to adjust the
curve, assuming it is in its default state with highlights at the top and shad-
ows at the bottom.

Dragging the curve
upward lightens the
image.

Dragging the curve
downward darkens the
image.

ADJUSTING CURVES

To adjust the white or
black points, drag the
top end point to the left
or the bottom end point
to the right.

An S-curve lightens the
highlights and darkens
the shadows increasing
the image’s contrast.
The steeper section of
the curve represents
portions of an image
with more contrast and
flatter sections
represent areas of lower
contrast.
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■ To lighten the image, click a point and drag the curve to bow it upward as
you watch the effect on the image.

■ To darken the image, click a point and drag the curve to bow it downward
as you watch the effect on the image.

■ To adjust highlights, click a point toward the top of the curve and drag it
down or to the right to darken them, or up and to the left to lighten them.

■ To adjust midtones, click a point in the middle of the curve and drag it
down or to the right to darken them, or up and to the left to lighten them.

■ To adjust shadows, click a point toward the bottom of the curve and drag it
down or to the right to darken them, or up and to the left to lighten them.

■ To move the white or black points, drag the top end point to the left or the
bottom end point to the right.

Dragging points on the
curve up or to the left
lightens an area.
Dragging down or to the
right darkens it.

Here a photo of the
Brooklyn Bridge in New
York City was too gray
(top). By adjusting the
curve (bottom), the
image was made to look
more like the foggy day
on which it was taken.

Dramatic changes in the
curve cause dramatic
changes in the image.

Selected control points
are black and
unselected ones are
white.
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USING EYEDROPPERS

The eyedropper tools in the Levels and Curves dialog boxes can set the black
and white points, adjust tones, and even remove color casts. When using
these tools, here are some things to think about:

■ The eyedropper tools undo any previous adjustment you’ve made in
Levels or Curves so use them first, and then tweak your adjustments with
the Levels sliders or Curves control points.

■ The Set Gray Point Eyedropper tool is used primarily for color correction
and is unavailable when working with grayscale images.

■ These tools work best on images that require only small changes. One
problem with them is that when you click a pixel in the image the tonal
values of all pixels shift higher or lower by the same amount so some pixels
may get clipped. This is unlike the Input Levels sliders and the Curves end
points that set the black point in an image while preserving most of the
tonality in the highlights and set the white point while preserving most of
the tonality in the shadows. Further, both Levels and Curves allow you to
make midtone adjustments without affecting either the black or white
points.

SETTING THE BLACK AND WHITE POINTS
Two of the eyedropper tools are used to set the black or white points in an
image. The left eyedropper shifts the tonal value of a clicked pixel to the
black point (0) and the right one shifts it to the white point (255). The values
of all other pixels in the image are shifted the same amount.

1. To begin, do the following before opening the Levels or Curves dialog box:

● Select View>Actual Pixels to make sure you are viewing the image’s true
colors and tones as you adjust them.

● Select the eyedropper tool in the toolbox, click the Sample Size drop-
down arrow on the options bar, and select 3 by 3 Average to ensure a
representative sample of a 9-pixel square instead of a single pixel.

● Select Window>Info to display the Info palette so it floats in the image
area so you can measure the average brightness of the 9-pixel square you
point to. Even if your monitor isn’t adjusted correctly, these measure-
ments are accurate.

2. To display the Levels or Curves dialog box, select Image>Adjustments
and then select Levels or Curves.

3. To set the black and white point, do the following:

● To set the black point, select the Set black point eyedropper in the
dialog box and click any pixel in the image that you want to shift to pure
black without any detail.

● To set the white point click the Set white point eyedropper in the dialog
box and click any pixel in the image that you want to shift to pure white
without any detail.

As you click areas, the tone under the pointer and all identical tones through-
out the image become pure black or pure white and all other tones adjust
proportionately. If you don’t like the results, hold down Alt, click Reset in the

The info palette with the
left side showing the
RGB values under the
mouse pointer.

TIPS

■ The first few
levels of white
should be re-
stricted to specular
highlights such as
reflections and
bright lights.

■ Once you find
settings that work
best with your
printer, you can
save them as
defaults.

The eyedroppers in the
Levels and Curves
dialog boxes are used to
set black, gray, and
white points.

USING EYEDROPPERS
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The color picker.

Levels or Curves dialog box, and try again. As you point to areas in the
image, the Info palette shows two values—for example, 220/240. The first
number is the color’s value before the adjustment and the second number
shows the color value afterwards.

If you want to change the tone associated with any of the eyedroppers, you
can double-click them to display the color picker (page 126).

REMOVING A COLOR CAST
You can use the middle eyedropper tool in the Levels or Curves dialog boxes
to correct a color cast. To begin, select Window>Info to display the Info
palette and locate an area in the midtones that should be neutral. If you can
remove a color cast from that area, all other colors in the image should also
be color balanced.

To locate neutral tones in the image, point to areas that should be white,
gray, or black as you read their R, G, and B values in the Info palette. What
you are looking for is a color that has equal R, G, and B values. If you can find
where all three values are identical, the neutral tone has no color casts.
However, you may find tones that are not perfectly neutral but perhaps
something like 128,135, 126. When you find a tone such as this, select the
middle Set Gray Point eyedropper and click on that spot in the image. It
averages the three values so brightness doesn’t change but uses that average
to set all three values to the same tone. If the image shifts too much, you
clicked the wrong spot. Alt+click Cancel to restore the default values and try
again. (If you locate the tone before opening the Curves or Levels dialog box
you can use the Color Sampler tool to mark up to four spots of interest and
monitor changes to them on the Info palette.

The Color Sampler tool
was used to place two
color samplers in
neutral shadow and
highlight areas. The
color values for the two
samplers are listed in
the Info palette.
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ADJUSTING SHADOWS AND HIGHLIGHTS

The Shadow/Highlight command adjusts images where the foreground
subject is underexposed and too dark because of a bright backlight or overex-
posed and too light because it was too close to the flash. It is also good at
bringing details out of dark backgrounds. Unlike the Brightness and Contrast
commands that adjust all tones equally, this command lightens or darkens
shadows or highlights independently and adjusts them based on the bright-
ness of surrounding pixels.

THE BASIC SETTINGS
To begin adjusting shadows and highlights, select Image>Adjustments>
Shadow/Highlight to display the Shadow/Highlight dialog box with the
following controls:

■ Amount sliders and text boxes adjust the brightness of shadows and
highlights. The defaults are set to adjust backlighting problems.

■ OK applies your changes to the image and closes the dialog box.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset so you can click it to
restore the original settings and try again.

■ Load/Save buttons let you save your settings for use with other images.

■ Preview check box, when on, updates the image as you make adjustments.

■ Show More Options check box, when on, displays additional sliders and
other settings that give you finer control over shadow or highlight adjust-
ments.

MORE OPTIONS
When you turn on the Show More Options check box, you gain access to the
following controls in addition to the ones discussed above.

■ Tonal Width, available for both shadows and highlights and initially set to
50%, determines the range of tones that are adjusted.

● Small values limit adjustments to the extreme light and dark areas. As
you increase the setting, you expand the range, even into the midtones. If
your adjustments introduce halos around high contrast edges, reduce the
values.

ADJUSTING SHADOWS AND HIGHLIGHTS
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● 100% gives a linear effect where deep shadows are modified the most,
there is no correction to bright highlights, and half the shadow correction
is applied to midtones.

■ Radius, available for both shadows and highlights and initially set to 30
pixels specifies the size of the surrounding area used to determine if a pixel is
in the shadows or highlights. Since the ideal Radius setting varies from
image to image, you have to experiment. You'll find that if you set the Radius
too large, the adjustment affects the entire image instead of the intended
area. To achieve this, try setting the radius to the same size as the area of
interest in the image.

■ Color Correction slider fine tunes color saturation in areas of the image
that you have adjusted with an Amount slider. Its effects depend on how
much the Amount was changed. (To adjust color saturation over the entire
image, use the Hue/Saturation command (page 71) after applying the
Shadow/Highlight command.)

■ Brightness, available only when adjusting a grayscale image, lightens or
darkens the image.

■ Midtone Contrast slider increases or decreases the image’s contrast in the
midtones and often darkens shadows and lightens highlights.

■ Black Clip and White Clip text boxes specify how wide a range of shadow
and highlight pixels will be shifted to pure white or pur black without details
(clipped). Larger values increase contrast but reduce detail in the shadows or
highlights.

■ Save As Defaults button makes your current settings the defaults when you
next use the command. To restore the original defaults, Shift+click the Save
As Defaults button.
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■■■■■ Original and Current Pick images at the top of the dialog box make it easy
to see the effects of your changes. To apply changes to the Current Pick
image, click the thumbnails in the lower part of the screen. The seven to the
left change colors and the three to the right change brightness.

■■■■■ Shadows, Midtones, or Highlights option buttons let you confine your
adjustments to the dark, middle, or light areas of the image. When removing
a color cast, first try adjusting Midtones.

■■■■■ Saturation option button lets you adjust the richness of colors in the
image.

■■■■■ Fine/Course slider specifies the amount or intensity of each adjustment.
Dragging the slider to the left decreases the amount, and dragging to the
right increases it. Set it low because you can strengthen the effect just by
clicking a thumbnail multiple times. Moving the slider one tick mark doubles
the adjustment amount.

ADJUSTING COLOR

Since color is so important in digital images, you are provided with a variety
of tools to enhance it or make it more accurate.

ADJUSTING COLOR AUTOMATICALLY
The Image>Adjustments>Auto Color command adjusts the contrast and
color by identifying shadows, midtones, and highlights in the composite
image and not the individual red, green, and blue channels.

USING THE VARIATIONS COMMAND
The Variations command lets you visually adjust colors and works best on
images that don’t require major or precise color adjustments. To begin
choose Image>Adjustments>Variations to display the Variations dialog box
with the following settings:

TIPS

■■■■■ To adjust the
entire image, make
sure nothing is
selected (page 86).

■■■■■ To adjust only a
single layer, select
that layer in the
Layers palette
(page 104).

■■■■■ To adjust just a
portion of your
image, select that
portion (page 86)
or create a mask
(page 146).

TIPS

■■■■■ One color cannot
be adjusted with-
out affecting
overall color
balance.

■■■■■ You can’t use the
Variations com-
mand with images
in Indexed Color
mode.

■■■■■ The Levels (page
61) and Curves
(page 64) dialog
boxes have Chan-
nel drop-down
arrows so you can
select the compos-
ite RGB channel or
select the Red,
Green, or Blue
channel to adjust
only a single color.

■■■■■ After making
color corrections,
select Edit>Fade ...
to adjust them.

ADJUSTING COLOR
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■■■■■ Show Clipping check box, when on, highlights (in neon) tones that will be
clipped by the adjustment. Clipping should be avoided because it can cause
undesirable color shifts as distinct colors get merged into the same color.
Clipping does not occur when you adjust midtones.

■■■■■ Load/Save buttons lets you reuse your Variation settings with other
images.

■ OK applies your changes to the image and closes the dialog box.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset so you can click it to
restore the original settings and try again. (You can also click the Original
thumbnail to remove adjustments.)

Once you have adjusted settings, you click thumbnails to adjust color and
brightness in the image:

■■■■■ To add a color to the image, click the appropriate color thumbnail.

■■■■■ To subtract a color, click the thumbnail for its opposite color. For ex-
ample, to remove red, click the More Cyan thumbnail. The six color thumb-
nails are arranged in a circle around the central Current Pick with comple-
mentary colors opposite each other. If you click one thumbnail to add color
and then click the one diagonally opposite it to add its complementary color,
the two changes cancel each other out.

■■■■■ To adjust brightness, click one of the thumbnails on the right side of the
dialog box.

The effects of clicking the thumbnails are cumulative so clicking a color
thumbnail twice applies the color twice. Also, each time you click a thumb-
nail, the other thumbnails change and the three Current Pick thumbnails
always reflect the current status.

USING THE HUE/SATURATION COMMAND
The Hue/Saturation command adjusts the hue, saturation, and lightness of
an image. To begin, select Image>Adjusment>Hue/Saturation to display the
Hue/Saturation dialog box with the following settings:

TIP

■■■■■ You can also use
adjustment layers
(page 116) to make
the following
adjustments
discussed in this
section:

● Hue/Saturation
● Color Balance
● Photo Filter

The Colorize check box
was turned on to make
a full color image (top)
look like an old albumen
photo (bottom).

Complementary colors
are opposite each other
on a color wheel. The
pairs you can adjust
include Cyan-Red,
Magenta-Green, and
Yellow-Blue. As you
increase one color in the
pair, you decrease the
other.
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■■■■■ Edit drop-down arrow lets you choose which colors to adjust. Master (the
default) adjusts all colors at once.

■ Hue slider adjusts the color—what we normally refer to by names such as
red or blue.

■■■■■ Saturation slider adjusts the purity of a color by changing the amount of
gray mixed in with the hue.

■■■■■ Lightness slider adjusts how light or dark a color is and can be set between
–100 and +100.

■ OK applies your changes to the image and closes the dialog box.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset so you can click it to
restore the original settings and try again.

■ Load/Save buttons let you reuse your settings with other images.

■■■■■ Colorize check box, when on, replaces all colors in the image with a single
hue, perhaps to make the image look like an old albumen print.

■ Preview check box, when on, updates the image as you make adjustments.

USING PHOTO FILTERS
There is no longer a need to buy and use lens filters because Photoshop’s
Photo Filter command applies the same effects after a picture has been taken
and you can keep the original image unaltered for other uses. To begin, select
Image>Adjustments>Photo Filter to display the Photo Filter dialog box with
the following settings:

■ Filter text box displays the named filter being applied to the image. You
can click the drop-down arrow to select a Warming Filter (85) that adds
yellow, a Cooling Filter (80) that adds blue, and other color filters that adjust
hues.

■ Color option button applies a filter having the color shown in the swatch to
its right. To change the color you click the swatch to display the color picker
(page 126).

■ Density slider or text box adjusts the amount of color applied to the image,
A higher value applies a stronger filter adjustment.

TIPS

■ The two color
bars in the Hue/
Saturation dialog
box represent the
colors in their
order on the color
wheel. The upper
bar shows the color
before the adjust-
ment; the lower bar
shows how the
adjustment affects
all hues at full
saturation. When
you click the Edit
drop-down arrow
and select any
color other than
Master, an adjust-
ment slider ap-
pears between the
color bars so you
can adjust the
range of color and
its fall-off that are
beyond the scope
of this book.

■ The Sponge tool
adjusts the satura-
tion of colors you
drag over.

■ It’s better to use
the Photo Filter
adjustment layer
(page 116).

ADJUSTING COLOR

The Photo Filter
command does what
glass filters do when
placed on the camera
lens when the picture is
taken. Courtesy of
Rodenstock.
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■ Preserve Luminosity check box, when on, keeps the image from being
darkened by the filter you apply.

■ OK applies your changes to the image and closes the dialog box.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset so can click it to
restore the original settings and try again.

■ Preview check box, when on, updates the image as you make adjustments.

REMOVING COLOR
You can remove all color from an image, perhaps to make it look like a black
and white photo. The Image>Adjustments>Desaturate command converts
colors to their grayscale equivalents without affecting their brightness. This
command has the same effect as setting Saturation to –100 in the Hue/
Saturation dialog box (page 72).

ADJUSTING COLOR BALANCE
The Color Balance command lets you adjust the mixture of colors in an
image. To begin, select Image>Adjustments>Color Balance to display the
Color Balance dialog box with the following settings:

■■■■■ Cyan, Magenta, and Yellow sliders increase one color while decreasing its
complementary color. For example, increasing red decreases cyan. The
values above the color bars show the amount of change from -100 to +100.

■■■■■ Shadows, Midtones, or Highlights option buttons specify which tonal
range will be adjusted.

■■■■■ Preserve Luminosity check box, when on, prevents luminosity from
changing when you adjust color.

■ OK applies your changes to the image and closes the dialog box.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset so you can click it to
restore the original settings and try again.

■ Preview check box, when on, updates the image as you make adjustments.

Complementary colors
are opposite each other
on a color wheel. The
pairs you can adjust
include Cyan-Red,
Magenta-Green, and
Yellow-Blue. As you
increase one color in the
pair, you decrease the
other.

TIP

■■■■■ You can only use
the Color Balance
command when
the composite RGB
channel is selected
in the Channels
palette (page 58).
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USING FILTERS

When people first get their hands on Photoshop, they quickly discover filters.
Since one of the most interesting things to do with digital images is to
manipulate or modify them in some way, filters are a great place to start.
Many, such as the unsharp mask filter (page 78) are used to make your
images look more like the original scene. However, many others can make
photos look like paintings, stained glass windows, or other objects. The can
emboss images, twist and twirl them, add textures, and create all kinds of
creative havoc. Filters are easy to use, you just select one and sit back and
watch your computer go to work. If you don't like the result, just select
Edit>Undo and change some of the filter’s default settings or try another
filter. And don't stop with just one filter, use two or more in succession on
the same image and watch as it moves further and further from reality. You
can always use the History palette to undo the changes or just abandon the
file without saving it.

You can apply filters using commands on the Filter menu or using the Filter
Gallery. Since the gallery shows thumbnails of the filter effects, it provides a
more visual way to work with filters and gives you more control. However,
not all filters can be applied using the Filter Gallery.

USING THE FILTER MENU
When you pull down the Filter menu, it displays names for filter groupings.
As you highlight each group name the menu cascades to display the actual
filters you can select. If a filter’s name is followed by ellipses (...), selecting it
displays a Filter Options dialog box. The topmost menu listing is the most
recently used filter in the current session. If any plug-in filters developed by
third parties are installed, they are generally listed at the bottom of the Filter
menu unless the developer has specified another location. When you select a
filter, there are three possible outcomes. The effect is applied immediately,
the Filter Gallery is displayed, or a dialog box specific to the filter appears. If
a dialog box specific to the filter appears, you can use many of the same
controls described for the Filter Gallery below.

USING THE FILTER GALLERY
Using the Filter Gallery, you can apply more than one filter to create a
stacked filter effect. You can also rearrange filters and change the settings of
each filter you’ve applied to achieve the effect you want.

The Filter Gallery dialog box has three main panels. A preview window on
the left, thumbnails of filters in the middle, and adjustments for the selected
filter on the right, below which is a list of applied effects. To begin choose
Filter>Filter Gallery to display the Filter Gallery with the following settings:

■ The Preview window in the left panel displays the image and the effects
that filters have on it.

● To zoom the preview, click the + or - button under the image. You can
also click the nearby triangle and select a preset zoom.

● To scroll an enlarged image, point to it and drag with the Hand tool.

● To center an area of an enlarged image in the preview window, click
the area of the image (although this doesn’t always work).

A Filter options dialog
box.

The Filter menu.

USING FILTERS
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■ The filter thumbnails in the middle panel give you some idea of each
filter’s effects.

● To expand and collapse a category of filters, click the triangle icon in
its heading.

● To apply a filter, select its thumbnail and make adjustments in the right
panel. (You can also select filters by clicking the Filters drop-down arrow
in the right panel where the currently selected filter is listed.) A progress
bar below the preview indicates how long it takes to apply the filter to the
preview. To apply the filter to the image and add it to the list of applied
filters below the settings, click the New effect layer button at the bottom
of the panel.

● Show/Hide button to the left of OK shows and hides the filters thumb-
nails and expands the preview area. When thumbnails hidden you can
select filters by clicking the Filters drop-down arrow.

■ OK applies your selected filters to the image and closes the dialog box.

■ Cancel closes the dialog box without applying filters to the image. Alt+click
the button to reset the settings without closing the dialog box so you can start
over.

■ List of applied filters at the bottom of the right panel is used to manage
filters. The name of any filter you select is listed against a dark background.
Once you click the New Effect Layer button to apply it, its name is listed
against a white background.

● To hide a filter’s effect on the preview, click the eye icon next to it.

● To rearrange filters drag and drop them into new positions. Their
effects are applied to the image in the order you arrange them—bottom
one first.

● To delete an applied filter, drag and drop it onto the Delete effect layer
button below the list or select the filter and click the button.

TYPES OF FILTERS
There are so many filters most people don’t start by reading about them, but
by jumping in and trying them, and watching as amazing things happen.
When you see an effect you like, look up the filter’s name in help for more
information. Many digital photographers spend their entire careers without
having used or cared about most of these filters. In fact, the only groups that

TIPS

■ To see what
filters are available
on your system,
pull down the Help
menu and click
About Plug-in.
Click any plug-in
to learn more
about it.

■ To save time
when trying
various filters,
experiment by
selecting a small,
representative part
of your image
before displaying
the Filter Gallery.

After applying filters,
you can select
Edit>Fade... to vary the
effect.

The New effect layer
and Delete effect layer
button icons.

Filter categories can be
collapsed (top) or
expanded (bottom).

The Show/Hide button
shows and hides the
filter thumbnails.
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Original image.

Plastic Wrap filter.

Watercolor filter.

Find edges filter.

all digital photographers should understand are those in the sharpen and
noise groups.

■ Artistic filters appeal to photographers who like the accolade “Ohhh, your
photo looks just like a painting!” (Not all photographers consider this a
compliment.) They make photos look like they were done is some other
medium. The filters in this group include Colored Pencil, Cutout, Dry Brush,
Film Grain, Fresco, Neon Glow, Paint Daubs, Palette Knife, Plastic Wrap,
Poster Edges, Rough Pastels, Smudge Stick, Sponge, Underpainting, and
Watercolor.

■ Blur filters soften the image or selected areas. The filters in this group
include Average, Blur, Blur More, Gaussian Blur, Lens Blur, Motion Blur,
Radial Blur, and Smart Blur.

■ Brush Strokes filters, like Artistic filters, make a photo look as if it was
done in another medium. The filters in this grouping include Accented
Edges, Angled Strokes, Crosshatch, Dark Strokes, Ink Outlines, Spatter,
Sprayed Strokes, and Sumi-e.

■ Distort filters apply wild and weird affects. The filters in this group include
Diffuse Glow, Displace, Glass, Ocean Ripple, Pinch, Polar Coordinates,
Ripple, Shear, Spherize, Twirl, Wave, and ZigZag.

■ Noise filters are often used to blend selections or hide dust, scratches, or
other defects. The filters in this group include Add Noise, Despeckle, Dust &
Scratches, and Median.

■ Pixelate filters work by clumping pixels of similar color. The filters in this
group include Color Halftone, Crystallize, Facet, Fragment, Mezzotint,
Mosaic, and Pointillize.

■ Render filters work with 3D shapes, cloud and refraction patterns, and
light reflections. The filters in this group include Clouds, Difference Clouds,
Fibers, Lens Flare, and Lighting Effects.

■ Sharpen filters increase the contrast of adjacent pixels to make edges look
sharper. The filters in this group include Sharpen, Sharpen Edges, Sharpen
More, and Unsharp Mask.

■ Sketch filters add texture, and like artistic and brush stroke filters, make
photos look as if they were done in another medium. The filters in this group
include Bas Relief, Chalk & Charcoal, Charcoal, Chrome, Conté Crayon,
Graphic Pen, Halftone Pattern, Note Paper, Photocopy, Plaster, Reticula-
tion, Stamp, Torn Edges, and Water Paper.

■ Stylize filters make photos look like they were done in another medium.
The filters in this group include Diffuse, Emboss, Extrude, Find Edges,
Glowing Edges, Solarize, Tiles, Trace Contour, and Wind.

■ Texture filters create effects that make photos look like they were done in
another medium. The filters in this group include Craquelure, Grain, Mosaic
Tiles, Patchwork, Stained Glass, and Texturizer.

■ Video filters improve images captured on video or reduce the color palette
of an image to those used for television reproduction. The filters in this group
include De-Interlace and NTSC Colors.

■ Other filters perform a number of tasks most people don’t understand. The
filters in this group include Custom, High Pass, Maximum, Minimum, and
Offset.

TIPS

■ Before using any
Blur filter, turn off
the Lock transpar-
ent pixels check
box in the image’s
Layers palette
(page 105).

■ Many of the
Sketch filters use
the foreground and
background colors
as they redraw the
image.

■ Most filters
cannot be applied
to 16-bit images.
Select Image>
Mode to convert an
image to 8-bits.

USING FILTERS
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SHARPENING IMAGES

Most photos captured with a digital camera or a scanner can be improved by
sharpening. There are a number of ways to do this, the best being the un-
sharp mask filter.

USING UNSHARP MASKING
Unsharp masking sharpens edges in an image and is so common many high-
end cameras and scanners have embedded software that does it automati-
cally. You'll find that this procedure can make a tremendous difference in
photos, especially those that you print. However, as nice as it would be, this
filter can’t fix a badly blurred image.

So how does the Unsharp Mask filter work? First it locates pairs of adjacent
pixels that have a difference in brightness that you specify—the threshold. It
identifies these as edges, and increases their contrast by the amount you
specify. The change affects not only the pair of pixels, but also any that fall
within a specified radius. The result is higher contrast at the edges that
makes them look sharper. The effects of the Unsharp Mask filter are far more
pronounced on-screen than in high-resolution prints, so experiment to
determine what settings work best for your image.

One of the limitations of unsharp masking is its ability to accurately identify
edges. In some cases it finds and sharpens edges where there are none. It this
case it degrades the image rather than improves it. To reduce these un-
wanted effects, you can adjust the threshold or radius. Also, be sure not to
oversharpen or you will create halos around edges. As with most other things
in life, moderation is good.

The top image hasn’t
been sharpened, the
bottom one has been—
exaggerated here for
effect.

An unsharpened image
(left) has low contrast
along the edges of
objects. The unsharp
mask filter finds these
edges and increases the
contrast making the
dark areas darker and
the light areas lighter
(right).

To sharpen an image select Filter>Sharpen>Unsharp Mask to display the
Unsharp Mask dialog box with the following settings:

■ The preview window shows you a section of the image you are sharpening
so you can see the effects.

● Drag in the preview window to scroll around the image.

● Click + or – to zoom in or out.

● Click the preview repeatedly and rapidly to toggle the effect of sharpen-
ing on and off so changes jump out at you.

TIPS

■ Unsharp mask-
ing dates back to
the darkroom era
when images could
be sharpened by
aligning the
original negative in
the enlarger with a
slightly blurred and
underexposed copy
of the same nega-
tive.

■ When sharpen-
ing, display the
image at 100%.
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■ Amount is the percentage by which contrast of the edge pixels is increased.
When printing high-resolution digital photos, an amount between 100% and
200% usually works well, but you can go as high as 500% and as low as 1%.

■ Radius is the number of pixels around the edge that are sharpened. Lower
values sharpen only edge pixels and as you increase the value, a wider range
of pixels gets sharpened. Higher values are better for larger images than they
are for smaller ones. To begin, you might try a radius between 1 and 2 pixels.

■ Threshold is the difference in brightness between two pixels before they
are considered edge pixels to be sharpened by the filter. When set to 0, all
pixels in the image are sharpened. In some cases, such as images with flesh
tones, this can introduce noise because every pore is sharpened. In these
cases, you might want to experiment with higher thresholds, perhaps be-
tween 2 and 20.

■ OK applies your changes to the image and closes the dialog box.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset so you can click it to
restore the original settings and try again.

■ Preview check box, when on, updates the image as you make adjustments.
This lets you see the effects of sharpening on the actual image, not just the
dialog box’s preview.

OTHER SHARPENING FILTERS
In addition to the unsharp mask filter, there are other filters that affect
sharpness in an image. Unlike the unsharp mask filter, these filters are
automatic and don’t let you control their effects. To apply one of thee filters
select Filter>Sharpen to display a submenu, then select one of the following.

■ Sharpen and Sharpen More sharpen the image with Sharpen More having
a stronger sharpening effect.

■ Sharpen Edges sharpens edges without affecting smooth areas in the
image.

TIPS

■ If your camera
has a control to
sharpen images,
turn it off if you
plan on editing
them in Photoshop.

■ When sharpen-
ing, it helps if you
start with some
standard settings
and then experi-
ment from there. It
seems every
photographer
recommends a
different starting
point, so here’s
ours:

● Amount=100
● Radius=1
● Threshold=2

■ Unsharp mask-
ing only affects the
selected layer. To
sharpen a multi
layer image you
may need to flatten
the layers (page
111).

■ You can sharpen
just part of your
image using a mask
(page 146).

The unsharp mask filter
lets you specify the
amount, radius, and
threshold of sharpening.

SHARPENING IMAGES
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THE CAMERA RAW PLUG-IN—INTRODUCTION

Many digital cameras let you capture images in a RAW format instead of the
more widely used JPEG format. The RAW format gives you the highest
possible image quality because it stores all of the original image data, but
doesn’t process, convert, and compress it in the camera—actions that perma-
nently reduce the amount of information available. Instead, the RAW format
lets you interpret the image data in any number of ways on your computer
without in any way affecting the original file.

When you use the File>Open command or File Browser to open a RAW file,
the Photoshop Camera Raw plug-in opens if the file’s RAW format is sup-
ported. (Every camera company has their own version.) A large preview of
the image is displayed, as is its histogram. The plug-in contains a variety of
tools and controls that adjust the image before clicking OK to open a copy of
the RAW file in Photoshop with your settings attached. The original image
remains on the disk, unaffected in any way.

Here is what each tool or control in the plug-in is used for:

LEFT OF THE PREVIEW WINDOW
■ Zoom tool lets you click the preview to zoom in, Alt-click to zoom out, or
drag to select the area to be zoomed. You can also adjust zoom with the zoom
text box and drop-down arrow below the preview.

■ Hand tool moves the preview image when it is larger than the viewing
window. Hold down the spacebar to access this tool temporarily when
another tool is selected.

■ White Balance tool (the eyedropper) can quickly set white balance when
you use it to click an area of the image that should be white with detail (not a
specular highlight with no detail) or neutral gray. In most cases this is the
best tool to start with when removing a color cast or tint from an image. You
can then fine tune the results with the Temperature and Tint sliders.

TIPS

■ Raw images are
discussed in detail
in The Textbook of
Digital Photogra-
phy and that
lengthy discussion
is not repeated
here.

■ Cameras that
offer the RAW
image format also
supply software to
edit and convert
them. Raw process-
ing software is also
available from
PhaseOne and
other third-parties.

■ Photoshop’s Raw
format is not the
same as a camera
raw format and is
used primarily to
transfer images
between systems.

■ When making
adjustments, zoom
the image to 100%
so you can best see
the effects of your
changes.

■ You can select
more than one
RAW file in the File
Browser and then
double-click one of
them to open them
one after another
in the plug-in.

■ To open a RAW
image directly into
Photoshop, hold
down Shift when
you double-click it.
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BELOW THE PREVIEW WINDOW
■ Zoom menu drop-down arrow displays a menu from which you can
choose a zoom setting. When making adjustments, 100% is the best setting to
use.

■ Preview check box enables or disables the preview. When off, the original
image is displayed, without the applied image setting adjustments. Clicking it
on and off makes it easy to compare before and after previews.

■ R, G, and B values are displayed when you point to any area of the image
with the Zoom, Hand, or White Balance tool and pause.

■ Rotate buttons rotate the preview image.

■ Space specifies which color space is attached to the image when you open
it in Photoshop. The space is initially assigned to the image by the camera but
you can change it here, or later in Photoshop (page 187).

■ Size specifies the size of the image in pixels when you open it in Photoshop.
You can click the drop-down menu to resample the image larger or smaller
than its captured size.

■ Depth specifies the color depth of the image when you open it in
Photoshop. One of the advantages of RAW images is that they are 16-bit and
not 8-bit images. If you plan further editing in Photoshop, you should keep
them as 16 bit images. These files are large but give you many more tones to
work with. Once in Photoshop, should you need to reduce an image to 8 bits,
select Edit>Mode>8 bits/Channel.

■ Resolution specifies how many dots per inch (dpi) are used to print the
photo. This setting has no effect on the total number of pixels in the image.

RIGHT OF THE PREVIEW WINDOW
■ OK button serves multiple uses:

● Click it to open a copy of the camera raw image file in Photoshop with
your adjustments applied. You can then edit the image farther and save it
in a Photoshop-supported format.

● Hold down Alt and the button changes to Update. Click it to update the
image in the plug-in without opening it in Photoshop. Both the image and
thumbnail reflect the update. To restore the original settings, click the
Settings drop-down arrow and select Camera Default.

● Hold down Shift and the button changes to Skip. Click it to skip the
current image when you are opening more than one.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset so you can click it to
restore the original settings and try again.

■ Basic/Advanced option buttons hide or display the Lens and Calibrate tabs
and a few commands on the plug-in menu.

■ Settings drop-down arrow lets you select which settings to apply. Your
choices always include Selected Image, Camera Default, Previous Conver-
sion (using the settings from the previous conversion of an image captured
by the same camera), and Custom below which are listed any settings you
have saved. The Selected Image setting changes to First Selected Image
when opening more than one image, and when selected the settings from the
image selected first are applied to other images in the batch.

You can apply saved
settings to one or more
RAW files that you
select in the File
Browser. Just pull down
the Automate menu, or
right-click one of the
selected files and select
Apply Camera RAW
Settings.If you click the
Advanced button in the
dialog box that appears,
all settings are
displayed (below) so
you can adjust them.

The plug-in’s Settings
menu.

THE CAMERA RAW PLUG-IN—INTRODUCTION

TIP

■ The only camera
settings that affect
the actual RAW
image are the
aperture, shutter
speed, and ISO. All
other settings can
be applied on the
computer using
Photoshop.
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■ Histogram shows all three channels (Red, Green, and Blue) of the image
simultaneously and is automatically updated as you adjust settings.

■ Tabs section contains drop-down arrows, text boxes, and slider bars that
you use to adjust an image (page 83). The Adjust and Detail tabs are always
displayed but the Lens and Calibrate tabs are only displayed when the
Advanced option button is selected.

THE PLUG-IN’S MENU
When you use the plug-in to make changes to a RAW image, the original
image data is not affected. (In fact there is no way to overwrite the original
RAW image with an altered version.) Instead, any changes you make to the
image are stored and then applied to a copy of the image that opens in
Photoshop. The settings used with one image can also be saved and used with
other images. This is very useful if you have a number of images from the
same camera or taken in the same light, that need the same or similar
corrections. The settings that affect the way changes are saved, set prefer-
ences, or save settings for use with other images, are on the plug-in’s menu
displayed when you click the triangle icon to the right of Settings. The menu
has the following choices:

■ Load Settings loads previously saved settings.

■ Save Settings saves the current settings and adds them to the plug-in’s
Settings menu so you can use them with other images.

■ Save Settings Subset, available only when the Advanced option button is
selected, is like above but displays a dialog box so you can select which
settings to save. For example, you can save just a specific white balance or
sharpness setting.

■ Delete Current Settings deletes any custom setting that you have saved
previously and then selected for use with the current image. You can’t delete
any of the named settings supplied with Photoshop.

■ Set Camera Default replaces the default settings supplied by Adobe for
your camera model with your own settings. If you use more than one camera
model, you can have a default setting for each.

■ Reset Camera Default restores the Set Camera Default setting to the
original default settings supplied by Adobe.

■ Preferences, available only when the Advanced option button is selected,
offers the following choices:

● Save settings in specifies if the settings are saved in a Camera Raw
database or in a Sidecar ~.xmp~ files. Those stored in a database (the
default) will remain attached to a file even if you rename or move it
elsewhere on the system. However, if you are moving images to CD/DVD
or sharing them with others, sidecar files, automatically generated when
you edit the image and having the same name but .xmp extension, can be
sent along with them so the settings are also applied on other systems.

● Apply sharpening to All images or Preview images only. The first
applies sharpening to the RAW images themselves and the later applies it
just to the preview. The later option lets you use sharpening to see its
affect but not actually sharpen the image until you do so in Photoshop.

The Save Settings
Subset dialog box.

The Camera RAW plug-
in’s menu.

The Camera RAW plug-
in’s tabs.
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THE CAMERA RAW PLUG-IN—MAKING ADJUSTMENTS

The Camera Raw plug-in has a number of settings you can change by drag-
ging sliders. Watch the preview as you make the changes and you’ll soon find
the tools you like best.

THE ADJUST TAB
The Adjust tab adjusts the white balance of the image.

■ White Balance section. When you capture a Raw image, most cameras
record the white balance setting you used and saves it as a metadata entry.
When you open the image in the plug-in, this becomes the initial setting
displayed in the White Balance text box. If it’s not the way you want it, there
are three ways to remove a color cast in your image. (There is also a control
on the Calibrate tab that corrects any color cast left in the shadows after you
adjust the white balance as described here).

To begin, click the White Balance drop-down arrow and select a setting. The
As Shot choice uses the camera’s settings. If necessary you can then make
fine adjustments with the Temperature and Tint sliders.

● Moving the Temperature slider to the left makes the image colors bluer
and moving it to the right makes the image colors warmer (yellowish).

● Moving the Tint slider to the left adds green to the photo, while moving
the slider to the right adds magenta.

One of the easiest ways to adjust the white balance is to first use the White
Balance tool (the eyedropper) to click an area in the preview image that
should be a neutral gray or white with detail (not a specular highlight). Then
use the Temperature and Tint sliders to fine-tune the adjustment so the
color is as neutral as possible.

■ Exposure slider adjusts the brightness of the image in increments
equivalent to f-stops. For example +1.0 is similar to opening the camera’s
aperture or slowing its shutter speed 1 stop. This adjustment can also shift a
range of pixel values to pure white so they are clipped and is much like the
white point slider in the Levels dialog box (page 61). It also allows you to
sometimes recover highlight detail lost through overexposure.

■ Shadows slider shifts a range of pixel values to pure black so they are
clipped and is much like the black point slider in the Levels dialog box (page
61).

■ Brightness slider adjust the overall brightness after you set the white and
black clipping points with the Exposure and Shadow sliders. It compresses
the shadows and expands the highlights when moved to the left and the
opposite when moved to the right.

■ Contrast slider adjusts the midtones in an image. Higher values increase
the midtone contrast, while lower values decrease it. Normally, you make
this adjustment after setting the Exposure, Shadow, and Brightness values.

■ Saturation slider, acting much like the slider in the Hue/Saturation dialog
box, adjusts the color saturation of the image from pure monochrome
(–100) to twice the normal saturation (+100).

TIP

■ When adjusting
Exposure and
Shadows, Alt+drag
the sliders to locate
where the high-
lights become
completely white
(Exposure) or
black (Shadows)
with no detail
(clipped) and then
back off slightly.
The black (Expo-
sure) or white
(Shadows) indi-
cates areas that are
not clipped, and
color indicates
areas that are
clipped in only one
or two channels.

The Adjust tab.

THE CAMERA RAW PLUG-IN—MAKING ADJUSTMENTS
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THE DETAIL TAB
The Detail tab sharpens images and reduces the effects of noise that degrade
image quality. Sharpness is almost always needed but noise is most obvious
in images captured with a high ISO setting or a less-sophisticated digital
camera.

■ Sharpness works much like the unsharp filter (page 78) but calculates the
threshold to use based on camera model, ISO, and exposure compensation
recorded in the image’s metadata. You can use the plug-in menu’s Prefer-
ences command (page 82) to specify if sharpening is applied to images or just
previews. When planning further editing in Photoshop, sharpen only pre-
views or leave this set to zero and then sharpen in Photoshop as the last step.

■ Luminance Smoothing reduces grayscale noise that makes an image look
grainy.

■ Color Noise Reduction reduces chroma noise which usually appears as
colored artifacts in the image.

THE LENS TAB
The Lens tab corrects chromatic aberration and vignetting introduced by
lenses in the camera.

■ Chromatic Aberration R/C adjusts for red/cyan color fringing.

■ Chromatic Aberration B/Y adjusts for blue/yellow color fringing.

■ Vignetting Amount lightens or darkens the corners of images. Some lenses
have light falloff in the corners that leaves them darker than the rest of the
image.

■ Vignetting Midpoint adjusts the size of the area affected by the Vignetting
Amount slider.

THE CALIBRATE TAB
The Calibrate tab corrects a color cast in the shadows and specifies how the
built-in profile alters non-neutral colors.

■ Shadow Tint removes color casts in shadows. Normally you use this
adjustment after adjusting white balance (page 83)

■ Red/Green/Blue Hue adjusts the hues of the R, G, and B colors.

■ Red/Green/Blue Saturation adjusts color saturation.

The Detail tab.

The Lens tab.

The Calibrate tab.
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When editing a digital photo, commands usually affect the entire
image. However, if you first select an area of the image, you can
confine adjustments to just that area. You can also select areas and

then copy, move, or delete them, perhaps to create a collage or to paste part
of one image into another to create a composite image. There are a number of
ways to select the areas of the image to be affected. The approach you choose
depends on the nature of your image, the changes you want to make, and the
area you want to select. For example, the Magic Wand tool is useful for
quickly selecting areas of similar color, such as a clear blue sky. To select a
more complex area, such as a person standing in a crowd of people, you can
use the Lasso tools.

Chapter 4
Working with Selections

CONTENTS

■ Introduction to
Selecting ■ Using
Marquee Tools ■ Using
Lasso Tools ■ Using the
Magic Wand Tool ■
Selecting a Range of
Colors ■ Adjusting an
Existing Selection ■
Moving, Copying, and
Pasting Selections ■
Saving and Reusing
Selections ■ Transform-
ing Images
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INTRODUCTION TO SELECTING

When you select areas in an image, the selected area is indicated by a border
of moving dashes, called a selection border, selection marquee or more
informally, as marching ants. The area inside the border can be moved,
copied, painted, or otherwise edited without affecting the area outside of the
border.

USING THE SELECT MENU
The Select menu lists commands you use to make and modify selections:

■ All selects all pixels in the image.

■ Deselect cancels any previously made selections.

■ Reselect reselects the most recent selection.

■ Inverse reverses a selection so the unselected area becomes selected and
the selected area becomes unselected (page 94).

■ Color Range selects a specific color or a range of colors (page 93).

■ Feather feathers an existing selection (page 94).

■ Modify modifies an existing selection (page 94).

■ Grow and Similar expand an existing selection (page 94).

■ Transform Selection scales, rotates, and distorts a selection (page 101).

■ Load/Save Selection lets you reuse your selections (page 99).

USING SELECTION TOOLS
The toolbox contains a number of selection tools—some of them hidden—
including the following:

■ Marquee tools, including the Rectangular Marquee and Elliptical Mar-
quee, select regularly shaped areas of your image by dragging with the mouse
(page 88). The Single Row and Single Column Marquee tools select 1-pixel
wide rows and columns the width or height of the image

■ Lasso tools, including the Lasso, Polygonal Lasso, and Magnetic Lasso,
draw around an irregularly shaped area to select it (page 90).

■ Magic Wand tool selects pixels having similar colors (page 92).

SELECTION TOOL OPTIONS
When you choose one of these tools in the toolbox, the options bar displays
settings that affect the way the tool works. Many of these settings vary from
tool to tool, but all selection tools include settings that determine how a new
selection interacts with the current selection and how sharp a selection’s
edges are. (Options specific to only one tool are covered in the discussions of
those tools.)

■ Multiple selection buttons create complex selections by specifying how
multiple selections interact. If you select any button other than New selec-
tion, you can make multiple selections as long as they don’t overlap. These
other buttons specify how a new selection interacts with the current selec-
tion when they do overlap.

The Select menu.

The selection border.

You can choose a
selection command from
a context menu while
using the Marquee,
Lasso, or Magic Wand
tools. To access this
menu, right-click in the
image window.
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● New selection, the default, cancels the current selection as soon as you
start making a new one.

● Add to selection adds a new selection to the current selection when they
overlap. You can also add to an existing selection by Shift+dragging.

● Subtract from selection subtracts a new selection from the current
selection where they overlap. For example, to create a semicircle you can
first select a full circle and then subtract a square from it. You can also
subtract from an existing selection by Alt+dragging.

● Intersect with selection selects only the area where the new selection
overlaps an existing one. You can also select an intersection by
Alt+Shift+dragging.

■ Feather value in the text box specifies how soft the edge of a selection will
be. When set to 0 (the default), the edge of a selection is crisp and sharp.
However, as you increase the value, the edge softens over a wider transition
zone, up to 250 pixels wide, so it blends into the area outside of the selec-
tion. This blending becomes more apparent when you move, cut, copy, or fill
the selection. You can define feathering for most selection tools as you use
them, or you can add feathering to an existing selection (page 94).

TIPS

■ To select a
hidden tool in the
toolbox Alt+click
the tool, or point to
the tool and hold
down the mouse
button.

■ For consistent
results when
adding to or
subtracting from a
selection, use the
same feather and
anti-aliased
settings used for
the original selec-
tion.

■ You can use the
Horizontal and
Vertical Type Mask
tools to create
selections in the
shape of type (page
120).

■ To set tool pref-
erences select
Edit>Preferences>
General.

INTRODUCTION TO SELECTING

The multiple selection
buttons on the options
bar determine how
multiple selections
interact.

The Edit in Quick Mask
Mode button (right) in
the toolbox. The Edit in
Standard Mode button is
on the left.

When feathering a selection, the selection border doesn’t show the edge of
the selection, but the place where feathering is 50%. To preview the
boundaries of a feathered selection, click the Edit in Quick Mask Mode
button in the toolbox (page 149). Selected areas of the image look normal
and unselected areas are covered by a color overlay. Feathering appears as a
gradation between these two extremes. To return to your normal view click
the Edit in Standard Mode button in the toolbox.

If you make a small selection with a large feather radius, you may get the
message “No pixels are more than 50% selected.” If this happens, decrease
the feather radius, or increase the selection’s size.

■ Anti-aliased check box, when on, smooths the edges of a selection by
blending just the edge pixels into the background (page 133). Since only the
edge pixels change, no detail is lost. Anti-aliasing is useful when cutting,
copying, and pasting selections to create composite images. This option is
available when you select the Elliptical Marquee tool, any Lasso tool, or the
Magic Wand tool. You must specify this option before using these tools. Once
a selection is made, you cannot add anti-aliasing.

UnfeatheredFeathered
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USING MARQUEE TOOLS

The simplest way to select regular shapes is to drag or click with one of the
Marquee tools. The Single Row and Single Column Marquee tools select 1-
pixel wide rows or columns. The Rectangular or Elliptical Marquee tools
select larger areas. The point where you hold down the mouse button to
begin the selection defines one corner of a rectangular selection area and the
point where you release the button defines the diagonally opposite corner.
The Elliptical Marquee tool selects an ellipse that fits within this rectangular
area.

THE MARQUEE TOOLS OPTIONS BAR
When you select the Rectangular or Elliptical Marquee tool, clicking the
Style drop-down arrow on the options bar lets you select how the tool works:

■ Normal selects any size and shape area without any restrictions.

■ Fixed Aspect Ratio displays Width and Height text boxes into which you
type any combination of numbers that represent the image’s aspect ratio, or
proportions. For example, if the image is 3000 x 2000 pixels in size, you can
enter those numbers, 3 and 2, or 1.5 and 1 for the same effect. When you now
select an area it will have the same aspect ratio as the original image. If you
enter 1 and 1, you will select a square (or circle with the Elliptical Marquee
tool.)

■ Fixed Size displays Width and Height text boxes into which you type the
dimensions of the area you want to select in inches, centimeters, or pixels.
For example, if you enter a width of 800 and a height of 600, and then click
in the image, a section 800 x 600 pixels in size is selected. To specify the unit
of measurement, follow the numbers with px (the default), in, or cm.

ASPECT RATIOS

An image’s aspect ratio is the ratio between its width and height. For
example, a 35 mm slide or negative is 1.5 inches wide by 1 inch tall.
Therefore, its aspect ratio is 1.5 to 1. A square image has an aspect ratio of
1:1. This ratio is often expressed in one of three ways:

■ When expressed as 1.5 to 1 or 1.5:1, the actual numbers calculated in the
division process are used, even though one has a decimal place.

■ To remove the decimal, the numbers are raised to a new ratio so both
numbers are whole. In our example, 1.5 to 1 would be raised to 3 to 2.
That’s what’s done with TV screen aspect ratios. The aspect ratio for
normal TV is referred to as 4:3 and HDTV as 16:9.

■ In a few cases, where one part of the ratio is assumed to be 1, just the
other part is given. For example, a 1.5:1 ratio is expressed just as 1.5.

Aspect ratios present a problem when printing images because the aspect
ratios of images usually differ from the aspect ratios of the paper we print
on.

The Marquee tools.

Images with the same
aspect ratio can be
different sizes but they
always share the same
diagonal.

The multiple selection
buttons on the options
bar include New
selection, Add to
selection, Subtract from
selection, and Intersect
with selection (page
86).

HTTP://WWW.PHOTOCOURSE.COM


89FOR INFORMATION ON DIGITAL PHOTOGRAPHY, VISIT HTTP://WWW.SHORTCOURSES.COM

SELECTING WITH MARQUEE TOOLS
Once you have selected a Marquee tool and made any changes to the options
bar, you can make a selection.

■ To make a selection with the Rectangle or Elliptical Marquee tool, drag
over the area you want to select.

● To constrain the selection to a square or circle, Shift+drag the border.

● To drag a marquee from its center, instead of the usual corner, hold
down Alt after you begin dragging.

● To make a fixed size selection when Style on the options bar is set to
Fixed Size, click in the upperleft corner of what you want selected, then
without releasing the mouse button, drag the selection to reposition it if
necessary.

TIP

■ If you use
feathering with the
Elliptical Marquee
tool you should
turn off the Anti-
aliased check box
(page 87) .

USING MARQUEE TOOLS

■ To make a selection with the single row or single column marquee, click
near the area you want to select, and then reposition the selection border if
necessary as described below. If you can’t see the selection border, zoom the
image larger.

As you make selections, there are ways to make adjustments:

■ To reposition the selection border while still dragging to define the
selected area, don’t release the mouse button while you hold down the
spacebar and drag. To resume selecting, release the spacebar, but keep the
mouse button depressed as you drag.

■ To align your selection with guides, a grid, slices, or document bounds,
select View>Snap, or View>Snap To and choose a command from the
submenu.

■ To reposition the selection border after making a selection, press the
arrow keys to move a pixel at a time (hold down Shift when you press them to
move in 10 pixel jumps). You can also drag it with the mouse as long as one
of the selection tools remains selected (page 94).

The Rectangular and
Elliptical Marquee tools
both select an area
within a rectangle
defined by dragging
from a start to an end
point.

The View>Snap To
submenu.

TIP

■ To remove the
section border,
choose Select>
Deselect. If the
New Selection
button is selected
on the options bar,
you can also click
anywhere outside
of the selection to
cancel it.
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USING LASSO TOOLS

The Lasso tools let you drag a freehand line around any part of the image.
Each of the three versions—Lasso, Polygonal Lasso, and Magnetic Lasso—has
unique features.

THE LASSO TOOL
The Lasso tool is used primarily to draw freehand selections although you
can also use it to draw straight-edged segments. To use the Lasso tool, select
it in the toolbox and set its options on the options bar (page 86):

■ To make a selection, hold down the mouse button and drag to draw a
freehand selection border.

■ To close the selection, drag back over the starting point and release the
mouse button. If you don’t cross over the starting point, or close the loop, the
point where you release the mouse button is connected to the starting point
by a straight segment.

■ To draw a straight-edged segment, press and hold down Alt, release the
mouse button, point to where you want the straight segment to end and click.
Continue pointing and click to add additional straight segments. To switch
back to freehand, hold down the mouse button and then release Alt. If you
release Alt key first, the selection is closed with a straight line. (It takes some
practice.)

THE POLYGONAL LASSO TOOL
The Polygonal Lasso tool is primary used to draw straight-edged segments of
selections, although you can insert freehand segments. To use the Polygonal
Lasso tool, select it in the toolbox and set its options on the options bar (page
86):

■ To begin, click in the image to set the starting fastening point.

■ To draw a straight segment, position the pointer where you want the first
straight segment to end, and click. Continue clicking to set fastening points
for subsequent segments by clicking.

■ To draw a freehand segment, hold down Alt after clicking to end a straight
segment, and drag. When finished, release Alt and the mouse button and you
resume entering straight segments by clicking.

■ To erase recently placed endpoints for straight segments, press the Delete
key to “back up.”

■ To close the selection border, do one of the following:

● Position the pointer over the starting point (a small circle is displayed
next to the mouse pointer when it’s positioned correctly), and click.

● If the pointer is not over the starting point, double-click or Ctrl+click
the final point to close the selection with a straight segment.

The Lasso tools.

If there was ever a time
when you’d like to have
a tablet to draw on
instead of drawing with
the mouse, this is it.
Courtesy of Wacom.

TIP

■ When selecting,
you may want to
zoom to see details
or scroll to parts of
the image that you
can see. You can do
both without
releasing the
mouse button and
closing the selec-
tion:

● To zoom, hold
down Ctrl and
press the + and -
keys on the nu-
meric keypad.

● To access the
Hand tool, hold
down the spacebar.
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THE MAGNETIC LASSO TOOL
With the Magnetic Lasso tool, the selection border snaps to edges and places
fastening points as you drag along them in the image. This is especially useful
for selecting objects in the image having complex edges against a uniform
background.

To use the Magnetic Lasso tool, select it in the toolbox and set its options on
the options bar:

■ Width specifies the area, between 1 and 256 pixels wide, in which edges are
detected. To display a circle around the mouse pointer showing the detection
width, engage Caps Lock after selecting the tool. To decrease or increase the
circle’s size, press [ or ]. Each time you press it you adjust the size by 1 pixel.
(This also adjusts the width when the circle isn’t displayed.)

■ Edge Contrast specifies the lasso’s sensitivity to edges as a percentage
between 1% and 100%. Higher values detect well-defined edges that contrast
sharply with their surroundings; lower values detect poorly defined lower-
contrast edges.

■ Frequency specifies the rate at which the lasso sets fastening points that
anchor the selection border in place. The range is between 0 and 100 and
higher values anchor the selection border in place more often. Higher
settings are best for curves or intricate edges.

■ Pen pressure is for those using a stylus tablet. When on, an increase in
stylus pressure causes the width of the edge detection to decrease.

Once you have set options, click in the image to set the first fastening point.
As you then drag the pointer along the edge you want to trace, the selection
border snaps to the highest-contrast edge that falls within the specified
Width and has the specified Edge Contrast. Fastening points are added to
the selection border at the rate specified in the Frequency option.

■ To erase recently drawn segments and fastening points, press the Delete
key one or more times to “back up.”

■ If the border doesn’t snap to the desired edge, click once to add a fastening
point manually. Continue to trace the edge, and click to add fastening points
as needed.

■ To switch temporarily to another Lasso tool, do one of the following:

● To activate the Lasso tool, hold down Alt, as you drag while holding
down the mouse button.

● To activate the Polygonal Lasso tool, press and hold down Alt, release
the mouse button and click endpoints for straight segments. To return to
the Magnetic Lasso, release the mouse button, click to end the final
straight segment, then resume dragging.

■ To close the selection border, do one of the following:

● To close the border manually, drag back over the starting point (a
closed circle appears next to the pointer), and click.

● To close the border with a magnetic segment that follows edges,
double-click at the point you want to close from or press Enter. To close
the border with a straight segment, hold down Alt, and double-click.

TIPS

■ If an image has
well-defined edges,
use higher Width
and Edge Contrast
settings. If the
edges are softer,
use lower settings,
and trace the
border more
carefully.

■ You can drag the
Magnetic Lasso
with or without the
mouse button
down.

Engaging Caps Lock
when using the
Magnetic Lasso displays
a circle showing the
zone in which edges are
detected.

USING LASSO TOOLS

HTTP://WWW.SHORTCOURSES.COM


92

CHAPTER 4. WORKING WITH SELECTIONS

FOR INFORMATION ON CLASSROOM USE, VISIT HTTP://WWW.PHOTOCOURSE.COM

USING THE MAGIC WAND TOOL

The Magic Wand tool selects an evenly colored area such as the sky when you
click it. By adjusting the tolerance you control the range of colors that are
selected. For example, if you set the tolerance value to 10, 10 similar but
lighter tones and 10 similar but darker tones will be selected. To use the
Magic Wand tool, select it from the toolbox and then choose settings on the
options bar:

■ Tolerance controls the range of colors selected and the range is 0 to 255.
Low values select colors similar to the pixel you click, and higher values
select a wider range of colors.

■ Anti-aliased check box, when on, creates a smooth selection edge (page
132).

■ Contiguous check box, when on, selects only pixels adjacent to the pixel
you click. Pixels in other areas of the image aren’t selected even if they are
identical to the pixel you click. When off, the selection includes pixels
anywhere in the image as long as they match the one you click or are close
enough to it to fall within the tolerance range.

■ Use All Layers check box, when on, selects colors on all visible layers
(page 104). When off, only colors from the active layer are selected.

To select an area in the image, click the color you want to select. Since the
area selected depends both on the color of the pixel you click and the
tolerance setting, experiment with both until you get the selection you want.
Sometimes, just clicking a few pixels away changes the selection
dramatically. To add to the selected area, you can Shift+click unselected
areas, or choose Select>Grow (page 95). To unselect and try again, right-
click in the image and choose Deselect from the context menu.

TIPS

■ Once you have
made a selection
with the Magic
Wand tool you can
choose Select>
Grow or Select>
Similar to expand
it (page 95).

■ You can’t use the
Magic Wand tool
on images in the
Bitmap format. To
check the format
select Image>
Mode.

The Magic Wand tool
works best when
selecting uniformly
colored areas such as
skies. Here is has been
used to select the black
night sky. Using the
Select>Inverse
command the selection
can be inverted to select
the moon so it can be
copied into another
image.
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SELECTING A RANGE OF COLORS

The Color Range command selects a range of colors that you specify by
clicking with eyedroppers, selecting from a menu, or by specifying a tonal
range. In fact, you can use all three ways to refine an existing selection. Just
use the Color Range command repeatedly to select colors in different ways.

To begin selecting a range of colors, choose Select>Color Range to display
the Color Range dialog box with the following settings:

■ Select text box displays what’s being selected but you can click the drop-
down arrow to display a menu from which to select other choices.

● Sampled Colors, the default, selects colors when you click in the image
with one of the three the Eyedropper tools.

● Color patches represent the colors that make up images, much like
channels—RGB and CMY. When you select these you can’t use the
Fuzziness slider.

● Tonal range lets you select highlights, midtones, or shadows.

● Out-of-Gamut works only on RGB and Lab images and selects colors
that cannot be printed using process color printing.

■ Fuzziness slider adjusts the range of colors with higher values including
more colors in the selection.

■ Selection and Image option buttons specify if you see a preview of the
selection (white areas are selected) or the entire image in the preview
window. To toggle between the two views, press Ctrl.

■ Selection Preview, normally set to None, has a drop-down arrow you click
to preview the selection as a Grayscale, Black Matte, White Matte, and
Quick Mask (page 149).

■ OK applies your changes to the image and closes the dialog box.

■ Cancel closes the dialog box without applying your adjustments to the
image. If you hold down Alt, the button changes to Reset so you can click it to
restore the original settings and try again.

■ Load/Save buttons let you reuse your settings with other images.

■ The eyedroppers are used when you have set Select to Sampled Colors.
Position the pointer over the image or preview area, and click to sample the
colors you want included in the selection. (Using a low Fuzziness setting and
multiple clicks often works best because you can incrementally build the
selection.) To adjust the selection:

● To add colors to the selection, select the plus eyedropper, and click in
the preview area or image. To temporarily activate the plus eyedropper,
hold down Shift.

● To remove colors from the selection, select the minus eyedropper, and
click in the preview area or image. To temporarily activate the minus
eyedropper, hold down Alt.

■ Invert check box, when on, inverts the colors in the Preview box when the
Selection option button is on.

TIP

■ If a message
reads “No pixels
are more than 50%
selected,” the
selection border
will not be visible.
Try selecting a
different color.

The Color Range dialog
box.

The Select drop-down
menu.

SELECTING A RANGE OF COLORS
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ADJUSTING AN EXISTING SELECTION

Once you have made a selection, and as long as the selection border remains
in place, you can fine-tune it in a number of ways. For example, you can
move, invert, hide, feather, modify, or grow it.

MOVING AN EXISTING SELECTION BORDER
After making a selection you can move the selection border without moving
the selected area of the image. To do so with any selection tool, click the
New Selection icon on the options bar, point inside the selection border so
the pointer changes to indicate that you can move the selection, then drag
the border to adjust its position. If any multiple selection button other than
New Selection is selected on the options bar, when you try to drag the
current selection border, you just start a new selection. If you select the
Move tool, moving the selection border also moves the selected part of the
image. This leaves a blank area that is filled with the current background
color (page 126).

■ To constrain the direction to multiples of 45°, begin dragging, and then
hold down Shift as you continue to drag.

■ You can drag a selection border beyond the image boundaries and even to
another image window.

Instead of using the mouse to move the selection border, you can use the
arrow keys on your keyboard to position the border very precisely, in 1-pixel
increments. To control the movement of a selection do one of the following:

■ To move the selection in 1-pixel increments, press one of the arrow keys.

■ To move the selection in 10-pixel increments, hold down Shift as you press
the arrow keys.

INVERTING A SELECTION
Inverting a selection unselects the selected area and selects everything else.
When deciding how best to select an area, ask yourself if it’s easier to select
it, or the areas around it. If it’s easier to select the areas around it, do so and
then invert the selection. For example, to select a detailed moon against a
dark black sky, you might use the Magic Wand tool to select the sky and then
invert the selection to select the moon. To invert a selection, choose
Select>Inverse. When using a selection tool, you can also right-click an
image to display a context sensitive menu and click Select Inverse.

To add a border in the
current foreground color
around a selection,
choose Edit>Stroke.

TIPS

■ When selecting
with the Marquee
tools, you can hold
down the spacebar
in the middle of the
operation and drag
the selection to a
new position. You
can then release
the spacebar and
continue dragging
to adjust the
selected area.

■ To remove the
selection border,
choose Select>
Deselect or if the
New selection
button is selected
on the options bar
click anywhere
outside the selec-
tion border.

Selection Inverted Selection
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HIDING THE SELECTION BORDER
Should you ever want to hide the selection border while leaving it active you
can do so by selecting View>Show>Selection Edges. If the border is on, the
command turns it off. If it’s off, it turns it back on. You can also hide it along
with other elements by selecting View>Extras.

FEATHERING A SELECTION
Although some tools let you feather a selection at the time you make it (page
87), you can also feather it later as long as it remains selected. To do so,
choose Select>Feather to display the Feather Selection dialog box. In the
Feather Radius text box specify a transition zone between 0.2 and 250
pixels wide over which edges fade out, and click OK. The selection border
doesn’t show the edge of the selection, but the place where feathering is 50%
(page 87). If you apply a large feather radius setting to a small selection, you
may get the message “No pixels are more than 50% selected.” If this
happens, decrease the feather radius, or increase the selection’s size.

MODIFYING A SELECTION
Once you make a selection, you can modify it by choosing Select>Modify to
display a submenu with the following choices:

■ Border creates a soft-edged, anti-aliased selection border of the width you
specify in the dialog box that appears.

■ Smooth cleans up isolated pixels that were selected or left unselected
against your wishes. In the Smooth Selection dialog box, set the Sample
Radius to a value between 1 and 100, and click OK. The program searches
around each pixel for within the specified sample radius.

● If most pixels in that radius are selected, any unselected pixels are
added to the selection.

● If most pixels in that radius are unselected, any selected pixels are
removed from the selection.

■ Expand/Contract commands display dialog boxes you use to increase or
decrease the size of an existing selection by a specified number of pixels.
Enter a value between 1 and 100, and click OK.

GROWING A SELECTION
You can expand a selection to include adjacent pixels or pixels scattered
anywhere in the image that fall within the tolerance range specified on the
Magic Wand’s options bar. A higher tolerance value adds a broader range of
colors. To increase the selection incrementally, choose the command
multiple times.

■ To expand a selection to include all contiguous pixels falling within the
tolerance range, choose Select>Grow. The selection will not jump across
areas that are outside of the tolerance range.

■ To expand a selection to include pixels throughout the image that fall
within the tolerance range, not just contiguous ones, choose Select>Similar.

TIP

■ You cannot use
the Select>Grow or
Select>Similar
commands on
images in bitmap
mode.

The Select>Modify
submenu.

ADJUSTING AN EXISTING SELECTION

The Feather Selection
dialog box.
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MOVING, COPYING, AND PASTING SELECTIONS

You can move or copy selected areas within or between images—perhaps to
create a collage or composite image.

ABOUT MULTIPLE IMAGES
It’s not uncommon to copy or move selections between images. When doing
so, open both images and you may want to select Window>Arrange>Tile to
arrange them side-by-side. You can drag selections or cut and paste them as
described below, but there are some things specific to doing so between
images.

■ When you drag a selection into another image, a border highlights the
destination image window when you can drop the selection into it.

■ When you copy, move, or paste a selection into another image, the selec-
tion is on a new layer (page 104) and retains its pixel dimensions.

DRAGGING A SELECTION—THE MOVE TOOL
Once you have selected an area you can select the Move tool and then copy
or move it in a number of ways.

● To move the selection, select the Move tool, point inside the selection
border, and drag with the mouse. When many other tools are selected,
Ctrl+drag moves the selection.

● To copy the selection, point inside the selection border, and Alt+drag.
When many other tools are selected, Alt+Ctrl+drag moves the selection.

● To move the selection in small increments of 1 pixel press the arrow
keys. Hold down Shift as you do so to move it 10 pixels at a time.

When using the Move tool you have the following choices on the options
bar:

■ Auto Select Layer selects the topmost layer that has pixels under the Move
tool, rather than the selected layer (page 104).

■ Show Bounding Box check box, when on, displays a bounding box around
the selected item with handles you can drag to transform the selection. When
you then click or drag the bounding box, or just outside of it with the pointer
displayed as a curved arrow, the options bar changes so you can transform
the selection by dragging bounding box handles or dragging on the options
bar.

● To change the reference point location, around which all transforma-
tions are performed, click one of the nine points on the Reference point
location button. You can also use the Move tool to point to the “X” or “Y”
on the options bar and drag the mouse. By default, this point is at the
center of the selection.

● To change the selection’s size and retain its proportions, Shift+drag a
corner handle. To change the size without moving the center point,
Alt+drag, or Alt+Shift+drag to also retain the selection’s aspect ratio. You

TIPS

■ When copying
one image into
another, you may
want to increase
the size of the
target image’s
canvas so there is
room for the new
photo.

■ When any tool
other than Move is
selected, you can
temporarily switch
to the Move tool by
holding down Ctrl
before you start to
drag the selection.

■ You can’t Ctrl+
drag when using
the Pen, Freeform
Pen, Path Selec-
tion, Direct Selec-
tion, Hand, Slice
Select, or anchor
point tools.

After clicking the
bounding box with the
Move tool to change the
options bar, you can
right-click in the image
to display a menu listing
transform commands
(page 101).
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can also click the Maintain Aspect Ratio icon (the chain links) on the
options bar to turn it on, then use the Move tool to point to the “W” or “H”
on the options bar and drag the mouse.

● To rotate the selection, point just outside of the selection border so the
pointer turns into a curved arrow, and drag. You can also use the Move
tool to point to the Rotate button on the options bar and drag the mouse.

● To skew the selection, Ctrl+drag a corner handle to skew that corner or
Ctrl+drag a middle side handle to skew the entire selection. You can also
use the Move tool to point to the “H” or “V” on the options bar and drag
the mouse.

● To transform the selection side to side or top to bottom, without
changing the center point, Alt+drag a side handle.

● To complete transforming the selection, double-click within the selec-
tion, click the Commit icon on the options bar, select a different tool in the
toolbox, or press Enter.

● To cancel transforming the selection, click the Cancel icon on the
options bar or press Esc.

■ Align and Distribute buttons are used to align the content of one or more
layers to a selection or distribute edges and centers.

COPYING AND MOVING SELECTIONS—THE CLIPBOARD
You can copy and move selections by choosing commands on the Edit menu
to copy or cut a selection to an area of memory called the clipboard. The
selection remains on the clipboard and can be pasted into any image until
you copy or cut another selection to the clipboard or quit the program.

When you cut, delete,
or move a selection on
the background layer
(page 104), the void is
filled with the current
background color (page
126).

The Cancel and Commit
icons.

The Reference point
location, Use relative
positioning for reference
point, scale, Maintain
aspect ratio, Rotate,
and Set horizontal skew
and set horizontal skew
button on Move Tool’s
option bar.

■ To cut or copy a selection to the clipboard, pull down the Edit menu and
select one of the following commands:

● Cut moves the selection to the clipboard.

● Copy copies the selection to the clipboard.

● Copy Merged copies all layers in the selected area to the clipboard. The
Cut and Copy commands just cut or copy the selected layer (page 104).

MOVING, COPYING, AND PASTING SELECTIONS

TIP

■■■■■ You can drag
and drop and cut/
copy and paste
selections into
other applications.
On Windows
systems the target
application must
support OLE (most
do).
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■ To paste a selection from the clipboard, select the image you want to
paste it into, pull down the Edit menu and select one of the following
commands:

● Paste copies the selection onto a new layer in the current image.

● Paste Into copies the selection on the clipboard into a selected area of
the current image. After it’s been pasted, you can select the Move tool and
use it or the arrow keys to position the copied selection within the selec-
tion border. (What you have done is create a layer mask—page 150.) When
you’re happy with the arrangement, you can leave it as is in case you want
to change it later or choose Layers>Merge Down to make the change
permanent.

■ To copy a selection from the clipboard into a new image, select File>New
to create a new blank image the same size as the image on the clipboard. You
then select Edit>Paste to paste the selection into the new image on its own
layer with a blank background layer.

REMOVING FRINGE PIXELS
When you copy or move an anti-aliased selection, the pixels used to anti-alias
can create a halo-like fringe around the selection. Selecting Layer> Matting>
Defringe and entering 1 or 2 pixels in the Width text box, removes this fringe
by replacing the color of any fringe pixels with the colors of nearby pixels
containing pure colors without background color. If you are pasting an anti-
aliased selection cut or copied from a white or black background onto a
different background, you can choose Layer>Matting>Remove Black Matte
or Layer>Matting>Remove White Matte.

DELETING A SELECTION
To delete a selected area from your image, select Edit>Clear, Edit>Cut, or
press Backspace or Delete. If you delete a selection from the background
layer, the void left by the deletion is filled with the current background color
(page 126). On other layers you open transparent areas so layers below show
through.

The Edit menu lists
commands you can use
to cut, copy, and paste
a selection.

The Defringe dialog box.

Here a portrait was
copied to the clipboard.
A new document was
opened and an oval was
selected with a large
feathering value. The
selection was then
deleted and the portrait
on the clipboard was
pasted into the opening
using the Edit>Paste
Into command. The
Move tool was then
selected to adjust the
portrait’s position within
the opening.
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SAVING AND REUSING SELECTIONS

Selecting detailed or complicated areas in an image can take a great deal of
time. If you close the image file and then reopen it, or even click in the
wrong place with the wrong tool, you loose all of that effort. One way to
preserve a selection, is to save it and then reload it whenever you need it.
Selections are saved as channels, called alpha channels to distinguish them
from color channels, and listed at the bottom of the Channels palette (page
153). The selection at this point has become more than a selection, it has
become a grayscale image called a mask or alpha mask. Masks, the focus of
Chapter 7, are more powerful forms of selections because you can edit them
with all of the tools Photoshop puts at your command to edit images.

SAVING A SELECTION
To save a selection, click the Channel palette’s Save selection as channel
button to list the new channel, named according to the sequence in which it
was created. To save it with options, Alt+click the same button or select
Select>Save Selection to display the Save Selection dialog box with the
following settings:

■ Document drop-down arrow lets you specify a destination image for the
selection. By default, the selection is saved in the active image. You can
change this to save the selection to a channel in another open image as long
as it has the same pixel dimensions, or to a new image.

■ Channel drop-down arrow lets you specify a destination channel for the
selection. By default, the selection is saved in a new channel. If your have
previously saved a selection, you can choose to save the selection to it.

■ Name, used if you’re saving the selection as a new channel, lets you enter a
descriptive name for the selection.

■ Operation section, used when you’re saving the selection to a previously
save selection, specifies how to combine the selections. Replace Channel
replaces the current selection, Add to Channel adds the selection to the
current channel contents, Subtract from Channel deletes the overlapping
sections, or Intersect with Channel keeps only the overlapping sections.

■ OK saves the selection (but remember to save the image file).

■ Cancel closes the dialog box without saving the selection.

LOADING A SELECTION
Loading a selection that you have previously saved displays it in the image as
a selection border. After loading it be sure to select the RGB channel in the
Channels palette, and the layer you want to use it with in the Layers palette.

To load a previously saved selection listed in the Channel palette, drag and
drop the selection’s channel onto the palette’s Load channel as selection
button or select the channel and click the same button.  To load a channel
using options, choose Select>Load Selection to display the Load Selection
dialog box with the following settings:

■ Document drop-down arrow lets you select any open image containing a
saved selection. (The images must have the same pixel dimensions.)

■ Channel drop-down arrow lets you select a previously saved selection
stored in the image you selected as the Document.

The Save Selection
dialog box.

The Load Selection
dialog box.

SAVING AND REUSING SELECTIONS

When you save a
selection, its thumbnail
is listed at the bottom of
the Channels dialog
box. Selected pixels are
white, unselected pixels
are black, and partially
transparent or selected
pixels are gray.

The Channel palette
buttons include (from
left to right) Load
channel as selection,
Save selection as
channel, Create new
channel, and Delete
current channel.
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■ Operation section, used when you’re loading a selection into an image with
an existing selection, specifies how to combine the selections. Your choices
include New Selection to replace the current selection in the image, Add to
Selection, Subtract from Selection, or Intersect with Selection. The effects of
these choices are discussed on page 86.

■ OK loads the selection and it appears in the image as a selection border.
Select the composite color channel in the Channels palette to use the selec-
tion to edit the image. If the image has more than one layer, the selection
affects only the one you have selected in the Layers palette (page 104).

■ Cancel closes the dialog box without loading the selection.

MANAGING CHANNELS
■ To select a channel, click its name in the Channels palette. To select
multiple color or alpha channels, Shift+click them. If you select any channel
other than RGB only those you select are listed in dialog box Channel drop-
down menus, multiple color channels being listed by abbreviations such as
RG for Red and Green channels.

■ To display just the mask, click the eye icon in the Channels palette to hide
the color channels.

■ To display the mask’s color overlay in the image, display the eye icon for
any or all color channels.

■ To delete an alpha mask, select it in the Channels palette and click the
palette’s Delete current channel button, drag and drop the channel on the
same button. You can also right-click the channel or display the Channel
palette’s menu and choose Delete Channel.

■ To change the order of alpha channels (you can’t move color channels),
drag the channel up or down. When a line appears in the position you want,
release the mouse button.

■ To rename an alpha channel, double-click the channel’s name in the
Channels palette, type a new name and press Enter.

DUPLICATING CHANNELS
There are situation in which you may want to duplicate a channel. For
example, you might want to backup a channel you are about to edit, or copy a
selection to another image with the same pixel dimensions. To begin, select
the channel to be duplicated then select Duplicate Channel from the Chan-
nels palette menu to display the Duplicate Channel dialog box with the
following settings:

■ As text box lists the current name of the channel but you can enter a new
one.

■ Document lists the name of the document you want to duplicate the layer
to. The default is the current document but you can click the drop-down
arrow to select any other open document with the same pixel dimensions, or
New to copy it into a new image.

■ Name, available only when the Document is set to New is where you enter
a descriptive name for the duplicated channel.

■ Invert check box, when on, reverses the selected and masked areas in the
duplicate channel.

TIPS

■■■■■ When you save a
selection, it is only
saved permanently
when you save the
image file contain-
ing it. The file has
to be saved in the
PSD or TIFF
format.

■■■■■ To delete a
selection that you
have previously
saved, you have to
delete the channel
it was saved in
(page 58).

■ An alpha chan-
nel has these
properties:

● Each image can
contain up to 56
channels, including
color and alpha
channels.

● You can specify a
name, color, mask
option, and opacity
for each channel.
(The opacity affects
the preview of the
channel, not the
image.)

● All new channels
have the same
dimensions and
number of pixels as
the original image.

● You can edit the
mask in an alpha
channel using
painting tools,
editing tools, and
filters.
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TRANSFORMING SELECTIONS

You can scale, rotate, skew, distort, and apply perspective to selected parts of
an image. (You can also use the same techniques to transform layers and
shapes discussed later.) In digital photography, one use of these tools is to
correct the keystoning you get when you point the camera up to photograph
buildings.

THE TRANSFORM COMMAND
To transform a selection first select it, then choose Edit>Transform to
display a submenu listing the transform commands described below. (Hold
down Alt as you choose a command to transform a copy of the selection while
leaving the original selection unchanged.) When you select one of the
submenu’s commands, the selection is enclosed in a bounding box with
corner and side handles you drag to transform the image.

All transformations are performed around a fixed point called the reference
point. The point is initially in the center of the selection, however, you can
change it by clicking a square on the Reference point location button on the
options bar. Each square represents a point on the bounding box. For
example, clicking the top left square sets the reference point to the top left
corner of the bounding box. You can also change the reference point by
dragging the center point of the bounding box anywhere inside or outside of
the bounding box.

The transform commands you can select from the Edit>Transform submenu
include the following (you can apply more than one before committing the
combined transformations to the selection):

■ Scale changes the image’s size. Shift+drag a corner handle to retain the
selection’s aspect ratio. Alt+drag to scale around the center point.

■ Rotate rotates the selection around the reference point when you drag
outside of the bounding box.

■ Skew slants the selection horizontally or vertically when you drag a side
handle.

■ Distort stretches the selection in any direction when you drag a corner
handle.

■ Perspective applies single-point perspective when you drag a corner
handle. (You can also do this while cropping with the Crop tool—page 54.)

When finished, you have to apply a transformation by clicking the Commit
button on the options bar, double-clicking inside the bounding box, or
pressing Enter. To cancel the transformation, click the Cancel button on the
options bar, or press Esc. You can now choose Edit>Transform>Again
(Shift+Ctrl+T) to repeat the same transformation. This is a good way to build
up a transformation in small steps.

THE FREE TRANSFORM COMMAND
The Free Transform command lets you apply transformations without having
to choose commands from the menu. After making a selection in the image,
choose Edit>Free Transform, then select the Move tool and turn on the
Show Bounding Box check box on the options bar.

The Reference Point
location button on the
options bar.

The Edit>Transform
submenu.

The transfer bounding
box with a center point
and handles you drag.

The Cancel and Commit
buttons on the options
bar.

TRANSFORMING SELECTIONS
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An image with
converging verticals
(top) can be corrected
by selecting the
Perspective command
and dragging one of the
top corner handles until
the verticals in the
image are parallel
(bottom).

TIPS

■ To transform a
selection border,
choose Select >
Transform Selec-
tion.

■ To transform an
entire layer, make
the layer active,
and make sure
nothing is selected.
(You cannot
transform the
background layer
without first
converting it into a
regular layer (page
104).

■ To transform
multiple layers,
link them (page
111)

■ To scale, drag a handle. Shift+drag to retain the selection’s aspect ratio.

■ To rotate, point outside of the bounding border so the pointer becomes a
curved, two-sided arrow, and then drag. Shift+drag to rotate in 15° incre-
ments.

■ To distort relative to the center point of the bounding border, Alt+drag a
handle. To distort freely, Ctrl+drag a handle.

■ To skew, Ctrl+Shift+drag a side handle. When positioned over a side
handle, the pointer becomes a white arrowhead with a small double arrow.

■ To apply perspective, Ctrl+Alt+Shift+drag a corner handle. When posi-
tioned over a corner handle, the pointer becomes a gray arrowhead.
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When you first open a digital photograph it contains a single layer.
However, you can add additional layers either directly or indirectly.
Why would you want to do so? In some cases you have no choice.

For example, if you use the Type tool to add text to an image or a shape tool
to add a shape, the text or shape is automatically entered on a new layer. In
other situations you want to add layers yourself. For example, you can add an
adjustment layer to change such image characteristics as levels, brightness
and contrast, or hue and saturation. If you later hide or delete this layer, the
image reverts to its original form. Before layers were introduced, changes
were always made to the original image and were difficult or impossible to
undo later. Every change had to be well planned, as if you were carving in
stone. Now you can use layers to make changes and modify and delete them
at will without affecting the original image. The more you learn about layers,
and the tools you use to manage them, the more uses you will find for them.

Chapter 5
Working with Layers

CONTENTS

■ Using Layers ■ The
Layers Palette ■
Creating and Preserving
Layers ■ Creating and
Using Layer Sets ■
Managing Layers and
Layer Sets ■ Using
Adjustment Layers ■
Using Fill Layers ■
Entering Text ■ Creating
Clipping Paths
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USING LAYERS

When you first open a digital photo, it has only one layer—the background
layer containing the image. Any changes you make to this layer become part
of the image and permanently change its pixels. To avoid permanent
changes, you add additional layers and make your changes on those layers.
It’s as if you were covering an original photo with sheets of glass on which
you drew, painted, made adjustments to the image below, entered text, or
added fills.

Although layers can dramatically increase the size of a file, there are advan-
tages that outweigh this one disadvantage.

■ Changing a layer affects only that layer and doesn’t affect other layers
except in intended ways. For example, one layer may contain adjustments to
the image’s levels, while another layer has adjustments to its saturation.
These layers only effect the appearance of the image layer below them.

■ Hiding a layer, by clicking its eye icon in the Layers palette, temporarily
hides the layer and removes its effects from the image. For example, if you
add text on a layer, you can hide that layer and make a print without the text.
You can then unhide the layer and make a print with the text. (One trick is to
quickly toggle an adjustment layer on and off a number of times to see
exactly what effects it’s having on the image.)

■ Deleting a layer removes its effects from the underlying image. You can
delete a layer at any time, unlike the Edit>Undo command or History palette
that only undo changes made during the current session.

■ Adjusting or revising a layer is possible at any time, unlike changes made
to the image itself that are permanent. For example, if you use a layer to
adjust an image or add type, you can always go back later and change the
adjustment or change the size or color of the text.

■ Repositioning layers makes it easy to revise a layout. For example, if
you’ve added text or combined multiple images, you can drag their layers
into new positions at any time.

■ Adding or deleting layer styles such as drop shadows under text can be
done at any time.

Although you can create regular layers on which to place other images, paint,
or draw, there are some types of layers that are dedicated to specific func-
tions.

■ Adjustment layers can change an image’s levels, color balance, brightness,
contrast, hue, and saturation without changing the original image. Any
adjustments made to the adjustment layer are “projected” onto the underly-
ing image where you see their affects.

■ Fill layers (page 118) add a solid color, gradient, or pattern to an image.
You can then make the fill layer transparent or cut holes in it so the image
below shows through much like a photo shows through an opening cut in a
mat.

■ Type layers (page 120) are created automatically when you select the Type
tool from the tool box and click in the image to enter text. Having text on its
own layer makes it easy to edit, manipulate, move, and delete.

■ Shape layers (page 143) are created automatically when you select a Shape
tool in the toolbox and use it to draw a shape on the image.

The Layers palette
displays all of the layers
in an image. Here they
include (from bottom to
top), the background
layer, an adjustment
layer, and a text layer.

Adjustment layers affect
the layers below them.
Here a Photo Filter
adjustment layer has
been added to make the
colors warmer.

TIPS

■ Type, shape, and
fill layers are
different from
other layers. Their
content is not in
the form of pixels,
but in the form of
vector graphics.

■ Whenever you
plan on painting or
drawing on an
image, you should
create a layer to do
it on so you won’t
change the original
image.

HTTP://WWW.PHOTOCOURSE.COM


105FOR INFORMATION ON DIGITAL PHOTOGRAPHY, VISIT HTTP://WWW.SHORTCOURSES.COM

THE LAYERS PALETTE

The Layers palette is your control panel as you create, manage, and select an
image’s layers. To display the Layers palette, choose Window>Layers, or if
the palette is already open click its tab, or drag it out of the palette well so it
floats in the work area. If you have just opened a digital photograph, the
layers palette displays only a single layer—labeled Background and display-
ing a lock icon. As you edit an image, you may add additional layers that are
then listed in the palette above the background layer. You can click any one
of the layers to make it the active layer and many procedures then affect
only that layer. To manage layers you click icons in the Layers palette, select
commands on the Layers menu, and click the triangle icon to display the
palette menu. Here are some of the options you have:

■ Triangle icon displays the palette menu with commands you use to man-
age layers.

■ Blending Mode, set to Normal by default, has a drop-down arrow you can
click to select from a list of blending modes you can assign to the selected
layer (page 132).

■ Opacity, set to 100% by default, has a drop-down arrow that displays a
slider you drag to change the selected layer’s opacity (page 132).

■ Lock icons lock and unlock various properties of layers (page 114).

■ Fill, set to 100% by default, has a drop-down arrow that displays a slider
you drag to change the opacity of of pixels painted on the layer or shapes
drawn it. This control does not affect layer styles and blending modes applied
to the layer as the Opacity slider does.

■ Layers are shown on the palette in the order in which they are stacked in
the image—the topmost layer in the Layers palette is the topmost layer in the

TIPS

■ Palette Options
on the Layers
palette menu
changes the size of
the thumbnail
displayed in the
palette or even
hides it.

■ Buttons are not
displayed at the
bottom of the
palette when it is
minimized. Click
the palette’s
Restore button to
display them.

The Layers palette
displays the layers in an
image and lets you set
the selected layer’s
mode and opacity.
Clicking the triangle icon
displays the palette
menu, and icons along
the bottom edge let you
create or delete layers.

When you open a digital
photo, it is the
background layer.

The Layer palette’s Lock
transparent pixels (left),
Lock image pixels, Lock
position, and Lock all
(right) buttons.

THE LAYERS PALETTE
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image. The order of layers is important because it can determine what you
see and what layers are affected by changes in layers above them. For ex-
ample, if a type layer is below a fill layer or any other layer with 100% opac-
ity, it is hidden. You can drag any layer except the background layer up or
down in the Layers palette to change its position in the stacking order.

● The left column displays an eye icon when the layer is visible (page 111)
and no icon when a layer is hidden. Click to show or hide the layer and its
effects.

● The middle column displays a paintbrush (or a mask icon if the layer
has a mask—page 146) when you click it to select it as the active layer. This
is the layer to which editing changes will be made. If other layers are
linked to the selected layer, this column on those layers displays a link
icon (page 115).

● The right column displays a thumbnail indicating the layer’s contents or
function, a second thumbnail if the layer has a mask (page 150), and the
layer’s name. If a layer is locked, a lock icon is displayed in this column.

■ Add a layer style button displays a menu of styles you can apply to the
selected layer (page 122). This button is not available when the background
layer is selected.

■ Add layer mask button creates a mask that you can edit to prevent sections
of the selected layer from being affected by adjustments and to make areas of
a layer transparent so layers below show through (page 150). This button is
not available when the background layer is selected.

■ Create a new set button lets you organize layers in folder-like sets (page
109).

■ Create a new adjustment or fill layer button displays a menu of adjust-
ment and fill layers you can insert above the currently selected layer (page
116, 118).

■ Create a new layer button creates a regular layer above or below the
currently selected layer (page 107).

■ Delete layer button deletes the selected layer. You can also drag a layer
and drop it onto the icon to delete it.

Buttons at the bottom
of the Layers palette are
(from left to right) Add
a layer style, Add layer
mask, Create a new set,
Create a new fill or
adjustment layer,
Create a new layer, and
Delete layer.

The Layers palette lists
all of the layers in an
image in the same order
in which they are
stacked. This image has
three layers (from top
to bottom) a type layer,
a photo filter layer, and
the background layer
containing the photo.

In the Layers palette,
each layer has three
sections that present
information about the
layer.

Clicking the Add a layer
style or Create a new
adjustment or fill layer
icons displays a menu.
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CREATING AND PRESERVING LAYERS

Although a new digital photo has only a background layer you can convert
that layer into a regular layer and add as many additional layers as your
system has memory for.

THE BACKGROUND LAYER
The background layer, such as the one containing a digital photo that you
open for the first time, is unique in that there is only one and you can’t move
it in the stacking order or change its blending mode or opacity. However, you
can do all of these things and more if you first convert it into a regular layer.

■ To convert the background layer into a regular layer, do one of the
following:

● Double-click the background layer’s thumbnail in the Layers palette to
display the New Layer dialog box (page 108).

● Select Layer>New>Layer from Background to display the New Layer
dialog box (page 108).

● Double-click the background layer’s name and rename it.

■ To make a duplicate copy of the background layer while leaving the
background intact, select the background layer and drag it onto the New
Layer button, or choose Duplicate Layer from Layer menu or the Layer
palette’s menu.

■ To convert a regular layer into a background layer, when the image
doesn’t already have a background layer, select the layer and choose
Layer>New>Background from Layer. Any transparent areas in the original
layer are filled with the background color.

CREATING NEW LAYERS
When you add a new layer or perform an action such as adding type, a
shape, or a fill that creates a layer automatically, the new layer appears on
the palette above the currently selected layer. Since layers are usually
created to affect the layer below them—referred to as the stacking order—
the first step in creating a new layer is to select the layer above which you
want it to appear. In the case of an adjustment layer (page 116), this would
be the layer with the photo on it—usually the background layer. To add a
new layer above the selected layer, do one of the following:

■ To create a new layer above the selected layer, click the Create a new
layer button on the Layers palette. When the background layer isn’t selected,
Ctrl+click the button to add the new layer below the selected layer.

■ To create a new layer using the New Layer dialog box (page 108) do one
of the following:

● Select Layer>New>Layer to create a new regular layer or Layer from
Background to make a copy of the background layer that is a regular layer
that can be edited.

● Click the Layer palette’s triangle icon to display the palette menu and
select New Layer.

● Alt+click the Create a new layer button at the bottom of the Layers
palette.

Here the Layers palette
shows a variety of layer
types including (from
top to bottom) a regular
layer, a text layer, a
photo filter layer, a
levels adjustment layer,
and a background layer.

Buttons at the bottom
of the Layers palette are
(from left to right) Add
a layer style, Add layer
mask, Create a new set,
Create a new fill or
adjustment layer,
Create a new layer, and
Delete layer.

Selecting Layers>New
displays a submenu of
choices.

CREATING AND PRESERVING LAYERS

TIP

■ If you use the
Background or
Magic Eraser tool
(page 132) on the
background layer,
it turns it into a
regular layer and
erased areas
become transpar-
ent.
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■ To create a new layer from a selection by cutting and pasting, first copy
or cut the selection to the clipboard and then paste it back into the same or a
different image. Alternatively, you can choose Layer>New and then select
Layer via Copy or Layer via Cut.

■ To duplicate a layer, select the layer and drag it onto the New Layer
button, or choose Duplicate Layer from the Layer menu or the Layer
palette’s menu.

THE NEW LAYER DIALOG BOX
When adding a new layer to an image, a number of commands display the
New Layer dialog box where you can enter a name or change the following
settings:

TIPS

■ One technique
with a high con-
trast scene is to use
a tripod and take
two pictures—one
exposed to capture
the shadows
correctly and one
to capture the
highlights. You
then copy one of
these images into
the other so its on
it’s own layer. You
can erase through
various parts of the
top image so the
entire image looks
properly exposed.
You can also
generate the two
files from a single
RAW image.

■ Layers add to a
file’s size. You can
check the
uncompressed size
of a file, including
alpha channels and
layers, on the
status bar at the
bottom of the
window when
Document Sizes
has been selected
from the pop-up
menu.

■ Name text box displays a name that has been assigned automatically based
on the type of layer and the order in which it was created. You can type in a
new name or change it later (page 112).

■ Use Previous Layer to Create Clipping Mask check box, when on, uses the
content of the layer below to mask the layers above it (page 124).

■ Color text box lists the color of the layer in the Layers palette (not in the
image). Colors can help you identify certain layers and you can assign one by
clicking the drop-down arrow. You can also do this later by selecting a layer
and then selecting Layers>Layer Properties, or selecting Later Properties
from the Layer palette’s menu.

■ Mode specifies how pixels in the new layer blend with the layers below
(page 132). When you set this to modes other than Normal, Dissolve, Hue,
Saturation, Color, or Luminosity the check box below becomes active. Since
some filters cannot be applied to layers with no pixels, turning on this check
box fills the layer with a preset, neutral color. The neutral color uses the
layer’s blending mode and is invisible if no effect is applied.

■ Opacity specifies how transparent the layer is and how much the layer
below shows through it (page 132).

■ OK button closes the dialog box and adds the layer to the image and Layers
palette.

■ Cancel button closes the dialog box without creating the layer set.

PRESERVING LAYERS
Because you usually want to preserve layers in your working copy, you should
always save the image in a format such as PSD, TIFF, or PDF. (When you use
the Save As command, the Layers check box is available for formats that
preserve layers. If the check box is dimmed, the selected format won’t
preserve them.) If you want a JPEG image, where all layers are flattened, you
can always use the Save As command to create it from the working copy.

When saving an image
with layers, if you
choose a format that
does not support layers,
this warning icon is
displayed next to the
Layers check box in the
dialog box. To save all
of your data, be sure to
save one copy in
Photoshop’s PSD
format.
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CREATING AND USING LAYER SETS

Layer sets, acting much like folders, organize your layers and reduce clutter
in the Layers palette. You can also use layer sets to apply effects and adjust-
ments to multiple layers simultaneously.

CREATING LAYER SETS
To organize layers into layer sets, you first create a set and then move exist-
ing layers into it. There are a number of ways to create a new layer set:

■ To create a new layer set using default options, click the Create a new set
button at the bottom of the Layers palette. To add a layer set below the
currently selected set Ctrl+click the Create a new set button.

■ To create a new layer set from linked layers (page 115), select a layer to
which others are linked then choose Layer>New>Layer Set from Linked to
display the New Set from Linked dialog box.

■ To create a new layer set and specify options, do one of the following to
display the New Layer Set dialog box:

● Select Layer>New>New Layer Set from the main menu.

● Select New Layer Set from the Layers palette menu.

● Alt+click the Create a new set button in the Layers palette.

THE NEW LAYER SET DIALOG BOX
When you create a new layer set, you may see the New Layer Set or New Set
from Linked dialog box with the following settings.

■ Name text box displays a name that has been assigned automatically based
on the order in which the layer set was created. You can type in a new name
or change it later (page 112).

■ Color text box lists the color used to highlight the layer set in the Layers
palette and all layers or layer sets within it. You can assign a color by clicking
the drop-down arrow. You can also do this later by selecting a layer and then
selecting Layers>Layer Set Properties, or selecting Later Set Properties
from the Layer palette’s menu.

■ Mode (page 132) is normally set to Pass Through which means the set has
no blending properties of its own.

■ Opacity (page 132) specifies the opacity of all layers in the set.

■ OK button closes the dialog box and adds the layer set to the Layers
palette.

■ Cancel button closes the dialog box without creating the layer set.

CREATING AND USING LAYER SETS

TIP

■ Selections that
you make on one
layer, work on any
layer that you
select. It that way
they are indepen-
dent of the layers.
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A layer set containing
three layers.

ADDING AND REMOVING LAYERS
To add or remove layers or layer sets to or from a layer set do one of the
following:

■ To add a new layer to a set, select the layer set in the Layers palette and
click the palette’s Create a new layer button.

■ To move an existing layer or layer set into a layer set, drag it to the name
of the layer set so the name is highlighted and drop it.

■ To nest a layer set inside a new layer set, drag it to the Create a new set
button, or select it and Ctrl+click the Create a new set button. The layer set
and all of its layers move into the new set.

■ To remove a layer or layer set from a layer set, drag and drop it between
any other layers or above the topmost layer.

OPENING AND CLOSING LAYER SETS
You can open or close sets to show or hide their contents by clicking the
triangle to the left of the set’s folder icon in the Layers palette. The triangle
points to the right when the set is closed and points down when the set is
open. To open and close layer sets, do one of the following:

■ To open or close a set, click the triangle. You can also right-click the
triangle and choose Open This Layer Set or Close This Layer Set.

■ To open or close the set and any sets nested within it, Alt+click the
triangle.

■ To open or close all sets, Ctrl+click the triangle. You can also right-click
the triangle to the left of the folder icon and choose Open All Other Layer
Sets or Close Other Layer Sets.

■ To open or close all sets and all effects applied to layers contained within
the set(s) Ctrl+Alt+click the triangle. This is like a “reveal all” command.

An arrow icon in the
Layers palette can be
clicked to open (top) or
close (bottom) a layer
set.
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MANAGING LAYERS AND LAYER SETS

Once an image has more than one layer or layer set, you may want to select,
move, and otherwise manage them to get the best results. Almost all com-
mands discussed in this section work the same with both layers and layer sets
(when you select the set and not a layer within it). To simplify the discussion,
when you read “layer” assume it implies “layer set” unless we mention
otherwise.

SELECTING LAYERS
When an image has multiple layers, most editing commands affect only the
selected, or active layer or layer set. For example, if you make a selection
and can’t delete the selected area, it’s probably because you haven’t selected
the layer that contains the area you want to delete. For this reason it’s
important to know how to select layers and know which layer is active. Only
one layer can be active at a time and you can tell which it is by opening the
Layers palette where its name and thumbnail is highlighted and a paintbrush
icon is displayed in the second column to indicate the layer is being edited.
To select a layer, do one of the following:

■ To select a layer in the Layers palette, click its thumbnail or name.

■ To select a layer by clicking in the image, select the Move tool and right-
click. A context menu lists all layers containing pixels at the point you
clicked along with all fill and adjustment layers. Layers that are transparent
at the place you clicked and layers for text and shapes aren’t listed. Click the
name of the layer you want to select.

■ To select the topmost layer that contains opaque pixels at the place where
you click, select the Move tool and turn on the Auto Select Layer check box
on the options bar.

HIDING AND SHOWING LAYERS
You can hide and show layers at any point. You might do this to prevent a
layer from printing since only visible layers print. You might also do it to hide
an adjustment layer so it no longer affects the image. In fact, you can click an
adjustment layer on and off to compare “before” and “after” versions of the
image. When the eye icon is displayed, the layer and its contents or effects on
the image are shown. When the icon isn’t displayed, the layer’s contents and
its effects are hidden. To show or hide layer do one of the following in the
first column of the Layers palette:

■ To hide a single layer, click its eye icon. To hide or show multiple layers
drag through the eye column.

■ To hide or show all layers in a set, click the set’s eye icon. When a set is
hidden, all of the eye icons for layers in the set are dimmed.

■ To hide or show all layers but one, Alt+click the eye icon for the one layer
you want to see.

CHANGING THE STACKING ORDER
The stacking order determines whether a layer appears above or below other
layers in the Layers palette. This can sometimes affect whether a layer’s
contents are displayed or not, or determine if it’s adjustments affect the

TIPS

■ If editing
changes don’t seem
to be having the
expected effect, it
may be because
you haven’t se-
lected the correct
layer, or an area
within the layer is
selected.

■ To move the
selected layer drag
it with the Move
tool. You can’t
move the back-
ground layer
without first
converting it into a
regular layer (page
107).

TIPS

■ The background
layer is locked, but
it can still be edited
and even deleted.

■ If you use the
Background or
Magic Eraser tool
(page 134) on the
background layer,
it turns it into a
regular layer and
erased areas
become transpar-
ent.
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desired layer. To rearrange the stacking order, do one of the following in the
Layers palette:

■ To change the order of layers by dragging, select the layer or layer set
that you want to move then drag it by its name up or down. Drop it when the
highlighted line appears in the desired position between other layers or
above the topmost layer. (If you drag and drop a layer from within a set, you
can drop it outside of the set—page 110)

■ To change the order of a layer using menu commands, select the layer
that you want to move, then select Layer>Arrange, and choose a command
from the submenu to arrange the layer (when used on layers within a set,
the movements are confined to the set):

● Bring to Front makes the layer the topmost layer.

● Bring Forward moves the layer one level up in the stacking order.

● Send Backward moves the layer one level down in the stacking order.

● Send to Back makes the layer the bottommost layer in the image (except
for the background).

RENAMING LAYERS
As you add more layers to an image, they are automatically named to indicate
their type and the order in which they were created. If you didn’t name them
at the time you created them you’ll find that it’s helpful to give them descrip-
tive names reflecting their content or purpose. (You can’t rename the back-
ground layer without changing it into a regular layer.) To rename a layer do
one of the following:

■ Double-click the layer’s name in the Layers palette, and enter a new name.

■ Double-click the layer’s thumbnail in the Layers palette to display the
Layer Properties dialog box, type in a name, and click OK.

■ Select the layer in the Layers palette, pull down the Layer menu or display
the palette’s menu and select Rename Layer to display the Layer Properties
dialog box, type in a name, and click OK

DELETING LAYERS
When you no longer need a layer, you can delete it to free up memory and
simplify the Layer palette. To do so, select the layer in the Layers palette and
do one of the following. If prompted to confirm the deletion, click Yes:

■ To delete a layer by dragging, drag and drop it on the trash can icon at the
bottom of the Layers palette.

■ To delete the selected layer by clicking, click the trash can icon at the
bottom of the Layers palette. To bypass the dialog box requesting confirma-
tion of the deletion, Alt+click the trash can icon.

■ To delete the selected layer using a menu, pull down the Layer menu or
display the Layer palette’s menu, and choose Delete Layer.

■ To delete hidden or linked layers, display the Layer palette’s menu and
choose Delete Hidden Layers or Delete Linked Layers.

■ To delete a layer set select it, then choose Layer>Delete Layer Set. A
dialog box asks if you want to delete the set and its contents or just the set. If
you delete the set and contents, the set and the layers within it are deleted. If

When you hide all
layers, a checkerboard
pattern appears. This
pattern is often used to
indicate transparent
areas of an image. You
can change the look of
this display using the
Transparency section on
the Edit>Preferences
submenu.

TIPS

■ If you move part
of one or more
layers outside of
the image area and
know you won’t
need those areas
choose Select>All
and then Image>
Crop to delete
them and reduce
the file’s size.

■ You can’t move
the background
layer from the
bottom of the layer
stack without first
converting it into a
regular layer (page
107).

■ A composite of
all visible layers is
printed. To print
an individual layer,
make it the only
visible layer in the
Layers palette
before choosing the
Print command.
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● As text box lists the default name assigned to the duplicate, but you can
type over it with your own descriptive layer name.

● Document lists the name of the active image as the destination but the
drop-down arrow lets you select any other open file, or a new file. If you
select a New file, the Name text box becomes available to enter a name for
the new file. Enter a name and click OK.

● OK duplicates the layer. If you duplicate the layer into a new image, that
image has no background layer.

■ To duplicate the selected layer or layer set without specifying options,
select it and drag and drop it on the Create a new layer button at the bottom
of the Layers palette. The duplicate is given the same name as the original,
followed by copy. (If you drop a layer or layer set on the Create a New Layer
Set button, it will be nested within the newly created layer set.)

COPYING AND MOVING LAYERS TO ANOTHER IMAGE
To copy or move layers between images, you can drag and drop them. To
move multiple layers at the same time, put them together in a layer set (page
109) or link them (page 115).

■ To drag a layer or layer set to another image from the Layers palette,
select the layer in the palette and drag and drop it into the other image. To
center it in the new image, Shift+drag it into the target image and drop it.

■ To use the clipboard to copy or move a selection from one image to
another, select the area to be moved (Select>All to select all of the pixels on
the layer), and then select Edit>Copy or Edit>Cut to copy or move the

you delete just the set, it’s the same as moving the layers out of the set, then
deleting the empty set.

DUPLICATING LAYERS AND LAYER SETS
You can duplicate a layer or layer set into the same image, another image, or
a new image. If duplicating it to another image, be sure that image is open
and select Window>Images>Tile to arrange them side by side. To duplicate
any layer including the background layer or any layer set, select it in the
Layers palette, and do one of the following:

■ To duplicate the selected layer or layer set and specify options, pull down
the Layer menu, display the Layer palette’s menu, or right-click the layer’s
name (not the thumbnail) and choose Duplicate Layer or Duplicate Layer
Set to display the Duplicate Layer or Duplicate Layer Set dialog box. These
dialog boxes are identical and have the following options:

TIP

■ When you
duplicate a layer to
another image, the
duplicate layer
appears in the
destination image
above the active
layer. You can
either first select
the layer in the
destination win-
dow above which
you want it to
appear, or drag it
in the stacking
order after copying
it. To copy more
than one layer, first
link them together
(page 115).

The Layer menu.
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selection to the clipboard. Make the destination image active, select the layer
you want the copied layer above and select Edit>Paste to copy the selection
from the clipboard to a new layer.

MOVING LAYERS WITHIN AN IMAGE
When working with multiple layers, there are situations in which you want to
move individual layers vertically or horizontally. Perhaps you want to align
one image with another or align text on an image. Even if you move a layer
partially out of the image area, its contents are preserved so you can drag it
back into view. To move multiple layers at the same time, link them and
select the layer the others are linked to (page 115), or move the layers into a
set and then select and move the set. To move a selected layer do one of the
following:

■ To drag the selected layer, drag it with the Move tool. Hold down Shift as
you drag to constraint the movement to up or down, left or right, or to a 45°
diagonal.

■ To move the layer in small increments, press the arrow keys on the
keyboard to move it in 1-pixel increments, or hold down Shift while pressing
the arrow keys to move the layer in 10-pixel increments.

■ To select the topmost layer that contains opaque pixels at the place where
you click, select the Move tool and turn on the Auto Select Layer check box
on the options bar.

■ To align layers, you can reduce the opacity of the top layer so the layer
below shows through. After aligning the two layers, return the top layer’s
opacity to the setting you want to use.

LOCKING LAYERS
Fully or partially locking layers protects their contents. This is a way to
protect a finished layer, or some aspects of a layer in progress. For example,
if you protect the layer from painting tools, you can still change its position.
When a layer is locked, a lock icon is displayed to the right of the layer’s
name. When the layer isn’t selected, the lock icon is black when the layer is
fully locked and white when the layer is partially locked. It’s the reverse
when the layer is selected. (For type and shape layers, Lock Transparency
and Lock Image are selected by default and cannot be unselected.)

■ To lock a layer’s properties, select the layer and then click one of the lock
buttons at the top of the Layers palette:

● Lock All locks all layer properties. (This is the only button that works
when you have selected a layer set.) If you turn this on, you have to turn it
off before you can click any of the other three buttons to lock specific
properties.

● Lock Transparency confines editing to the opaque or semitransparent
portions of the layer.

● Lock Image prevents modification of the layer’s pixels using the paint-
ing tools.

● Lock Position prevents the layer’s pixels from being moved.

■ To apply lock options to all linked layers or all layers in a layer set,
select a linked layer or a layer set, select Lock All Linked Layers or Lock All

TIPS

■ Copying or
moving layers
between images is
almost identical to
doing the same
with selections. For
details not covered
here, see the
section on Moving,
Copying, and
Pasting Selections
(page 96).

■ Dragging and
dropping layers
between images
takes up less
memory than
copying and
pasting them
because they aren’t
first copied to the
clipboard.

■ When you copy
or move a layer
between images
with different
resolutions, the
pasted data retains
its original pixel
dimensions. This
can make the
pasted portion
appear out of
proportion to the
new image. You
can choose
Image>Resize>
Image Size to make
the source and
destination images
the same resolu-
tion before copying
and pasting.

The Layer palette’s Lock
transparent pixels (left),
Lock image pixels, Lock
position, and Lock all
(right) icons.
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Layers in Set from the Layers menu or the Layer palette’s menu to display a
dialog box, select the lock option you want to use and click OK.

LINKING LAYERS
Linking layers, or even layer sets, lets you save time because you can move
their contents together. You can also copy, paste, align, merge, apply trans-
formations to, and create clipping masks from the linked layers. To link
layers, first select one of the layers you want to link, then in the other layers
you want linked together, click the column to the immediate left of the
thumbnail to display a link icon. When you select a layer, if link icons are
displayed for other layers, it means those layers are linked to the selected
layer. To unlink layers, click the link icon.

MERGING AND FLATTENING LAYERS
Adding layers to an image increases its file size and the amount of memory it
needs and the complexity of the Layers palette. To reduce file sizes and
simplify the palette, you can merge layers when you have finished editing
them. Once merged you can no longer edit them the same way you did before
merging.  For example, if you merge a type layer into an image, you can no
long change the font styles.

To merge or flatten layers, select the appropriate layer and pull down the
Layer menu from the main menu or display the palette’s menu and choose
one of the following commands (the choices listed on the menu depend on
the type of layer you have selected):

■ Merge Down merges the selected layer with the layer below it. Make sure
both layers display an eye icon and select the top layer of the pair.

● If the bottom layer in the pair is a shape, type, or fill layer, you can’t
choose Merge Down until you’ve rasterized the layer (page 123).

● If the bottom layer in the pair is linked to another layer or is an adjust-
ment layer (page 116), you also can’t choose Merge Down.

■ Merge Linked (available only when you select a layer with other layers
linked to it) merges all visible layers linked to the layer you select—those
displaying both the eye and link icons.

■ Merge Layer Set (available only when you have selected a set) merges all
layers in the set and deletes the set.

■ Merge Visible merges all layers with an eye icon, so hide any layers you
don’t want to merge. If all layers are visible, this command is the same as
flattening the image.

■ Flatten Image merges all layers in the image and the effects on the image
created by those that are visible are made permanent. Hidden layers are
discarded and transparent areas are filled with white.

SAMPLING FROM LAYERS
Normally the Magic Wand, Smudge, Blur, Sharpen, Paint Bucket, Clone
Stamp, and Healing brush tools only sample pixels from the active layer. This
allows you to work on a single layer without affecting others, even when they
are visible. However, if you want to sample and affect all visible layers you
can sometimes do so. Just select one of the tools and turn on the Use All
Layers check box on the options bar.

TIPS

■ To keep track of
file sizes, click the
triangle on the
status bar at the
bottom of the
screen and select
Document Sizes
from the menu.
The value on the
left shows what the
file size would be if
you were to flatten
all the layers into
one. The value on
the right shows the
file size with all the
layers intact.

■ When merging
layers, overlapping
transparent areas
in the merged
layers remain
transparent.

■ If you can’t print
an image because
its file is too large,
flatten the image to
make it smaller.

TIP

■ Two layer
options that are
commonly used
with multiple
layers are blending
modes and opacity.
The blending mode
determines how
the pixels in one
layer blend into the
pixels on the layer
below. Opacity
determines how
transparent a layer
is and how much
the layer below it
shows through.
These settings are
discussed in detail
on page 132.
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USING ADJUSTMENT LAYERS

Adjustment layers let you experiment with color and tonal adjustments
without permanently modifying an image. Adjustments are stored in the
adjustment layer, and only their effects are “projected” onto the underlying
image. There are a number of reasons why you always want to use adjust-
ment layers when you can.

■ You can undo changes to an image at any time just by deleting the adjust-
ment layer that created them.

■ You can hide and show the adjustment layer to compare, save, or print
before and after views of the same image. (One trick is to quickly toggle an
adjustment layer on and off a number of times to see exactly what effects it’s
having on the image.)

■ You can fine-tune adjustments at any time.

■ You can copy the adjustment layer to other photos needing the same
adjustments. For example, if you have photographed a series of portraits
under the same lighting, you can adjust one image and then copy the adjust-
ment layers to each of the other images in the series.

■ Most commands affect only a single layer but adjustment layers affect all
layers below them or in their layer set.

CREATING AN ADJUSTMENT LAYER
To create an adjustment layer, open the Layers palette and select the topmost
layer you want to adjust. Adjustment layers normally affect all layers below
them. However, you can confine the adjustment to selected layers or selected
parts of an image.

■ To confine adjustments to a single layer or group of layers, create the
adjustment layer and then use it as one layer in a clipping mask consisting
only of it and the layers to be adjusted (page 124). You can also put the
adjustment layer in a layer set along with the layers to be affected and change
the set’s blending mode to any mode other than Pass Through. (Try Normal
to start.)

■ To limit the effects of an adjustment layer to only a part of the image,
select that area first although you can also do this later by editing the layer’s
mask (page 150). When you create an adjustment layer, it has a layer mask—
indicated by the mask thumbnail to the right of the layer thumbnail in the
Layers palette. If you create the adjustment layer when a part of the image is
selected, the selection is reflected in the mask. The purpose of the mask is to
confine the adjustments to a specific part of the image and you can edit at
any point to change its size, shape, feathering, opacity and so on (page 150).

Once you have selected what is to be affected, choose Layer>New Adjust-
ment Layer from the main menu or click the Create new fill or adjustment
layer button at the bottom of the Layers palette to display a menu. (Note that
if you clicked the palette button, the first three commands listed on the menu
are fill layers (page 118), not adjustment layers.) The choices on the menu
include the following and selecting one displays a dialog box discussed
elsewhere in this book on the indicate page:

■ Levels displays the levels dialog box so you can adjust the tonal range of
the image (page 61).

The Create new fill or
adjustment layer button
on the Layers palette is
the one with the circle
icon that’s half black
and half white.

The Layer>New
Adjustment Layer
command displays a
submenu listing the
kinds of adjustment
layers you can create.

Adjustment layers have
two thumbnails in the
palette. The layer
thumbnail on the left
indicates the type of
adjustment. The mask
thumbnail is on the
right (page 150).
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■ Curves displays the Curves dialog box so you can adjust the tonal range of
the image (page 64).

■ Color Balance displays the Color Balance dialog box (page 71).

■ Brightness/Contrast displays the Brightness/Contrast dialog box (page
61).

■ Hue/Saturation displays the Hue/Saturation dialog box so you can adjust
hue, saturation, and lightness (page 71).

■ Selective Color displays the Selective Color Options dialog box.

■ Channel Mixer displays the Channel Mixer dialog box.

■ Gradient Map displays the Gradient Fill dialog box so you can select a
gradient to fill the layer (page 118).

■ Photo Filter displays the Photo Filter dialog box (page 71).

■ Invert inverts the colors in an image making a positive image look like a
film negative and vice versa.

■ Threshold, used to convert an image to a high-contrast black-and-white
image, displays the Threshold dialog box and histogram. You drag a slider to
specify a threshold between 0 and 255. All pixels lighter than the threshold
become white; and all pixels darker become black.

■ Posterize, used for special effects, displays the Posterize dialog box where
you specify the number of levels for each color channel. To see how it works,
click in the Posterize dialog box’s Levels text box and press the up and down
arrows to change the levels as you watch the effect on the image. (Hold down
Shift to change the levels by 10.) Alt+click the Cancel button to reset effects
to their defaults.

EDITING ADJUSTMENT LAYER OPTIONS OR TYPE
In many ways, adjustment layers are just like other layers. They have the
same opacity and blending mode options, and can be moved within the layer
stacking order, deleted, hidden, and duplicated.

Once you create an adjustment layer, you can easily edit the settings, or even
change the layer to a different type of adjustment.

■ To edit an adjustment layer using the original dialog box, double-click its
layer thumbnail (the left one) in the Layers palette, or select the layer, then
choose Layer>Layer Content Options. Make the desired changes in the
dialog box and click OK.

■ To change the adjustment layer to a different type, select the layer then
choose Layer>Change Layer Content and select a different type of adjust-
ment from the list.

MERGING ADJUSTMENT LAYERS
You can merge an adjustment layer just like any other layer (page 115)
however, you can’t use it as the base or target layer for a merge. When you
merge an adjustment layer with the layer or layers below it, the adjustments
are rasterized and permanently applied to the merged layer. If the adjust-
ment layer is in a set, it’s affects are only applied to other layers in the same
set. The layer’s adjustments no longer affect other layers below the merged
adjustment layer.

TIP

■ If an adjustment
layer’s mask (the
layer’s rightmost
thumbnail in the
Layers palette)
contains only white
values, the layer
isn’t adding much
to the file’s size, so
you won’t save
much by merging
the layers.

TIPS

■ Adjustment
layers are assigned
a name that
reflects their type
of adjustment.

■ To reduce an
adjustment layer’s
effects, reduce its
opacity.

USING ADJUSTMENT LAYERS
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● Gradient shows a thumbnail of the selected gradient and you can click
the drop-down arrow to display a palette of preset gradients from which to
choose. Gradients with a checker board pattern fade to transparency. You
can also click the triangle icon to display a menu listing other libraries of
gradients from which to choose.

● Style specifies the shape of the gradient. Your choices include Linear,
Radial, Angle, Reflected, and Diamond.

● Angle compass specifies the angle at which the gradient is applied. To
change the angle, drag the compass needle or type an angle into the text
box.

● Scale slider changes the size of the gradient.

● Reverse check box, when on, reverses the order of the colors in the
gradient fill.

● Dither check box, when on, creates a smoother blend with less banding.

● Align With Layer check box, when on, aligns the gradient with the
edges of the image.

■ Pattern displays the Pattern Fill dialog box so you can select a pattern,
make other optional settings discussed below, and click OK.

● The pattern swatch shows a thumbnail of the selected pattern. You can
click the drop-down arrow to display a palette of preset patterns from
which to choose. You can also then click the triangle icon to display a
menu listing other libraries of patterns from which to choose.

USING FILL LAYERS

Fill layers are filled with a solid color, a gradient, or a pattern. Unlike adjust-
ment layers, fill layers do not affect the layers below them. Normally you
would place a fill layer below another layer that has transparent areas—
perhaps a text or shape layer so the fill shows through. Alternatively, you
might place it above another layer and cut holes in it or change its opacity so
the layer below shows through. You can also change the fill layer’s blending
mode to control how it interacts with pixels on the layers below.

TYPES OF FILL LAYERS
The types of fill layers you can create include the following:

■ Solid Color displays the color picker (page 126) so you can select a solid fill
color for the layer.

■ Gradient displays the Gradient Fill dialog box so you can select a gradient,
and make other optional settings discussed below, and click OK.

The Layer>New Fill
Layer submenu.

Gradient types (top
down) linear, radial,
angle, reflectance, and
diamond.
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● Scale slider makes the elements in the pattern larger or smaller.

● Link With Layer check box, when on, moves the pattern and layer
together when you drag them. When off, you can’t drag the pattern which
is always aligned with the image window.

● Snap to Origin button aligns the upperleft corner of the pattern with the
ruler origin in the upperleft corner of the image.

● Create a new preset from this pattern button saves a pattern you have
created or revised for future use.

CREATING A FILL LAYER
There are two ways to create a fill layer; using the main menu or the palette
button. To begin, select the layer above which you want to fill layer to appear.
To confine the effects of the fill to a selected area of the image, make a
selection. Then do one of the following to display a fill’s dialog box so you can
make the desired settings in the dialog box and click OK:

■ Select Layer>New Fill Layer to display a submenu listing the kinds of fill
layers you can create and click the one you want to use.

■ Click the Create a new fill or adjustment layer button at the bottom of the
Layers palette, and click the one you want to use.

When you create a fill layer, it has a layer mask—indicated by the mask
thumbnail to the right of the layer thumbnail in the Layers palette. If you
create the fill layer when a part of the image is selected, that selection is
reflected in the mask. The purpose of the mask is to confine the fill to a
specific part of the image and you can edit at any point to change its size,
shape, feathering, opacity and so on (page 150).

EDITING FILL LAYERS OPTIONS OR TYPES
Just as with adjustment layers, you can edit a fill layer’s settings using the
same dialog box you used to create it, or even change the layer to a different
type of fill.

■ To edit a fill layer using the original dialog box, double-click its layer
thumbnail (the left one) in the Layers palette, or select the layer and then
choose Layer>Layer Content Options. Make the desired changes in the
dialog box and click OK.

■ To change the fill layer to a different type, select the layer then choose
Layer>Change Layer Content and select a different type of fill from the list.

MERGING FILL LAYERS
You can merge or rasterize a fill layer just like any other layer (page 115, 123).
When you merge a fill layer with the layer below it, the fill is permanently
applied to the merged layer.

TIPS

■ When creating or
editing a gradient
or pattern fill,
when the dialog
box is displayed,
you can click in the
image area and
drag the gradient
or pattern to align
it the way you
want.

■ To resize a
pattern, choose
Select>All to
surround it with a
bounding box with
corner and side
handles you can
drag. You can also
drag within the
bounding box to
shift the pattern to
a new position.

■ Fill layers are
assigned a name
that reflects their
type of fill.

■ To see through a
fill layer to the
layers below,
adjust it’s opacity.

USING FILL LAYERS

Clicking the triangle icon
in the gradient or fill
palette displays a menu
listing other libraries of
gradients and fills.

HTTP://WWW.SHORTCOURSES.COM


120

CHAPTER 5. WORKING WITH LAYERS

FOR INFORMATION ON CLASSROOM USE, VISIT HTTP://WWW.PHOTOCOURSE.COM

ENTERING TYPE

Adding type to images is usually the realm of graphic designers, not photog-
raphers, especially those doing straight photography. However, it’s so easy to
do, you should know how so you can create title slides for your slide shows,
add copyright notices to your images, or just invent ways to combine type
and images in creative ways. The type tools enter horizontal or vertical type
or horizontal or vertical masks (selections in the shape of type). As you type,
a new layer is automatically created and type appears on-screen so you can
always see how it looks in your layout.

You can enter type in two ways, as point type or paragraph type. When
entering point type you end lines by pressing Enter. When entering para-
graph type, lines wrap automatically (inside a bounding box) just as they do
in a word processor, and you press Enter to end paragraphs.

SELECTING A TYPE TOOL
The toolbox contains four different type tools. To select one, point to the
Type tool, hold down the mouse button, and select one of the following:

■ Horizontal Type tool enters or selects horizontal type.

■ Vertical Type tool enters or selects vertical type.

■ Horizontal and Vertical Type Mask tools create selections in the shape of
type. These selections can be used just like any other selections (see Chapter
4) and edited and formatted like any other type.

SETTING TYPE TOOL OPTIONS
After selecting a type tool you then select formats on the options bar, Charac-
ter palette, or Paragraph palette. Some settings are available on both the
options bar and one of the palettes but they are all synchronized so changing
one changes the other. Your choices on the options bar include the following:

■ Change the type orientation button changes the type from horizontal to
vertical or vice versa much as if you were switching between the Horizontal
and Vertical Type tools.

■ Set the font family drop-down arrow specifies a font—a set of characters
that share a common style. Well-known fonts include Times Roman and
Helvetica.

■ Set the font style drop-down arrow specifies if the selected font will be
Regular, Bold, or Italic. The available type styles varies among fonts.

■ Set the font size drop-down arrow specifies how large the type is. The
universal unit of measurement for type is points (there are 72 points to the
inch), however, you can use an alternate unit of measurement by entering the
following abbreviations following the number—in, cm, pt, px, or pica. The
value you enter is converted to points. To enter a size larger than 72 points
click in the font size type box and type in a number between 0.01 and 1296 in
points or the equivalent in any other unit of measurement.

■ Set the anti-aliasing method smooth edges by partially filling edge pixels,
so type blends into the background. However, it increases file sizes and may

Type tools in the
toolbox.

The Character (top) and
Paragraph (bottom)
palettes are used to
format selected text.

TIP

■ To reposition
text as you are
entering it, hold
down Ctrl and drag
the text to where
you want it.
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create unwanted colors along the edges of type. When not used, type may
have jaggies—stair-step like curves and diagonals. When you click the drop-
down arrow, your choices include None (the default), Sharp (the most
sharp), Crisp (somewhat sharp), Strong (makes type appear heavier) and
Smooth (makes type appear smoother).

■ Left align, Center, and Right align text buttons, align point type relative to
where you first click to begin typing and paragraph type relative to the sides
of its bounding box.

■ Set the text color swatch displays the current color of the type. To change it
for new or selected type, click the swatch to display the color picker and
select a new color (page 126).

■ Create warped text button distorts type in a variety of shapes; for example,
in the shape of an arc or a wave. Warping applies to all type on the selected
type layer. To warp type while entering it or after selecting it later, click the
Warp button to display the Warp text dialog box. Select a Style to specify the
basic shape of the warped layer, use the option buttons and sliders to set the
bend and distortion of the warp effect, and then click OK. To unwarp type,
select the type layer and Type tool and repeat the process, but select None on
the Style drop-down menu, and click OK.

■ Toggle the Character and Paragraph palettes button displays and hides a
group window containing the two type formatting palettes.

ENTERING AND FORMATTING NEW TYPE
When you select a horizontal or vertical type tool, the mouse pointer changes
into a vertical or horizontal I-beam. When entering horizontal type, the small
line through the I-beam indicates the base line on which the type you enter
will rest. When entering vertical type, it indicates the center line of the type.
Clicking in an image with a Type tool puts the tool in edit mode so you can
enter and edit type. When in edit mode, a blinking cursor, the height of the
selected type size and in the same orientation as the Type tool, appears at the
point you click (called the insertion point). The options bar displays Cancel
and Commit buttons that you use to exit edit mode. As you enter type, it has
the format and alignment specified on the options bar, Character palette, or
Paragraph palette. If you change any character formats such as style or size
after you start typing, the changes only affect new type. To change previ-
ously entered type you have to first select it (page 122).

■ To enter type with the tool and formats you have selected, do one of the
following to enter edit mode:

● To enter point type, click in the image to set an insertion point for the
type, then type in your text. To begin a new line, press Enter on the main
keyboard. To delete characters, press backspace.

● To enter paragraph type, drag diagonally to define a bounding box for
the type. (You can also specify a size for the bounding box if you Alt+drag
to display the Paragraph Text Size dialog box.) Enter your text and as you
reach the edge of the bounding box, text automatically wraps to the next
line. To begin a new paragraph, press Enter on the main keyboard. If you
enter so much text that it can’t all be displayed in the bounding box at the
same time, the overflow icon appears in the lowerright corner of the
bounding box to indicate text is hidden.

■ To transform text, perhaps to rotate, scale or distort it, drag handles on the
bounding box. These handles are always displayed when entering paragraph

Point (top) and
paragraph (bottom) text
being entered.

When there is too much
text for the box, the
overflow icon appears in
the lowerright handle

When you click the
Warp text button it
displays the menu (top)
and selecting a choice
displays the dialog box
(bottom).

ENTERING TYPE
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text and can be displayed for point text by holding down Ctrl. You can use the
same commands as those discussed for the Free Transform command (page
101) except for perspective.

■ To commit the type and leave edit mode so you can perform other opera-
tions, such as selecting menu commands or moving the type to a new posi-
tion, do one of the following:

● Click the Commit button in the options bar.

● Press the Enter key on the numeric keypad, or Ctrl+Enter on the main
keyboard.

● Select any tool in the toolbox, click in the Layers, Channels, Paths,
Actions, History, or Styles palette, or select any available menu command.

When you commit text it basically closes the layer although you can still edit
and format it. When you enter new text, a new layer is created for it. Commit-
ting type in sections lets you keep separated those text elements you want to
format differently.

SELECTING TEXT
To edit or format existing text, you have to first select it in edit mode. When
you are not already in edit mode, select the text layer in the Layers palette,
then enter edit mode as follows:

■ To select all text on a type layer, select the layer in the Layers palette, and
double-click its layer thumbnail (the one on the left). You can press the left or
right arrow key to unselect the text and move the insertion point.

■ To select an entire line or paragraph, click anywhere in it with a Type tool
so it contains the insertion point.

■ To select individual characters, lines, or paragraphs, select a Type tool,
select the type layer in the Layers palette, or click in the text to automatically
select its layer. Click in the text where you want the insertion point to be, and
do one of the following:

● To move the insertion point through the text, press the left or right
arrow keys.

● To select text a character at a time, drag through it or hold down Shift
and press the right or left arrow key.

● To select larger elements, multi-click as follows—to select a single word
(double-click), a line (triple-click), paragraph (quadruple-click), or all text
(quintuple-click).

● To select a sequence between two points, position the insertion point to
the left of the first character in a sequence, then Shift+click to the right of
the last character.

● To select all text, right-click the text and choose Select All.

FORMATTING TEXT
There are three kinds of formats you can apply to text and each has it’s own
requirements about what you select to apply the format. For example,
commands on the Paragraph palette will effect entire lines and paragraphs
but not individually selected characters or words within those larger ele-
ments.

Text can be easily
formatted using the
Layer>Layer Styles
command or the Styles
palette.

The Cancel and Commit
icons.

The Styles palette will
format all of the text on
the selected layer.

If you exit Photoshop
without committing
text, a dialog box asks if
you want to commit it,
cancel exiting, or
discard the text.

When you apply layer
styles they are listed in
the Layers palette under
the layer you applied
them to.
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■ Character formats such as type size, style, and color affect only selected or
new characters.

■ Paragraph formats, such as alignment, affect entire lines or paragraphs
that either contain the insertion point or have been selected in whole or part.

■ Layer formats, such as warping and formats assigned with the Styles
palette affect all text on the selected layer even when smaller elements such
as words or paragraphs are selected.

Once you have selected the text you want to format, you format it as follows
and then click the Commit button:

■ To apply character or paragraph formats, change settings on the options
bar, in the Character palette, or in the Paragraph palette.

■ To apply a layer style, choose Layer>Layer Style to display a dialog box
you use to apply such effects as a drop shadow or beveled edges. You can also
choose Window>Styles to display the Styles palette. Be sure to display the
palette’s menu and try new styles listed in sets at the bottom of the menu.

■ To move selected text, select the Move tool, point to the text and drag it.
You can also move it later by dragging its layer.

■ To transform the text, drag handles on the bounding box. These handles
are always displayed when entering paragraph text and can be displayed for
point text by holding down Ctrl.

■ To convert point text to paragraph text, select it then select Layer>Type>
Convert to Paragraph Text.

RASTERIZING TYPE AND SHAPE LAYERS
Type and shape layers are different from other layers. Their content is not in
the form of pixels, but in the form or points, lines, and curves defined by
mathematical formulas. This format, called vector graphics, lets you size
these elements without their losing any sharpness. Fill layers are also differ-
ent in that they are generated. At some point you may want to convert one of
these layers to pixels—called rasterizing or simplifying them—so you can
apply filters or use selection and painting tools. However, once you do this
you can no longer make changes to the layer using the same tools you used to
create it. Because it’s converted to pixels you edit it just like you edit images.
To rasterize a layer, select it, choose Layer>Rasterize to display a submenu
from which to choose the type of layer.

CREATING A TYPE SELECTION
Using the Horizontal Type Mask and Vertical Type Mask tools, you can
select areas of an image in the shape of the characters you type. After typing
and clicking the Commit button on the options bar, the selection border is
displayed on the image. It’s just like any other selection border that you use
to select, cut, copy, move, or adjust selections.

To create a type selection border, select a regular layer on which you want
the selection to appear. (Type, shape, fill, and adjustment layers should be
rasterized first). Select the Horizontal Type Mask tool or the Vertical Type
Mask tool, set additional type options, and then enter point or paragraph
type. A red mask appears over the active layer as you enter the type. Once
the type is committed, the type selection border appears in the image on the
active layer.

Here text was typed
over an image of pine
needles and then cut
and pasted into another
image.

TIPS

■ In edit mode you
can pull down the
Edit menu and use
the Undo, Check
Spelling, and Find
and Replace Text
commands.

■ To explore the
type mask tools,
use them to cut
some text from one
image to paste into
another or cut text
out of one layer to
show the image on
the layer below.

■ You can change
the unit of mea-
surement in the
Units & Rulers
section of the
Preferences dialog
box.

ENTERING TYPE

Choose Layer>Styles to
display the Layer Styles
dialog box that lets you
apply interesting styles
to type and other
layers.

HTTP://WWW.SHORTCOURSES.COM


124

CHAPTER 5. WORKING WITH LAYERS

FOR INFORMATION ON CLASSROOM USE, VISIT HTTP://WWW.PHOTOCOURSE.COM

CREATING CLIPPING MASKS

You can enter type or a shape and have it filled with parts of an image. To do
so, you put the type or shape on one layer and the image on the layer above.
When you define the two layers as a clipping mask, the transparent pixels of
the bottom or base layer mask out the content of layer above it. The image is
displayed in the shape of the type or contents on the base layer, and take on
that layer’s opacity.

Another use of clipping masks is to confine the effects of an adjustment layer
to a group of layers. To do this, first create the adjustment layer (page 116),
then include it in or at the base of the clipping mask. The adjustment will
then be confined to the layers inside the group.

■ To create a clipping mask, do one of the following in the Layers palette:

● Alt+click the line dividing two layers with the pointer changed to two
overlapping circles).

● Select the top layer and choose Layer>Create Clipping Mask from the
main menu.

● Link the desired layers, then choose Layer>Create Clipping Mask from
Linked.

■ To remove a layer from a clipping mask, do one of the following in the
Layers palette:

● Alt+click the line separating two grouped layers with the pointer
changed to two overlapping circles.

● To remove the selected layer and any layers above it from the clipping
mask choose Layer>Release Clipping Mask.

■ To ungroup all layers in a clipping mask, select the base layer in the
clipping mask and choose Layer>Release Clipping Mask.

TIP

■ Since an image is
usually on the
background layer,
you have to convert
it to a regular layer
to place a type or
shape layer below
it for a clipping
path. An adjust-
ment layer doesn’t
need to be at the
bottom of the
group.

With a text layer below
a photo, creating a
clipping path shows the
photo in the shape of
the text.

In the Layers palette
overlying layers are
indented and have a
bent-arrow icon. The
base layer’s name is
underlined.
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The author of a book on making black and white prints from negatives
called his chapter on spotting prints to remove dust spots “So You
Have To Know How to Paint After All.” That would also be a good title

for this chapter because painting and drawing are useful tools in digital
photography. Although often used by graphic artists to add elements to
photographs and layouts, these tools are also used to fix or touch up areas of
your images or to select areas that you want to change. You can paint, erase,
and draw shapes with several different tools, all of which are introduced in
this chapter. In the next chapter you’ll learn how to use these tools to create
masks that precisely select the areas of your image you want to adjust.

Chapter 6
Painting & Drawing

CONTENTS

■ Selecting Foreground
and Background Colors
■ Using Brushes and
Pencils ■ Specifying
Tool Options ■ Erasing
■ Retouching Images ■
Using the Paint Bucket
and Gradient Tools ■
Drawing Shapes
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SELECTING FOREGROUND AND BACKGROUND COLORS

Toward the bottom of the toolbox are two overlapping color swatches that
display the current foreground and background color. The foreground color
in the upperleft swatch is used to paint, fill, and stroke selections. The
background color in the lowerright swatch is used to create gradient fills, fill
in areas erased on the background layer, and fill the canvas when you enlarge
it. Both colors are also used by some special effects filters.

The default foreground and background colors are black and white but you
can change them to any other colors using the color picker, Eyedropper tool,
Swatches palette, or Color palette.

USING THE COLOR PICKER
The color picker lets you select the foreground or background color from a
color spectrum or by entering color values. The color picker is widely avail-
able from dialog boxes through Photoshop, but to display it from the always
available toolbox do one of the following:

■ To change the foreground color, click the upperleft color swatch.

■ To change the background color, click the lowerright color swatch.

■ HSB, RGB, Lab, and CMYK are color models among which you can choose.
Their text boxes display the current value of the selected color and change as
you make adjustments. You can type values into these boxes to change the
color, but normally you drag sliders or click to select a color and these values
change automatically. The option buttons next to each text box (except
CMYK) specify which component of which color mode is displayed on the
narrow, vertical color slider to the left. The default, and most frequently used
color model is HSB that displays saturation (S) and brightness (B) as per-
centages from 0% to 100% and hue (H) as an angle from 0° to 360° that
corresponds to a location on a color wheel. HSB is the only model we discuss
in detail but the others work much the same and you can learn about them in
help.

The foreground and
background color
swatches and icons in
the toolbox. Click the
Default Colors icon
(lowerleft) to set the
foreground and
background colors to
black and white. Click
the Switch Colors icon
(upperright) to reverse
them.

TIPS

■ When the color
picker is open:

● Click in the
image outside of
the Adobe Color
Picker to select a
color.

● Click in the
image and hold
down the mouse
button as you point
anywhere on your
desktop. Releasing
the mouse button
selects the color
you’re pointing to.

HTTP://WWW.PHOTOCOURSE.COM


127FOR INFORMATION ON DIGITAL PHOTOGRAPHY, VISIT HTTP://WWW.SHORTCOURSES.COM

■ The square color field displays the range for the two unselected color
components—one on the horizontal axis, one on the vertical. For example,
with the H option button in the HSB section selected, this field displays the
saturation (S) and brightness (B) range of the hue selected on the color
slider. The selected hue’s saturation increases from left to right and bright-
ness increases from bottom to top. A circular marker indicates the currently
selected color’s position in the field.

■ Only Web Colors check box, when on, limits color choices to the 216 Web-
safe colors that are displayed accurately on a system set to display only 256
colors.

■ The color slider displays the range of the selected color component. With
the default H option button selected in the HSB section, the color slider
displays all available hues. To select a new hue on the slider click in it, drag
the white sliders up or down, or press the up and down arrow keys (hold
down Shift as you press them to move in larger jumps). Your goal is to select
the hue you want to use so you can then select its brightness and contrast by
clicking in the square color field to the left. When you click the color, things
happen:

● The circular marker in the color field indicates the new color’s position
in the field.

● The adjusted/original colors rectangle to the right of the color slider
displays the new color in the top half and the original color in the bottom
half.

● Alerts are displayed if the color is not Web-safe or is out of gamut (can’t
be printed). If an alert appears, click it to change the selected color to the
nearest safe alternative.

● # text box displays the hexadecimal number of the currently selected
color.

When you click the color picker’s OK button, the selected color is shown in
the foreground or background color swatch on the toolbox.

USING THE EYEDROPPER TOOL
The Eyedropper tool can quickly set a foreground or background color to any
color displayed on the screen. To begin, select the Eyedropper tool and click
the Sample Size drop-down arrow on the options bar to set the size of the
area that the tool samples. The choices include Point Sample to get the
precise value of the pixel you click, and 3 by 3 Average or 5 by 5 Average to
get the average value of the specified number of pixels around the pixel you
click.

With the Eyedropper tool set, change foreground and background colors as
follows:

■ To select a new foreground color from an image, click the desired color in
any open image. To select a color that appears outside of images, point inside
an image, hold down the mouse button, and point to the desired color.
Release the mouse button to select the new color.

■ To select a new background color from an image, Alt+click the color you
want in any open image. To select a color that appears outside of images,
point inside the image, hold down Alt and the mouse button, and point to the
desired color. Release the mouse button to pick the new color.

TIP

■ If you click in the
corner of the color
field and drag the
circular marker
into and past the
corner you will
select a pure color.

SELECTING FOREGROUND AND BACKGROUND COLORS

Watch the area next to
the adjusted/original
color rectangle for
alerts:

■ When a color is “out
of gamut” and can’t be
printed with CMYK inks,
an exclamation point
inside a triangle is
displayed.

■ When a color isn’t
“Web safe” a cube is
displayed.

To select the nearest in-
gamut or Web safe
color, click the
appropriate alert.

TIP

■ To use the
Eyedropper tool
temporarily while
using most paint-
ing tools, hold
down Alt. This
allows you to
quickly change the
foreground color.

Eyedropper sample size
can be Point Sample, 3
x 3, or 5 x 5.
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Swatches displayed as a
small list (above) and as
small thumbnails
(right).

USING THE SWATCHES PALETTE
You can select foreground or background colors just by clicking sample
colors stored in libraries in the Swatches palette. If the color picker is a “pick
any possible color” system, the swatches palette is more like selecting a color
from a paint chart. You can even add colors to a swatch library when you
want to reuse a specific color that’s not already in the palette. To display the
Swatches palette, select Window>Swatches.

■ To choose a foreground color, click a color in the palette.

■ To choose a background color, Ctrl+click a color in the palette.

■ To change the swatch library, click the triangle icon to display the palette
menu and click one of the libraries listed at the bottom of the menu. You can
also choose Load Swatches and select a swatch file. To return to the default
swatch library, select Reset Swatches from the same menu.

■ To change how swatches are displayed, display the palette menu and
select Small Thumbnail (the default) to display a thumbnail of each swatch
or Small List to display the name and thumbnail of each swatch.

■ To store the current foreground color for later use, click the Create new
swatch of foreground color button at the bottom of the palette. (To store the
current background color, first click the Switch Color icon to make it the
foreground color.) You can also click any empty square at the end of the list
or select New Swatch from the palette menu to display the Color Swatch
Name dialog box. When you enter a descriptive name in the dialog box and
click OK the swatch is added to the end of the palette and its name is dis-
played when you point to it or display the colors as a small list.

■ To delete a color, drag its swatch to the trash icon, or Alt+click it.

THE COLOR PALETTE
The Color palette is a simplified color picker where you use the palette’s
menu and sliders to select the foreground and background colors using
different color models. You can also choose a color from the spectrum of
colors displayed on the color ramp at the bottom of the palette. To display
the Color palette, choose Window>Color. The Color palette is outside the
scope of this book but you can learn more about it in help.

The Color palette and its
menu.
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USING BRUSHES AND PENCILS

Painting with a brush or pencil tool changes the colors of pixels and the
effect you have depends on the brush or pencil that you select. For example,
you can paint wide, feathered, semitransparent strokes or narrow, hard-
edged opaque strokes. There are two basic painting tools—the Brush and the
Pencil, both of which paint with the current foreground color:

■ The Brush tool, by default, paints with strokes that are soft but you can
change this. You can also use the Brush tool as an airbrush to simulate the
effect of spraying a fine mist of color.

■ The Pencil tool, by default, creates hard-edged, freehand lines.

When using these tools, be sure to paint on a separate layer so you can hide,
or delete your changes by hiding or deleting the layer. If you paint on a
separate layer you can also apply layer styles and change blending modes at
any time—things you can’t do if you paint directly on the image layer.

SETTING BRUSH AND PENCIL TOOL OPTIONS
When you select the Brush or Pencil tool, the Brush (top) or Pencil (bottom)
option bar offers the following settings:

■ Tool Preset Picker drop-down arrow lets you select preset tools.

■ Brush displays a thumbnail of the currently selected brush or pencil and
gives its diameter in pixels. You can click the thumbnail or the drop-down
arrow to display the Brush palette so you can change the size and hardness
of the selected brush or select a new one (page 130).

■ Mode specifies how pixels in the image are affected by a painting or
editing tool (page 132).

■ Opacity specifies the amount of paint coverage applied by the tool for
each stroke (page 132).

■ Flow slider (Brush only) controls how quickly paint is applied by the
Brush tool. A low setting produces a lighter stroke (page 132).

■ Airbrush button (Brush only) is normally off but you can click it to turn it
on when you want to use the Brush tool as an airbrush that applies gradual
tones to an image, simulating traditional airbrush techniques.

■ Auto Erase check box (Pencil only) is normally off, but you can turn it on
so you can erase with the pencil (page 134).

USING THE BRUSH AND PENCIL TOOLS
Once you have selected a tool, set its options, and selected a foreground
color, you are ready to paint in the image.

■ To paint, drag in the image. When opacity is set low, each additional
stroke over the same area lays down more color but only if you first release
and then repress the mouse button between strokes.

TIPS

■ When the
options bar dis-
plays text boxes for
percentages or
sizes:

●●●●● Click in the box
and press the up or
down arrow keys to
change the num-
ber, and hold down
Shift as you do so
to change it by 10s.

●●●●● If the options
bar has more than
one such text box,
you can click in
one, then Tab to
the others.

●●●●● To highlight the
entry in the first
text box, just +
press Enter.

USING BRUSHES AND PENCILS
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■ To draw a straight line, click a starting point in the image, then
Shift+click an ending point.

■ When using the Brush tool as an airbrush, paint as usual but pause where
you want to build up the color and move the pointer more quickly to apply
less color. For more control, reduce opacity and flow.

You can select preset brushes, and make minor changes to them, from either
the Brush pop-up palette on the options bar or the Brushes palette. Both
also allow you to view, select, and load libraries of preset brushes. Although
outside the scope of this book, the Brushes palette also lets you design
custom brushes.

USING THE OPTION BAR’S BRUSH PALETTE
 To display the option bar’s Brush palette, click the Brush thumbnail or
drop-down arrow, or right-click in the image after selecting the Brush or
Pencil tool.

TIPS

■ When painting,
it helps to use
shortcuts to zoom
in on details and
quickly adjust
brush sizes.

● To zoom in and
out, hold down Ctrl
while pressing the
+ and - keys on the
numeric keypad.

● To change the
size of the brush,
press the square
brackets [ and ].

■ To select a brush, click it on the list showing its diameter and a typical
stroke. After clicking one brush you can press the up or down arrow keys to
quickly scroll through others. To display a brush’s name, point to it and
pause until the tool tip appears.

■ Master Diameter slider changes a brush’s diameter. If the brush has a
dual tip, both the primary and dual brush tips are scaled. You can also
change a brush’s diameter on the fly while painting by pressing the [ and ]
keys.

■ Hardness slider changes the brush’s hardness or how much a brush stroke
fades out to form a feathered edge. In the palette, soft brushes look out of
focus and hard brushes look very sharp.

■ Triangle icon displays the palette’s menu so you can change the way
brushes are displayed and select other libraries of brushes listed at the
bottom of the menu.
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The Brushes palette and its menu work much like the almost identically
named Brush palette on the options bar discussed above. However, you can
choose Brush Presets to see sample strokes or Brush Tip Shape to see what
the brush tips look like. The biggest difference is that this palette lists brush
characteristics that you can adjust. Click the name of any characteristic to
display its settings on the right. For example, some brushes have two tips
and you access options for the primary tip by clicking Brush Tip Shape and
options for the secondary tip by clicking Dual Brush.

CREATING A SAMPLED BRUSH
One interesting thing you can do is select an area of the image and then
create a sampled brush that has the same size and shape as the selection. To
begin, make a selection in the image, then select Edit>Define Brush Preset.
The brush can be up to 2500 pixels by 2500 pixels in size. You can control
the hardness of the brush by feathering the selection before defining the
brush. For example, set feathering to 0 pixels to create a brush with a hard
edge. You select and use sampled brushes just like other brushes, and even
change their size.

■ Create a new preset from this brush button saves the current brush for
reuse. To name and save the current brush, click this button or select New
Brush from the palette menu to display the Brush Name dialog box. Enter a
descriptive name for the brush and click OK. The new brush is selected on
the options bar, and is listed at the bottom of the palette where its name is
displayed when you point to it. To rename or delete the brush, right-click it in
the palette and select Rename Brush or Delete Brush or select it and choose
the same commands from the palette menu.

USING THE BRUSHES PALETTE
To display the Brushes palette, select Window>Brushes. If you have already
selected a brush or pencil (or an erasing tool, toning tool, or focus tool), you
can also display the palette by clicking the Toggle Brushes palette button on
the options bar to the left of the Toggle File Browser button.

The Brush and Brushes
palettes have identical
palette menus except
for the top two
commands on the
Brushes palette menu
(shown above). At the
bottom of both menus
are libraries of other
brushes that you can
select. Use the Reset
Brushes command to
restore a palette’s
default brushes.

The Toggle Brushes
palette button (left) on
the options bar next to
the Toggle File Browser
button displays and
hides the Brushes
palette.

USING BRUSHES AND PENCILS
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A checkerboard pattern
often indicates
transparent areas of an
image.

The Opacity Slider bar.

SPECIFYING TOOL OPTIONS

Many tools and all layers let you specify blending modes and opacity. Here
we discuss those settings and others you find on the options bar when you
select the tools discussed in this chapter used to paint, erase and retouch
images.

BLENDING MODE
Blending modes (aka Mode) are available on the options bar for many tools
and in the Layers palette for all layers except the background. These modes
determine how a color you apply with a tool interacts with the colors you
paint over or how the colors on one layer interact with colors on the layers
below. Modes are powerful creative tools, especially when using photos in
the graphic arts or manipulating them extensively. However, blending
modes are outside the scope of this book although we encourage you to
search on-line help for “selecting a blending mode” and also refer to other
books on the creative use of Photoshop. You can also experiment with them
as you work on images of your own.

The list of available
blending modes.

Three layers were
created with a colored
circle on each layer.
With the layer blending
modes all set to Screen
the Red, Green, and
Blue circles show other
RGB colors where they
overlap (left). Just by
changing the circles’
colors to cyan,
magenta, and yellow
and the mode to
Multiply, the three
circles simulate CMYK
printing (right).

OPACITY
The opacity of a tool or layer determines how much the layer below shows
through. The default setting is always 100% so the tool or layer is totally
opaque with no show-through. However, clicking the drop-down arrow
displays the Opacity slider you drag to change the setting. If you reduce
opacity, you increase transparency, until you reach the limit of 1% opacity,
or 99% transparency. The one exception to this general rule is Eraser tool
opacity where opacity determines what amount is erased, not what’s left.
For example, if the opacity of an area is 100% and you set an eraser’s opacity
to 10%, areas you drag over have a remaining opacity of 90%.

For subtle effects with some tools, you can set opacity low and then make
multiple passes over an area, with each pass increasing the effect. The secret
is to release and then repress the mouse button between passes. You may
also want to temporarily reduce a layer’s opacity so you can see through it to
align it or your edits with the layer below. When finished, return it’s opacity
to 100%.

Opacity cannot be set to 0% so you can’t use most tools to create completely
transparent areas. The exception to this are the Eraser tools. Since you can
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set their opacity to 100% and totally erase areas, so they become
transparent. You can also create completely transparent areas by selecting
and deleting sections in one layer so the layer below shows through. These
transparent areas are not affected by the opacity setting.

FLOW
Flow specifies how quickly paint is applied by the tool and is normally set to
100% but clicking the drop-down arrow displays the Flow slider you can
drag to change the setting. When set low, it lets you build up the color by
pausing or making with repeated passes over the same area so the color
deepens until it reaches the level specified in the Opacity setting. You don’t
have to release and repress the mouse button between passes to saturate an
area. When used with eraser tools, the effect of the setting is the same but
applies to erasing rather than painting.

USE ALL LAYERS
Use All Layers check box, when on, samples colors from all visible layers not
just the active one.

ANTI-ALIASED
Anti-aliased check box, when on, smooths the edges of the areas you edit by
partially filling edge pixels so they blend into the background color.

TOLERANCE
Tolerance specifies what range of colors is selected, erased, or replaced with
a range between 0–255. A low tolerance limits affects to areas that are very
similar to the sampled (clicked) color. A high tolerance affects a broader
range of colors. If you find you are affecting colors you didn’t intend to affect,
specify a lower tolerance.

LIMITS
■ Limits specifies which areas of color are affected:

●●●●● Discontiguous affects the sampled color wherever it occurs under the
brush.

●●●●● Contiguous erases affects areas that contain the sampled color and are
connected to the area under the brush.

●●●●● Find Edges affects connected areas containing the sampled color while
preserving the sharpness of shape edges.

LAYER AND TOOL INTERACTIONS
Since you can set blending modes and opacity for both tools and layers, it
stands to reason the settings interact. For example, painting with a 40%
opacity on a layer with 100% opacity is the same as painting at 100% opacity
on a layer with 40% opacity. The interactions can take a little getting used to
but will become familiar should you decide this is an area you want to
explore in more detail.

SPECIFYING TOOL OPTIONS

Anti-aliasing (bottom)
softens the transition
between contrasting
colors.

TIP

To see the effects of
blending modes,
open an image and
the Layers palette.
Click the Layers
palettes’ Create a
new layer button
to add a layer
above the image.
Select the Paint
Brush tool and
paint some brush
strokes on the
layer. Now, select
the Move tool and
hold down
Shift+Alt as you
press the + and -
keys on the nu-
meric keypad to
cycle the layer
through all of the
blending modes.
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ERASING

The Eraser, Background Eraser, and Magic Eraser tools erase areas of an
image but work in slightly different ways. For example, the Eraser and Magic
Eraser tools erase areas of an image to transparency or to the background
color. The Background Eraser tool erases to transparency on a layer.

The toolbox displays only one of the tools at a time. To select one of the
hidden tools, point to the tool in the toolbox and hold down the mouse
button to display all three, or Alt+click the displayed tool to cycle through all
of them.

USING THE ERASER TOOL
The eraser tool changes pixels in the image as you drag through them.

■ When you erase on the background layer the erased area is filled with the
background color because the background can’t have transparent areas. It’s
as if you are painting instead of erasing.

■ When you erase on a regular layer without transparency locked, the
erased area can be made transparent by setting the tool’s opacity to 100%.
Lower settings make it semitransparent.

■ When you erase on a regular layer with transparency locked, the erased
area is filled with the background color but transparent areas remain unaf-
fected.

After selecting the tool, these choices become available on the options bar
(unless you set the Mode to Block).

■ Tool Preset Picker drop-down arrow lets you select preset tools.

■ Brush lets you select and adjust a brush to erase with (page 130).

■ Mode for this tool works differently than for other tools. It lets you select
a Brush (softer), Pencil (harder), or Block (smaller, great for square corners)
to erase with and your choice affects which other options are available.

■ Opacity specifies the maximum amount of erasing applied by the tool
(page 132).

■ Flow controls how quickly color is erased by the Eraser tool. A low setting
produces a lighter stroke (page 132).

■ Erase to History check box lets you erase to a saved state or snapshot of
the image. With this on, click the left column of the state or snapshot in the
History palette that you want to erase back to and erase. To temporarily use
the Eraser tool in Erase to History mode, Alt+drag through the area you
want to erase.

USING THE BACKGROUND ERASER TOOL
The Background Eraser tool erases the areas around an object without
erasing the object’s edges. It’s a good way to remove the background behind a
portrait. The tool overrides the Lock Transparency setting of a layer.

When you point to an area of an image and press the mouse button, the tool
samples the color under the cross hairs in the center of the brush, called the

TIPS

■ When erasing, it
helps to use
shortcuts to zoom
in on details and
quickly adjust
brush sizes.

● To zoom in and
out hold down Ctrl
while pressing the
+ and - keys on the
numeric keypad.

● To change the
size of the paint-
brush, eraser, or
other tool, press
the square brackets
[ and ].

TIP

■ When you want
to erase but not
have completely
transparent areas,
set opacity to less
than 100%. If you
set it low enough,
you can drag over
areas more than
once, each time
increasing their
transparency a
little more. To
erase in multiple
strokes, release and
repress the mouse
button each time.
As long as you hold
the mouse button
down, it will only
erase an area one
time.
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hot spot, and deletes that color wherever you click or drag the brush to make
the area transparent. The brush also removes colors around the edges of
foreground objects so color halos are not visible if you paste the foreground
selection into another image.

If you use the tool on the background layer, when you release the mouse
button the layer is converted into a regular layer with erased areas becoming
transparent. After selecting the tool, the choices below become available on
the options bar.

■ Tool Preset Picker drop-down arrow lets you select preset tools.

■ Brush lets you select and adjust a brush to erase with (page 130).

■ Limits specifies which areas of colors are erased (page 132).

■ Tolerance specifies the range of colors to be erased (page 132).

■ Protect Foreground Color check box, when on, prevents the erasure of
areas that match the foreground color in the toolbox. (To change the fore-
ground color, Alt+click in the image.)

■ Sampling specifies which colors are sampled as you edit. Your choices
include Continuous to sample colors continuously as you drag, Once to erase
only areas containing the color that you first click, and Background Swatch
to erase only areas containing the current background color. (To select a
background color, Alt+click it with the Eyedropper tool.)

The Background Eraser
was used to erase the
area around the
monster and the
checker board pattern
indicates transparent
areas of the image. The
layer was then copied to
another image that
provides an interesting
background.

Here the Background
Eraser tool’s Limits was
set to Contiguous (left)
and Discontiguous
(right). In both cases, a
section of the Monarch’s
wing was clicked. With
the tool set to
Discontiguous, the color
was erased wherever it
fell under the brush.

TIP

■ When using a
pressure-sensitive
digitizing tablet,
search help for
Stylus to see how it
works with various
tools.

ERASING
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TIPS

■ Using the Magic
Eraser or the
Background Eraser
tools on the
background layer
converts in into a
regular layer.

■ When using the
Eraser or Back-
ground Eraser
tools, you can draw
straight lines by
holding down Shift
as you click.

USING THE MAGIC ERASER TOOL
The Magic Eraser is a tool you click, not drag. When you click in a layer with
the tool, it samples the color under the pointer and erases all pixels with a
similar color.

■ When used on a background layer, when you release the mouse button the
layer is converted into a regular layer with erased areas becoming transpar-
ent.

■ When used on a regular layer with unlocked transparency, the pixels are
erased to transparency.

■ When used on a regular layer with locked transparency, the pixels change
to the background color.

After selecting the tool, the choices below become available on the options
bar. After setting them, click in the area of the layer you want to erase.

■ Tolerance specifies the range of colors to be affected (page 132).

■ Anti-aliased check box, when on, smooths the edges of the areas you edit
(page 132).

■ Contiguous check box, when on, erases only pixels that are adjacent to the
one you click. When off, pixels are erased no matter where they are in the
image.

■ Use All Layers check box, when on, samples colors from all visible layers
not just the active one (page 104).

■ Opacity specifies the maximum amount of erasure applied by the tool
(page 132).

USING THE PENCIL TOOL’S AUTO ERASE OPTION
The Auto Erase check box on the Pencil tool’s option bar, when on, lets you
paint the background color over areas containing the foreground color. After
selecting a foreground and background color and turning this on, drag over
the image to paint with the background or foreground color depending on
where your stroke starts:

■ If you begin dragging over areas in your image that contain the fore-
ground color, the pencil tool paints with the background color.

■ If you begin dragging from an area that doesn’t contain the foreground
color, the tool paints with the foreground color.
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RETOUCHING IMAGES

At times there will be small areas in an image that need retouching. For
example, some portraits have red-eye caused by the camera’s flash, or
complexions have minor imperfections. These and other problems can be
fixed by selecting one of the retouching tools in the toolbox.

THE COLOR REPLACEMENT TOOL—REMOVING RED-EYE
The Color Replacement tool changes the hue, saturation, color, or luminosity
of the area you click or drag over without affecting detail. This tool easily
removes red-eye, or glare from eyeglasses, dental braces, or other reflective
surfaces. When you select the tool, the options bar displays the following
settings:

■ Tool Preset Picker drop-down arrow lets you select preset tools.

■ Brush lets you select and adjust a brush (page 130).

■ Mode specifies how pixels in the image are affected by colors you apply
with the tool (page 132). The choices are a subset of the normal list and
include Hue, Saturation, Color and Luminosity.

■ Sampling specifies which colors are sampled as you edit. The choices
include Continuous to sample colors continuously as you drag, Once to use
only the color that you first click, and Background Swatch to replace the
foreground color with the background color. (To select a foreground color
Alt+click with the Color Replacement tool. To select a background color,
Alt+click it with the Eyedropper tool.)

■ Limits specifies which areas of color are replaced (page 132).

■ Tolerance specifies the range of colors to be replaced (page 132).

■ Anti-aliased check box, when on, smooths the edges of the areas you edit
(page 132).

One use of this tool is to correct red-eye that appears in photos when the
camera’s flash reflects off the back of a person’s eye. To replace the red with a
color of your choice, you need to select an accurate replacement color, use a
brush of just the right size, and have the Tolerance set to just the right point
so the correct colors are replaced. Here is how to do it:

■ Zoom into the area you want to fix.

■ Select the Color Replacement tool in the toolbox and on the options bar set
Mode to Color, Sampling to Once, Limits to Discontiguous, and Tolerance to
30 percent or so. Set the brush size so it’s somewhat smaller than the red
area of the eye. (Remember that pressing [ and ] adjusts the brush size.)

■ Choose a foreground color that will replace the red. To do so, click the
foreground color swatch in the toolbox. In the color picker, select a color
similar to the subject’s actual eye color and click OK.

■ To repair your photo, click once on the color you want to replace or drag
over it. If you can’t remove all of the red, try increasing the Tolerance level
on the options bar to correct more shades of red. When Tolerance is set too
low, there may be a red ring or area in the eye that isn’t changed.

When using the Color
Replacement tool you
click the Brush drop-
down arrow on the
options bar or right-click
in the image to adjust
the brush.

TIP

■■■■■ After using any
tool discussed in
this section you can
select Edit>Fade ...
to make final
adjustments.

Red-eye before (above)
and after (below)
correction.

RETOUCHING IMAGES
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BURNING AND DODGING
Two of the most popular darkroom techniques since the first prints were
made from negatives have been dodging and burning to darken or lighten
selected areas to bring out details.

■■■■■ Dodging was done using a piece of cardboard or other tool to block light
from selected areas of the image to make them lighter.

■■■■■ Burning was done with a piece of cardboard with a hole cut in it that let
you selectively darken light areas of the image.

To dodge or burn in Photoshop, select the Dodge or Burn tool in the toolbox,
and set the following options:

■ Tool Preset Picker drop-down arrow lets you select preset tools.

■ Brush lets you select and adjust a brush (page 130).

■■■■■ Range drop-down arrow selects the tones affected by the tool and includes
the choices Midtones, Shadows, and Highlights.

■■■■■ Exposure drop-down arrow displays a slider that adjusts the intensity of
the tool. The higher the setting, the more effect it has. The default is 50% but
for precise control set this to a low value and drag over the area a number of
times, releasing the mouse button periodically, making small changes on
each pass.

CLONING
The Clone Stamp tool copies a sample from the image, and applies it else-
where on the same or different image. One use for the tool is to remove
blemishes from portraits by selecting a smooth area of the skin to paint over
an imperfect area. The tool can also be used to remove such things as tele-
phone lines from an image.

To begin you select the Clone Stamp tool in the toolbox and set its options.
You then select what to paint with by Alt+clicking an area that matches the
tone, color, texture, and other characteristics of the area you want to repair.
Finally, you paint the area you want to repair by clicking or dragging. When
you hold down the mouse button, cross hairs indicate where the pixels that
you are painting with are coming from. As you drag, the crosshairs trail along
sampling new colors that they pass over. It’s as if you are painting one part of
the image by picking up colors, details, and patterns from another part. If
your results aren’t what you hope for, you can always select Edit>Undo and
try again.

■ Tool Preset Picker drop-down arrow lets you select preset tools.

■ Brush lets you select and adjust a brush that determines how large an area
you clone and how it’s applied (page 130).

■■■■■ Mode and Opacity determine how the copies blend with the image (page
132).

■■■■■ Flow slider controls how quickly the cloned area is applied (page 132).

■■■■■ Aligned check box, when on, samples pixels relative to where you first click

TIP

■ When dodging
and burning, set
the exposure level
low and make
multiple passes
over an area to
adjust it. Release
the mouse button
between passes or
the tool reaches its
limit and has no
more effect.

TIP

■ When cloning
one of the most
important settings
is the Aligned
check box. It
determines where
the crosshairs are
displayed, and
what colors are
copied, when you
hold down the
mouse button for
each stroke.

When using the Clone
Stamp tool, right-
clicking the image
displays a set of
brushes.
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to paint. Each time you start a new stroke, the sampling point is at the same
distance and angle from the mouse pointer as it was for the first stroke.
When off, each time you begin a new stroke, sampling begins at the same
place you originally sampled.

■■■■■ Use All Layers, when on, samples from all layers, not just the active one
(page 104).

HEALING BRUSH
The Healing Brush works much like the Clone Stamp tool, but instead of just
copying a selection, it blends it seamlessly into the background so the tex-
ture, lighting, transparency, and shading aren’t changed. You can either paint
with pixels sampled from the image or select a pattern to paint with.

Normally, you select the tool and set the Source to Sampled. You then
Alt+click in an area near the imperfection that has the color and tone you
want to paint with to hide the imperfection. You then click or drag over the
imperfection. Just keep in mind that the sampling point trails along sampling
new areas as you move the mouse pointer. To minimize problems, paint in
short strokes. When you release the mouse button, the blending takes effect.
The status bar indicates progress and you can always use the Edit>Undo
command to reverse the change if you don’t like it.

■ Tool Preset Picker drop-down arrow lets you select preset tools.

■ Brush lets you select and adjust a brush (page 130).

■ Mode specifies how pixels in the image are affected by painting with the
tool (page 132). Choose Replace to preserve noise, film grain, and texture at
the edges of the brush stroke.

■■■■■ Source specifies what you paint with when retouching an image:

●●●●● Sampled uses pixels you select by Alt+clicking them in any open image.

●●●●● Pattern paints with a pattern you select by clicking the Pattern drop-
down arrow to display a palette of choices. The palette’s menu lists other
libraries of patterns from which to choose.

■■■■■ Aligned check box, when on, samples pixels relative to where you first click
to paint. Each time you start a new stroke, the sampling point is at the same
distance and angle from the mouse pointer as it was for the first stroke.
When off, each time you begin a new stroke, sampling begins at the same
place you originally sampled.

■ Use All Layers check box, when on, samples colors from all visible layers
not just the active one (page 104).     When off you sample colors only from the
active layer.

PATCH TOOL
The Patch tool repairs an area of the image. To begin, select the area to be
repaired and then drag a copy of the selection border to an area that has the
texture, lighting and shading that you want to repair with. As you do so, the
area you choose is displayed in the original selection border so you can see
how it blends with the surrounding area. When you then drop the selection
border copy on the area of your choice, Photoshop seamlessly blends that
area with pixels in the original selection. There are only two options on the

TIPS

■ When retouch-
ing, it helps to use
shortcuts to zoom
in on details and
quickly adjust
brush sizes.

● To zoom in and
out hold down Ctrl
while pressing the
+ and - keys.

● To change the
size of the paint-
brush, eraser, or
other tool, press
the square brackets
[ and ].

■ If the area you
want to heal has
high contrast
edges, begin by
selecting an area
slightly larger than
the area you want
to heal but pre-
cisely following the
boundary of
contrasting pixels.
When you then
select and paint
with the Healing
Brush tool, colors
from outside won’t
bleed into the
selected area.

RETOUCHING IMAGES

When using the Healing
Brush tool you click the
Brush drop-down arrow
on the options bar or
right-click in the image
to adjust the brush.
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option bar. One (Destination) reverses the default process and lets you
select the area you want to repair with and drag and drop it on the area to be
repaired. The other lets you repair with a pattern if the image doesn’t
contain an area that meets your needs. You can select areas in the image
using the Patch tool or you can select them with other tools before selecting
the Patch tool. Generally, the tool works best with small areas.

■ Multiple selection buttons specify how multiple selections interact when
they overlap (page 86). When making multiple selections, you can’t begin
drawing one selection inside another or you will move the selection.

■ Source option button lets you begin by selecting the area that needs
repairing using the Path tool which operates much like the Lasso tool (page
90). Once selected, you point inside the selection border, drag it to the area
you want to use for the repair. As you do so, the area you are pointing to is
displayed in the area you selected to be repaired so you can preview the
results. When it’s the way you want it, drop the selection.

■ Destination option button lets you begin by selecting the area you want to
repair with. Once selected, you point inside the selection border, drag it to
the area you want to repair and drop it.

■ Use Pattern button, active only after you have selected an area to be
repaired, displays the currently selected pattern and has a drop-down arrow
you can click to select another. After selecting a pattern, click the Use
Pattern button to apply it. This setting is useful when the image has no areas
matching the area you want to repair.

OTHER TOOLS
Photoshop has so many painting tools, entire books could be, and have been,
written just about them. Since this is an introductory book, many of these
tools cannot be discussed in detail. However, here are some tools you may
want to explore after you have mastered the basics.

■ Blur tool blurs and the Sharpen tool sharpens edges that you drag over.

■ Sponge tool changes the saturation of areas you drag over.

■ Smudge tool smudges colors in your image. The Strength drop-down
arrow sets the intensity of the smudging. The Finger Painting check box,
when on, smears the foreground color onto the image. When off, the tool
smears the color under the pointer at the beginning of the stroke. To tempo-
rarily turn on Finger Painting as you drag with the smudge tool, hold down
Alt as you paint.

■ Pattern Stamp tool paints with the pattern you choose by clicking the
Pattern drop-down arrow on the options bar to display thumbnails of
available patterns. When the Aligned check box on the options bar is on, you
can draw multiple strokes and the patterns will match up where they overlap.
When off, they won’t. When the Impressionist check box is on, the pattern
looks impressionistic.

■ History and Art History Brushes paint with stylized strokes, using the
source data from a state or snapshot selected in the History palette. The
History Brush tool paints by recreating the specified source data, while the
Art History Brush tool uses that data along with the options you set to create
different colors and artistic styles.

TIP

■ When using the
Patch tool to repair
with pixels from
the image, select a
small area to
produce the best
result. And you can
also make a
selection prior to
selecting the Patch
tool. You can also
adjust the selection
as follows:

●●●●● Shift+drag in the
image to add to the
existing selection.

●●●●● Alt+drag in the
image to subtract
from the existing
selection.

●●●●● Alt+Shift+drag
in the image to
select an area
intersected by the
existing selection.
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USING THE PAINT BUCKET AND GRADIENT TOOLS

Filling layers and selections with solid colors or gradients is often useful in
photography because you can use these tools to create backgrounds or
borders or more importantly, to edit masks (page 146).

USING THE PAINT BUCKET TOOL
The Paint Bucket tool fills an area that is similar in color value to the pixels
you click. The fill can be the foreground color or a pattern you choose from a
wide selection.

To use the Paint Bucket tool, select it in the toolbox and click the part of the
image you want to fill. All pixels identical to the one you click or within the
specified tolerance are filled with the foreground color or pattern. To limit
the fill to a specific area, select that area first. Here are the option bar settings
that affect the tool:

■ Fill drop-down arrow specifies if you fill with the foreground color or with
a pattern.

■ Pattern, available only if you set Fill to Pattern, displays a thumbnail of
the currently selected pattern and has a drop-down arrow you click to display
a palette of patterns from which to choose. You can also then click the
triangle icon on the palette to display a menu listing other groups of patterns
from which to choose.

■ Mode specifies how pixels in the image are affected by the colors you fill
with (page 132).

■ Opacity specifies the amount of paint coverage applied by the tool for
each stroke (page 132).

■ Tolerance specifies the range of colors to be replaced (page 132).

■ Anti-alias check box, when on, smooths the edges of the filled selection.

■ Contiguous check box, when on, fills only pixels that are adjacent to the
one you click. When off, all similar pixels are filled no matter where they are
in the image.

■ All Layers check box, when on, samples colors from all visible layers.

You can work on your images while they are displayed against a background
color other than the default gray. To do so, click the image window’s Maxi-
mize button or drag the image window corners away from your image so that
the image window is larger than the image. Select the foreground color you
want to use, and then select the Paint Bucket tool in the toolbox. Hold down
Shift, and click in the area surrounding your image.

USING THE GRADIENT TOOL
The Gradient tool creates a gradual blend between multiple colors. To apply a
gradient, you should create a new layer so you don’t paint over the pixels on
the image layer. The gradient will fill the entire layer, so if you just want it to
be in one area, select that area first. You then drag the path along which or
around which you want the gradient to form. You can choose from existing
gradient fills or create your own.

TIPS

■ If you don’t want
the Paint Bucket
tool to fill transpar-
ent areas on a
layer, lock the
layer’s transpar-
ency in the Layers
palette (page 105).

■ If you are filling
a layer, you may be
better off using a
fill layer (page 118).

Here a gradient was
added to a layer mask
(page 150) and it
makes the image fade
in from left to right.

USING THE PAINT BUCKET AND GRADIENT TOOLS
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■ The direction you drag determines the angle and sequence of the gradient.
For example, dragging in opposite directions reverses the gradient. Dragging
vertically creates a vertical gradient and dragging horizontally creates a
horizontal gradient. To constrain the gradient angle to a multiple of 45°,
Shift+drag.

■ The distance you drag determines the spacing of the gradient’s colors or
tones. For the linear gradient, you drag the entire path, but for the others you
just drag half of the path, from the center to the edge around which you want
it to form.

To use the Gradient tool, select it in the toolbox and make the following
settings on the options bar:

■ Gradient displays a thumbnail of the currently selected gradient. You can
click the thumbnail to display the Gradient Editor dialog box so you can edit
the currently selected gradient. (If you are interested in this, search held for
“editing gradients.”) To change the gradient, click the drop-down arrow to
display a palette of gradient from which to choose. You can also click the
triangle icon on the palette to display a menu listing other groups of gradi-
ents from which to choose. Gradients with a checker board pattern fade to
transparency.

■ Gradient fill types are icons you click to select one of the following types of
gradients:

●●●●● Linear gradient runs perpendicular to the path you drag.

●●●●● Radial gradient forms a circle around the radius you drag.

●●●●● Angle gradient forms a counterclockwise sweep around the radius you
drag.

●●●●● Reflected gradient forms a gradient along the path you drag, and forms
a mirror image of it on the side you didn’t drag.

●●●●● Diamond gradient forms a diamond-shaped gradient around the radius
you drag. The point where you stop dragging becomes one corner of the
diamond.

■ Mode specifies how pixels in the image are affected by a painting or
editing tool (page 132).

■ Opacity specifies the amount of paint coverage applied by the tool for
each stroke (page 132).

■ Reverse check box, when on, reverses the order of the colors in the gradi-
ent fill. This has the same effect as dragging in the opposite direction when
you create the fill.

■ Dither check box, when on, creates a smoother blend with less banding.

■ Transparency check box, when on, lets the gradient create transparent
areas. To preview its effect, select a gradient that has transparent areas
indicated by the checker board pattern, then click this check box on and off
while watching the gradient thumbnail.

Gradient types (top
down) linear, radial,
angle, reflectance, and
diamond. The arrow
shows the path
dragged.
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DRAWING SHAPES

The Shape tools provide an easy way to create buttons, navigation bars, and
other items used on Web pages. Shapes (and text) are vector graphics, made
up of lines and curves defined by their geometric characteristics instead of by
pixels. This allows them to be scaled to any size and printed at any resolution
without losing detail or clarity. As you drag to draw shapes, they are normally
created on a new layer although you can click one of the Multiple shape
buttons on the options bar to draw multiple shapes on the same layer. The
shape tools you have to choose from include the following:

■ Rectangle tool draws a square-cornered rectangle and the Rounded
rectangle tool draws a round-cornered rectangle with the corners having the
specified Radius.

■ Ellipse tool draws an ellipse and circle.

■ Polygon tool draws a polygon having the specified number of Sides.

■ Line tool draws a straight line with the thickness specified in the Weight
text box. You can even add arrowheads to it

■ Custom Shape tool displays the Shape drop-down arrow on the options bar
which you can click to display a palette of shapes to choose from. Clicking the
small triangle on the palette displays a menu of shape categories from which
you can choose related shapes.

CREATING A SHAPE
To create a shape, select any of the shape tools, check that the Shape layers
button on the option bar is selected, then drag. When you release the mouse
button, a new layer appears with the shape on it and the shape is filled with
the color specified on the options bar (by default the foreground color). As
you are drawing a shape, do the following:

■ To draw a shape not filled with color, hold down Alt before you press the
mouse button and start to drag.

■ To expand the shape outward from its center, instead of from a corner,
hold down Alt after you start to drag.

■ To constrain the shapes to their original proportions (rectangular and
elliptical shapes are squares or circles), Shift+drag the shape.

■ To expand the shape from the center and retain original proportions hold
down Alt+Shift after you start to drag.

■ To move the shape as you draw it, without releasing the mouse button,
hold down the spacebar and drag the shape to reposition it.

■ To add a second or subsequent shape to the same layer, click one of the
multiple shape buttons on the options bar other than the New shape layer
button.

SHAPE OPTIONS
When you select a Shape tool, the options bar displays settings you can
change. The options are the same for all tools with one exception. The
choices common to all Shape tools are as follows:

Shape tools in the
toolbox.

The Shape layers button
(the leftmost button)
must be selected to
draw shapes on a layer.
The other buttons are
Paths that’s outside the
scope of this book and
Fill pixels that creates
rasterized shapes filled
with the foreground
color.

Buttons on the Shape
tool’s options bar
include Pen tool,
Freeform pen tool,
shape tools (5), Custom
Shape Tool and
Geometry options.

The multiple shape
buttons on the options
bar determine how
multiple shapes interact.

DRAWING SHAPES
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■ Shape layers button lets you draw shapes on layers and the Fill pixels
button rasterizes a shape layer. The Path button is beyond the scope of this
book.

■ Tool buttons let you quickly switch among tools in the Shape tool set. (The
Pen and Free Transform Pen tools are outside the scope of this book.) The
Geometry Options drop-down arrow, to the right of the Custom Shape Tool
button, displays settings specific to the selected tool. Using these options you
can add arrowheads to lines, constrain ellipses to circles, define the sizes of
custom shapes, and make other advanced settings. If interested in knowing
more about these options look up the shape tool in help.

■ Variable section in the middle of the bar changes depending on what tool
you select. If has no setting for the Rectangle and Ellipse tools, but it lets you
select the Radius for the Rounded Rectangle tool, the number of Sides for the
Polygon tool, the Weight for the line tool, and a Shape for the Custom Shape
tool.

■ Multiple shape buttons lets you combine shapes. The Create new shape
layer, creates a new layer for each shape you draw. The other buttons let you
draw more than one shape on the same layer and determine how they
interact when they overlap. They work much like the same buttons do when
making selections (page 86).

■ Link button is outside of the scope of this book but it changes properties on
the target layer when on and on a new layer when off.

■ Style drop-down arrow displays a palette of preset styles from which you
can choose effects such as embossing or ridges. Click the triangle button on
the palette to display categories of styles from which to choose. You can also
apply styles such as drop shadows to the layer with the Layer>Layer Style
command or the Styles palette. Keep in mind that styles are applied to all
shapes on a layer.

■ Color swatch displays the current fill color—by default the foreground
color. Click the drop-down arrow to display the color picker if you want to
change it.

EDITING SHAPES
When you draw a shape you create a fill layer linked to a vector mask. You
can easily change the fill to a different color, a gradient, or a pattern by
editing the shape’s fill layer. You can also edit the shape’s vector mask to
modify the shape outline, and apply a style to the layer.

■ To change a shape’s color, double-click its layer thumbnail in the Layers
palette to display the color picker.

■ To fill a shape with a pattern or gradient, select its layer in the Layers
palette, and choose Layer>Change Layer Content to display a submenu and
then select Gradient or Pattern and select options.

■ To add layer styles such as a drop shadow to a shape, double-click the
shape layer’s vector mask thumbnail in the Layers palette or Paths palette to
display the Layer Styles dialog box. Select the styles you want to apply and
click OK.

RASTERIZING SHAPE LAYERS
Just as with type layers (page 120), you have to rasterize a shape layer so you
can paint on it or apply filters.

Shape tools available
from the toolbox.

Only one section of the
option bar changes as
you select Shape tools.
Here, from top to
bottom, are the settings
for the Rounded
Rectangle, Polygon,
Line, and Custom tools.

The Custom Shape tool
gives you access to
libraries of shapes.

A shape is a fill layer
linked to a vector mask.
In the Layers palette
the layer thumbnail is
on the left and the
vector mask thumbnail
is on the right.
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In previous chapters, you were introduced to making selections, using
layers, and painting and drawing. In this chapter we bring these elements
together to create masks. These powerful tools are used to confine

adjustments to selected area of an image or to make one are of an image
transparent so the layer below shows through. Unlike a selection, a mask is a
grayscale image just as your images are. This means you can edit one just like
you edit images; using brushes, erasers, fills, filters, and almost every other
tool and technique you have learned. Having all of these tools at your dis-
posal means you can create more complex selections than you can with the
selection tools you learned earlier.

Because masks make precise selections possible, they lie at the heart of
compositing—the creation of a new image by piecing together parts of other
images. You can either cut and paste selected areas or make some areas
transparent so layers below show through. Once you master a few basic tools,
the possibilities are endless.

Chapter 7
Creating and Using Masks

CONTENTS

■ Masks—An
Introduction ■ Editing
Masks ■ Using Quick
Masks ■ Using Layer
Masks ■ Using Alpha
Channel Masks ■ Using
the Extract Command ■
Replacing Color
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MASKS—AN INTRODUCTION

Masks are actually grayscale images that perform two different but related
tasks. First, you can use them to select areas of an image so adjustments
affect only the desired area. By making parts of the mask various shades of
gray, you can even apply various levels of adjustment. Second, you can use
masks to make parts of a layer fully or partially transparent so layers below
show through to some specified degree. This control of transparency is
especially useful because it lets you combine a number of images, each on its
own layer, and then use masks to create a composite image without actually
changing the images themselves.

Selections are indicated
by a selection border
that separates the
selected areas from the
unselected areas.

Masks can be displayed
as grayscale images
(top), transparent areas
(bottom) or as color
overlays (right).
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The Edit in Quick Mask
Mode button (right) in
the toolbox. The Edit in
Standard Mode button is
on the left.

SELECTIONS VS MASKS
Selections and masks are both similar and different in some respects:

■ They are similar in the following respects:

● Both let you select parts of an image.

● Both can be saved so you can reuse them with the same or even different
images. When a selection is saved, it is converted into a grayscale image
and becomes a mask.

● Both saved selections and masks are listed in the Channels palette.

● You can start with a selection and turn it into a mask for further editing,
or load a mask so it appears in the image as a selection border. In fact, the
Edit in Quick Mask Mode and Edit in Standard Mode buttons in the
toolbox let you switch back and forth between the two modes so you see a
selection both as a selection border and as a mask.

■ They are different in the following respects:

● Masks make obvious which areas are protected or revealed in a number
of ways, for example, by covering them with a color overlay. Selections
separate selected from unselected areas with a thin selection border and
you can’t see feathered edges or semitransparent areas at all.

● Only masks are grayscale images.

● Selections are made using a limited number of selection tools while
masks, being grayscale images, can be edited with any editing tools
including selection tools, paint brushes, erasers, fills, gradients, and even
filters. The ability to use all of these tools lets you create very complex
selections.

● Only masks (other than Alpha layer masks—page 153) have thumbnails
displayed in the Layers palette to the right of the layer’s thumbnail. These
mask thumbnails represent the grayscale channels.

● Only masks show feathering and other tonal transitions. Selections are
always displayed with a hard-edged selection border that only indicates
the line at which feathering or a gradient is 50% gray—halfway between
pure white and pure black.

● Masks can make parts of a layer transparent (hidden) without actually
deleting pixels from it.

CREATING MASKS
Photoshop lets you create masks in the following ways:

■ When you make a selection with any tool including Type Mask tools, you
can edit it in Quick Mask mode as if it were a mask and save it as an alpha
channel just like a mask.

■ Adding a layer mask to the selected layer or layer set lets you make some
areas of the layer transparent or select areas for adjustment.

■ When you add adjustment layers and fill layers they automatically have
layer masks.

■ Clipping masks (page 124) let you create a shape on one layer and use it to
mask the layer above.

■ Drawing shapes with any Shape tool automatically creates a vector mask.

A layer mask always
has a mask thumbnail
to the right of the layer
thumbnail that indicates
the layer’s function. The
mask thumbnail shows
unmasked pixels in
white and masked pixels
in black (partially
transparent or selected
pixels appear as gray).

MASKS—AN INTRODUCTION

HTTP://WWW.SHORTCOURSES.COM


148

CHAPTER 7. CREATING AND USING MASKS

FOR INFORMATION ON CLASSROOM USE, VISIT HTTP://WWW.PHOTOCOURSE.COM

EDITING MASKS

Although there are a number of ways to create or select a mask (as you’ll soon
see), once you have done so, you can edit it with the same tools and tech-
niques discussed in the chapters on selecting and painting. There are many
ways to edit masks but here we emphasize the most common way—using
brushes.

■ When creating a new mask, begin by selecting the part of the image you
want to affect. This step is optional and the selection only needs to be rough
because you can refine it when it’s displayed as a mask.

■ Select the tool you want to use to edit the mask and set its options. When
selecting a brush, choose one that’s feathered or sharp depending on your
goals.

■ Select a foreground color in the toolbox. When you create a new mask or
display an existing mask, the foreground and background color swatches in
the tool box become black and white so you can paint to create or fine-tune
the selection. To switch between black and white foreground colors, click the
Switch Colors icon to the right of the foreground color swatch. To select a
shade of gray using the color picker double-click the foreground color swatch.

■ To edit the mask, do one of the following:

● To mask areas so an adjustment doesn’t affect them, or to hide areas
using a layer mask, paint with the foreground color set to black or erase
with it set to white.

● To unmask areas so an adjustment does affect them, or to reveal areas
using a layer mask, paint with the foreground color set to white or erase
with it set to black.

● To partially mask areas, so the adjustment affects the image to some
degree, or so areas on a layer mask are partially transparent, use a soft
brush or airbrush, or paint with gray or adjust the opacity of black. Darker
grays protect or hide areas more than light grays do. You might explore
gradients because they give you a range of grays to work with.

■ To change the color and opacity of the mask’s color overlay, do one of
the following (by default, mask color overlays are red with opacity set to
50%):

● To change the color overlay for a quick mask, double-click the Edit in
Quick Mask Mode button in the toolbox to display the Quick Mask Op-
tions dialog box, change the color and opacity and click OK. (The Masked
Areas and Selected Areas option buttons are described on page 149.)

● To change the color overlay for a layer or alpha mask, double-click the
mask thumbnail in the Layers palette, or double-click the alpha mask’s
channel in the Channels palette to display the Layer Mask Display Options
or Channel Options dialog box, change the color and opacity and click OK.

These settings affect only the appearance of the mask and have no effect on
how underlying areas are protected. The only practical reason to change
them is to make the mask stand out better against the colors in the image.

To change the Quick
Mask’s Color and
Opacity settings,
double-click the Edit in
Quick Mask Mode button
to display the Quick
Mask Options dialog
box.

When painting a mask,
click the Default Colors
icon (lowerleft) to set
the foreground and
background colors to
black and white. Click
the Switch Colors icon
(upperright) to reverse
the colors.

Right-click a mask to
display the Brush pop-
up palette.

TIP

■ When editing a
mask:

● Black unselects
or hides.

● White selects or
reveals.

The Swatches pallet has
shades of gray.
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USING QUICK MASKS

The purpose of Quick Mask mode is to let you easily switch back and forth
between the two modes of making and viewing selections—selection borders
and masks. You can either start with a selection in Standard mode and then
switch to Quick Mask mode to refine it, or you can create the mask entirely
in Quick Mask mode. At any point you can switch back and forth between
the two modes just by clicking the buttons.

CREATING A QUICK MASK
To create a quick mask, just click the Edit in Quick Mask Mode button in the
toolbox to display the mask for editing using the tools and techniques
described on page 148. Here is what happens:

■ If you selected an area first, that area appears normal to indicate that it is
selected. The rest of the image is covered by a semitransparent red color
overlay to indicated that it is unselected and protected. If the selection was
feathered, the feathering is shown as variations in the overlay’s
transparency.

■ If you didn’t first select an area or you selected the entire image, the
entire image looks normal to indicate it is selected. You only see the red
mask when you paint it with black or a shade of gray to unselect and protect
areas.

■ The Channel palette lists a temporary Quick Mask channel, and its
thumbnail displays selected pixels in white and unselected pixels in black.

USING AND SAVING THE MASK
When finished creating or editing a mask, click the Edit in Standard Mode
button and make the desired changes to the image. They affect only the
selected area indicated by the selection border. (In Quick Mask mode, the
same commands affect the mask, not the image.)

■ The selection border in Standard mode indicates the line at which pixels in
feathered edges or semitransparent areas are 50% gray.

■ To deselect the selection (you may want to save it first), choose Select>
Deselect.

■ To save the quick mask for reuse, switch to Standard mode and choose
Select>Save Selection to display the Save Selection dialog box described on
page 99. The selection is saved as a grayscale image and is listed in the
Channels dialog box as an alpha channel (page 153).

■ To load a previously saved quick mask for reuse, choose Select>Load
Selection to display the Load Selection dialog box described on page 99.

■ To reverse what the color overlay indicates and which colors you use to
edit it, double-click the Edit in Quick Mask Mode button in the toolbox and
change the default Masked Areas to Selected Areas. You can also Alt+click
the Edit in Quick Mask Mode button to toggle between the two modes. This
has no affect on what is actually selected but when changed, the mask covers
unprotected (selected) areas and you extend it by painting with white and
reduce it by painting with black.

The Edit in Quick Mask
Mode button (right) in
the toolbox. The Edit in
Standard Mode button is
on the left.

In Quick Mask mode, a
quick mask channel is
displayed in the
Channels palette.

The Quick Mask Options
dialog box lets you
reverse what the color
overlay covers and the
colors used to edit it.

USING QUICK MASKS

TIP

■ When using a
brush you can
paint with grays by
changing the
opacity of black. To
do so, just press
any number key.
For example, type
0 for 100%, 1 for
10%, and other
numbers such as 2
then 3 for 23%.
When using the
airbrush hold down
Shift as you type
the numbers.
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USING LAYER MASKS

Layer masks are linked to a layer and come in three basic types that share
similarities and differences:

■ Regular layers (page 146) can have masks added to hide and reveal parts
of the image. These masks are widely used in making composite images
because painting areas of the mask with black makes them hidden/
transparent so layers below show through. Painting with white reveals areas
on the mask’s layer, obscuring the same area on the layers below. On the
mask thumbnail, black indicates hidden/transparent areas and white
indicates revealed areas.

■ Adjustment and fill layers have masks added automatically so you can
control which areas of the image are affected by the adjustment or fill and to
what degree. Painting the mask with black unselects and protects areas from
the adjustment or fill. Painting with white selects areas so they are affected.
On the mask thumbnail, black indicates selected areas and white indicates
unselected areas.

■ Shape layers have vector masks added automatically. You edit these
masks with pen and path tools that are outside the scope of this book.

A layer mask always
has a mask thumbnail
to the right of the layer
thumbnail that indicates
the layer’s function.

ADDING MASKS TO REGULAR LAYERS
Layer masks serve two basic functions. They are used to make areas of a
layer transparent and can also be loaded so they are displayed in the image
just like any other selection border. (You can’t add a layer mask to the
background layer without first converting it into a regular layer—page 107).

When you add a mask to a regular layer, you can have it initially reveal all or
hide all of the image or a previously made selection. Your choice determines
the starting point for editing and should be based on the size of the area to be
revealed or hidden. For example, when masking a small area, it’s more
efficient to choose Hide All, and paint to reveal rather than choosing Reveal
All, and painting to hide. To add a mask that shows or hides the entire layer
or the selected area, display the Layers palette, select the layer or layer set to
which you want to add a mask, and do one of the following:

A regular layer’s mask
thumbnail (bottom)
shows revealed pixels in
white and hidden pixels
in black (partially
transparent or selected
pixels appear as gray).
An adjustment layer’s
mask thumbnail (top)
shows the unprotected,
selected pixels in black
and the protected,
unselected pixels in
white.

Layer masks are
displayed in the
Channels palette but
only when the layer
they are attached to is
selected in the Layers
palette.
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■ To create a mask that reveals the entire layer or the area within a selec-
tion, click the palette’s Add layer mask button. (You can also choose
Layer>Add Layer Mask from the main menu to display a submenu and
choose Reveal All or Reveal Selection.)

■ To create a mask that hides the entire layer or the area within a selection,
Alt+click the palette’s Add layer mask button. (You can also choose
Layer>Add Layer Mask from the main menu to display a submenu and
choose Hide All or Hide Selection.)

After creating the mask, you can add to or subtract from the masked area.
Areas you paint in black will be made transparent, areas you paint in white
will be revealed, and areas you paint in shades of gray will have various
levels of transparency.

EDITING LAYER MASKS AND CONTENTS
When a layer has a mask, you switch between editing the layer’s content and
its mask by clicking thumbnails in the layers palette.

■ To edit the mask (page 148), click the mask thumbnail (the one on the
right). The foreground and background colors change to grayscale values, a
mask icon is displayed in the second column, and the thumbnail is sur-
rounded by a border to indicate you are editing the mask.

■ To edit the layer’s content, do one of the following in the Layers palette:

● To edit a regular layer’s contents, click the layer thumbnail (the one on
the left). The paintbrush icon is displayed in the second column and the
thumbnail is surrounded by a border to indicate that you are editing the
layer.

● To edit an adjustment or fill layer’s content, double-click the layer
thumbnail (the one on the left) to display the dialog box controlling the
adjustment or fill.

LOADING LAYER MASKS
Although a layer mask is a grayscale image you can load it to display it in an
image as a selection border. You can then edit and use this selection border
just like any other (page 85).

■ To load a mask so it appears in the image as a selection border, Ctrl+click
the mask thumbnail or right-click the mask thumbnail to display a pop-up
menu and choose Set Selection to Layer Mask.

■ To combine the layer mask with a selection in the image, right-click the
mask thumbnail and make a choice from the pop-up menu.

■ To select the entire layer, Ctrl+click the layer thumbnail.

MANAGING LAYER MASKS
When using or editing layer masks, you can click the layer and mask thumb-
nails to manage the mask:

■ To display and hide the grayscale mask, Alt+click the layer mask thumb-
nail. On a regular layer’s mask the black indicates transparent or hidden
areas. On an adjustment or fill layer mask it indicates unselected areas. The
eye icons are dimmed because all layers or layer sets are hidden.

■ To display and hide the color overlay, Alt+Shift+click the layer mask

In the Layers palette,
the layer thumbnail is
on the left and the mask
thumbnail on the right.
When the link is
displayed between
them, they move
together.

When editing a layer
mask, a mask icon is
displayed in the second
column of the Layers
palette. When editing
the layer’s contents, a
paintbrush icon is
displayed instead.

Right-click a layer mask
to display a pop-up
menu.

The palette’s Add Layer
Mask button is the
second from the left.

USING LAYER MASKS

TIP

■ When editing a
layer mask:

● Black hides.

● White reveals.
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A disabled mask has a
red X through it.

TIP

■ To use the same
mask with other
adjustments or fills,
duplicate the layer
(page 111) so you
have two copies of
the same adjust-
ment. Then select
the duplicate layer
and choose
Layer>Change
Layer Content to
display a submenu
of layer types to
choose from.

thumbnail. On a regular layer’s mask the overlay covers transparent or
hidden areas. On an adjustment or fill layer mask it covers unselected areas.

■ To disable or enable the mask, Shift+click the mask thumbnail. When
disabled, the thumbnail is displayed with a large red X through it and the
layer appears without masking effects. If you toggle back and forth you can
compare the before and after affects of masking. (You can also enable and
disable the mask by choosing Enable Layer Mask or Disable Layer Mask
from the main menu’s Layer menu or the pop-up menu displayed when you
right-click the mask thumbnail.)

■ To unlink a layer or layer set from its mask so they can be moved sepa-
rately, click the link icon between the thumbnails in the Layers palette. To
relink them, click the same place to display the link icon again.

■ To discard a layer mask and reduce the file’s size or simplify the Layers
palette, do one of the following, and make one of the following choices when
offered—Apply (to make the changes permanent), Cancel (to cancel the
command), and Discard (to discard the mask and its effects).

● Right-click a mask thumbnail and select Discard layer mask to delete
the mask and its effects without any choices being offered.

● Select a regular layer’s mask thumbnail and click the palette’s Trash
button or drag and drop the thumbnail on that button and then select
Discard, Cancel or Apply. You can also choose Layer>Remove Layer
Mask and then choose Discard or Apply.

● Select an adjustment or fill layer’s mask thumbnail and click the
palette’s Trash button or drag and drop the thumbnail on that button and
select Discard or Cancel. You can also choose Layer>Remove Layer Mask
and then choose Discard or Apply.

Here a gradient was
added to a layer mask
and it makes the image
fade in from left to
right.

TIP

■ To transform a
layer mask, unlink
the mask, and
select the mask
thumbnail in the
Layers palette
(page 150).
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USING ALPHA CHANNEL MASKS

As you‘ve seen, the Channels palette lists the individual red, green, and blue
grayscale channels and the combined full color composite image. Masks,
being grayscale images, are also listed in the same palette in what are called
alpha channels. You’ve met alpha channels before, although indirectly. For
example;

■ When you save and name a selection, it is saved as an alpha channel.

■ When you create a Quick Mask, it is temporarily stored in an alpha
channel. If you save the Quick Mask, it is saved there permanently.

■ When you create a layer mask, it is saved in an alpha channel.

All of these masks are created elsewhere and then saved as alpha channels.
However, you can also create a new alpha channel and then use painting
tools, editing tools, and filters to add a mask to it (page 148).

CREATING ALPHA CHANNEL MASKS
To create a new alpha channel with the default options click the Create New
Channel button at the bottom of the Channels palette. The new channel is
named according to the sequence in which it was created.

To create a new channel with options, Alt+click the Create new channel
button at the bottom of the palette or select New Channel from the
Channels palette menu to display the New Channel dialog box with the
following options.

■ Name text box is where you enter a descriptive name.

■ Masked Areas (the default) and Selected Areas option buttons specify if
the color overlay covers the unselected areas (the default) or the selected
areas. It also determines which colors add to or subtract from the mask (page
148).

■ Color swatch and Opacity text boxes specify the look of the color overlay.

■ OK creates the new channel and lists it at the bottom of the Channels
palette.

USING ALPHA CHANNEL MASKS
Alpha channel masks are edited just like other masks, but like saved selec-
tions, they have to be loaded before they can be used. When loaded, the mask
appears as a selection border in the image.

■ To display the mask in the image window for editing, select its channel in
the channel palette. Just the mask is displayed when no color channels are
displayed. Click the eye icons to turn them all off. If one or all of them is on,
the mask appears as a transparent red overlay over the image.

■ To load an alpha mask after editing or changing it so it appears in the
image as a selection border, select its channel in the Channels palette and
click the palette’s Load channel as selection button. Select the RGB
composite channel to see the selection border in the image.

■ To remove the selection border in the image, choose Select>Deselect.

TIPS

■ If you display an
alpha channel at
the same time as
one or more color
channels, the alpha
channel appears as
a transparent color
overlay that you
can paint with
black to enlarge or
white to reduce.

■ Alpha channels
are saved along
with the image but
are preserved only
if you save a file in
Adobe Photoshop,
PDF, PICT, Pixar,
TIFF, or Raw
formats. Saving in
other formats,
including JPEG,
may cause channel
information to be
discarded.

■ To see what
channels really
look like, select
Split Channels on
the Channels
palette’s menu.

The Channels palette
buttons include (from
left to right) Load
channel as selection,
Save selection as
channel, Create new
channel, and Delete
current channel.

The New Channel dialog
box.

USING ALPHA CHANNEL MASKS
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USING THE EXTRACT COMMAND

The selection of subjects with complex edges can be very time consuming if
you do it with brushes, or even the ever useful Background Eraser tool (page
134). Imagine painting around every hair in a windblown portrait, or every
leaf in a landscape! To make it faster and easier, you can use the Extract
command. Here is how it works:

1. Begin by selecting the layer with the object you want to extract and then
choosing Filter>Extract to display the Extract dialog box. Using the Edge
Highlighter tool you paint over edges of the subject where the details you
want to extract overlap the background you want to remove. If the object has
a center you want to preserve, the highlight must fully enclose the object or
run into the edges of the image so it fully “seals off” an area.

2. Use the Fill tool (the paint bucket) to fill with blue the sealed off area you
want to keep. You now have three areas in the image, the unhighlighted area
that will be removed, the blue filled area that will be retained, and the green
highlighted area that will be analyzed.

3. Click the Preview button to preview the extraction. the program retain all
areas covered in blue, delete all of those not covered with any color, and do
its best to separate foreground from background in areas highlighted in
green. Pixels on the edge of the object are striped of any color components
derived from the background so they will blend with a new background
without producing a color halo. The end result is a foreground object against
a transparent background.

4. Use the the Cleanup and Edge Touchup tools to erase background traces
and sharpen edges. If there is no clear edge, the Edge Tool adds opacity to the
object or subtracts opacity from the background. You can also clean up after
an extraction using the Background Eraser and History Brush tools in the
toolbox.

4. Click OK to complete the extraction. You can add back opacity to the
background and create other effects using the Edit>Fade command after the
extraction.

5. Refine the extraction, if necessary, by repeating the process after adjusting
the highlight and fill or after changing settings such as Smooth, Force
Foreground, or Color.

When using the extract dialog box, here are the tools and settings you have at
your disposal to fine-tune the process:

TOOLS
■ Edge Highlighter tool paints the area where the foreground subject
extends into and overlaps the background. Use a large brush to cover intri-
cate edges such as hair or trees.

● If the object you want to extract has a well-defined interior, make sure
that the highlight forms a complete enclosure or runs into one of the
image boundaries. If the object doesn’t have a definite interior that you
want to retain, highlight the entire object.

TIPS

■ To avoid losing
the original image
information,
extract on a
duplicate layer or
make a snapshot of
the original image
state.

■ If you extract on
a background layer,
it becomes a
normal layer after
the extraction.

■ If the layer
contains a selec-
tion, the extraction
process applies
only in the selected
area.

Here is the original
image (top), after edge
highlighting and fill
(center), and after
extraction (bottom).
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● To erase parts of the highlight, select the Eraser tool in the dialog box,
and drag over the highlight. To erase the entire highlight, press
Alt+Backspace.

■ Fill tool fills the area surrounded by the Edge Highlighter with blue to
indicate an area that will be fully retained. (Clicking a filled area with the tool
removes the fill.)

■ Eyedropper tool, used when you’ve selected Force Foreground, samples
the foreground color inside the object, or you can click the color swatch to
select the foreground color in the color picker. This technique works best
with objects that contain tones of a single color.

■ Cleanup tool erases background traces in the extracted area by subtracting
opacity and has a cumulative effect. Alt+drag to add back opacity. You can
also use the tool to fill gaps in the extracted object.

■ Edge Touchup tool sharpens edges by adding opacity to the object or
subtracting it from the background.

■ Zoom tool magnifies an area. Alt+click with the tool to zoom out.

■ Hand tool drags the image preview when it’s zoomed larger than the
window.

BUTTONS
■ OK applies the final extraction.

■■■■■ Cancel button cancels the procedure and closes the dialog box. Reset,
displayed when you hold down Alt, restores default settings so you can try
again.

■ Preview button displays a preview of the extraction so you can examine the
results and, if necessary, make changes to refine the extraction.

The tools include, from
top to bottom, the
Edge Highlighter, Fill,
Eyedropper, Cleanup,
Edge Touchup, Zoom,
and Hand.

The Extract dialog box’s
controls and settings.

USING THE EXTRACT COMMAND
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TOOL OPTIONS
■ Brush Size slider sets the width of the edge highlighter, eraser, cleanup,
and edge touchup tools.

■ Highlight drop-down arrow selects a color that appears around objects you
paint with the Highlighter tool.

■ Fill drop-down arrow selects a color for the area covered by the Fill tool.

■ Smart Highlighting check box, when on, is useful when highlighting a
well-defined edge because it helps you accurately trace the edge using a
highlight that is just wide enough to cover it, regardless of the brush size.
There are places where it can get confused. For example, if an edge you are
tracing is near another edge and the highlight is attracted to the wrong edge,
decrease the brush size. If the edge has a uniform color on one side and high-
contrast edges on the other side, keep the object edge within the brush area
but center the brush on the uniform color.

EXTRACTION OPTIONS
■ Texture Image check box is used if the foreground or background of your
image contains a lot of texture.

■ Smooth slider increases or decreases the smoothness of the outline.
Normally set to zero, you only increase this if you get unwanted blurring of
details or sharp artifacts in the extraction.

■ Channel drop-down arrow lets you choose an alpha channel if you have
saved a selection or mask in the image that identifies the edge boundary.
When you select the alpha channel, it’s like loading a selection and the area
outside of the selection is highlighted in the preview window.

■ Force Foreground check box, when on, extracts areas within the high-
lighted area that match the color shown in the Force Foreground color
swatch. This is useful if the object is intricate or lacks a clear interior. When
selected, the eyedropper tool becomes available so you can click in the image
to select a color.

PREVIEW OPTIONS
■ Show drop-down arrow lets you switch between previews of the original
and extracted images.

■ Display drop-down arrow lets you preview the extracted object against a
colored matte background or as a grayscale mask. To display a transparent
background, choose None (the default).

■ Show Highlight check box, toggles the highlight color on and off in the
image.

■ Show Fill check box, toggles the fill color on and off in the image.

TIPS

■ You can’t
highlight the entire
object if you’ve
selected Texture
Image or Force
Foreground.

■ If you select an
area of the image
before using the
Extract command,
the unselected area
is covered by a red
mask.
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REPLACING COLOR

There are times when you want to adjust the hue, saturation, or lightness in
one area of an image while leaving other areas unchanged. Although you can
do this with selection tools and masks, you can also use the Replace Color
command that creates a temporary mask around the specific colors you want
to adjust. To begin, select Image>Adjustments>Replace Color to display the
Replace Color dialog box. Click the eye dropper tools in the preview or actual
image to select the areas that are masked, or protected from changes. When
the mask is finished, you then use the sliders to change the hue, saturation
and lightness of the unmasked (white) areas .

■■■■■ Selection section adjusts the mask. Masked areas protected from adjust-
ments are black, and unmasked areas affected by adjustments are white.
Partially masked areas that will be partially affected by adjustments are
covered by varying shades of gray depending on their opacity.

● Eyedropper tools select colors areas exposed by the mask, add colors to
the masked areas (+), or subtract from them (-) by clicking in the preview
or the actual image which can be zoomed.

● Fuzziness slider expands or contracts the range of related colors in-
cluded in the selection.

● Selection option button displays the mask in the preview window.

● Image option button displays the image in the preview window.

■■■■■ Replacement section sliders adjust the Hue, Saturation, and Lightness of
white areas not protected by the mask. The Sample color swatch shows the
color being used in unmasked areas. If you want, you can click it to choose a
color from the color picker isntead of using the sliders.

■■■■■ OK button completes the procedure.

■■■■■ Cancel button cancels the procedure and closes the dialog box. Reset,
displayed when you hold down Alt, restores default settings so you can try
again.

■■■■■ Load/Save buttons let you save a mask for reuse.

TIPS

■■■■■ Click in the
image or in the
preview box to
select the areas
exposed by the
mask.

■■■■■ Shift+click or
use the eyedropper
+ button to add
areas.

■■■■■ Alt+click, or use
the eyedropper -
button to remove
areas.

■■■■■ There is also a
Color Replacement
tool (page 137).

All colors in the image,
except red, were clicked
to add them to the
mask. Now the colors of
everything can be
changed while the lips
remain red.

REPLACING COLOR
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In some ways, we’ve reserved the best for last because it’s now time to
discuss some of the many things you can do with your digital photo
graphs. Digital photography opens up a vast new range of exciting ways

to display and share the best of the images you capture. Projects are limited
only by your imagination, and Photoshop has brought automation to the
process to make things easier and faster. In this chapter you’ll see how to
print contact sheets and picture packages like those made by professional
studios. You’ll learn how to create a Web gallery to showcase or share your
images, stitch together images into panoramas and create PDF’s that can be
displayed as slide shows on the computer or TV. All of these possibilities and
many others are fun to explore and easy to accomplish.

You can use commands on the File Browser’s Automate menu to perform
these automatic processes. You can also run these commands by selecting
File>Automate from the main menu, but running them from the File
Browser saves you a lot of time, because you don’t have to open each indi-
vidual file.

Chapter 8
Automating Tasks

CONTENTS

■ Printing Contact
Sheets ■ Printing
Picture Packages ■
Creating a Web Photo
Gallery ■ Merging
Images into a Panorama
■ Creating a PDF
Presentation ■ Batch
Renaming Files ■
Creating and Using
Actions ■ Using the
Batch Command ■
Batch Processing
Camera RAW Image
Files—A Tutorial

AA30470C
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With the dialog box displayed, you can set the following options and click
OK to generate the contact sheet:

■■■■■ Source Images section’s Use drop-down arrow lets you specify which
images to include:

● Current Open Documents includes images that are currently open in
Photoshop.

● Folder activates the Browse button so you can select the folder of
images you want to include. The Include All Subfolders check box, when
on, includes images in any subfolders.

● Selected Images from File Browser includes all images in the selected
folder unless you select specific images before choosing the Contact Sheet

PRINTING CONTACT SHEETS

Contact sheets present small thumbnails of selected images. You can use
these indexes to manage your images or include them along with CD/DVDs
you send out so people can see what’s on the disc without opening the files.
As you begin, keep in mind that contact sheets include every image in a
folder unless you use the File Browser to first select specific images. To create
a contact sheet do one of the following to display the Contact Sheet II dialog
box:

■■■■■ From the main menu, select File>Automate>Contact Sheet II.

■■■■■ From the File Browser, select a folder of images or select specific image
files, and then, from the File Browser menu, select Automate>Contact Sheet
II.

TIP

■ Photoshop takes
a long time to
create contact
sheets because it
has to extract
thumbnails from
the images. Image
management
programs generate
these pages of
thumbnails much
more quickly
because they store
previously ex-
tracted thumbnails
in a database.

File Browser’s Automate
menu.

PRINTING CONTACT SHEETS
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II command. To select images in the File Browser Shift+click to select a
series of images or Ctrl+click to select noncontiguous images.

■ Document section specifies the size of the area in which the thumbnails
will print—not the size of the paper you print them on. The Mode drop-down
arrow lets you print the contact sheet in Grayscale, RGB color (the default),
CMYK or Lab Color. The Flatten All Layers check box, when on, flattens all
layers (page 115). When off, each image is on a separate layer and each
caption is on a separate text layer.

■■■■■ Thumbnails section sets layout options for the thumbnail previews.

●●●●● Place drop-down arrow lets you specify if thumbnails are placed left to
right, then top to bottom or from top to bottom, then left to right.

●●●●● Columns and Rows text boxes specify the layout of images on the page.
As you change these settings, the maximum dimensions for each thumb-
nail are displayed to the right, along with a visual preview of the specified
layout.

●●●●● Use Auto-Spacing check box, when on, places thumbnails automati-
cally on the contact sheet. When off, you specify the vertical and horizontal
space around the thumbnails. The contact sheet preview reflects changes
in spacing.

●●●●● Rotate For Best Fit check box, when on, rotates images so they fit most
efficiently.

■ Use Filename as Caption section specifies if the filename is printed below
each thumbnail and if so, in what typeface.

A contact sheet.

Placement can be across
first (top) or down first
(bottom).
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With the dialog box displayed you can set the following options and then
click OK to generate the picture package which you then print:

■■■■■ Layout section displays the picture package as it will print. To add or
change pictures, do one of the following:

●●●●● Source Images section’s Use drop-down arrow lets you select File or
Folder and then click Browse to select a picture. If you select Folder, you
can turn on the Include All Subfolders check box to include images inside
any subfolders. ALL images in the folder and subfolders will be printed.

●●●●● Click an image in the Layout section to display the Select an Image
dialog box and browse to select an image.

●●●●● Drag an image from the desktop or a folder onto one of the existing
photos.

■■■■■ Document section lets you specify the page size, layout, resolution, and
color mode. The Layout preview section shows the effects of your changes.
Flatten All Layers check box, when on, prints all images and label text on a
single layer. When off, each image is on a separate layer and each label is on
a separate text layer. Placing each image and label on a separate layer lets
you update your picture package after it’s been saved. Keep in mind that not
flattening layers increases the file size of your picture package.

■■■■■ Label section is where you use the Content menu drop-down arrow to
specify the source for label text. If you choose Custom Text, enter the text for
the label in the Custom Text field. Other settings let you select a font, font
size, color, opacity, position, and rotation for the labels.

PRINTING PICTURE PACKAGES

The Picture Package command prints multiple copies of the same, or differ-
ent, images on a single page, much like photos sold by portrait studios. To
begin do one of the following to display the Picture Package dialog box:

■■■■■ From the main menu, select File>Automate>Picture Package. If an image
is open, it’s displayed in the dialog box. If more than one image is open, the
frontmost one is displayed.

■■■■■ From the File Browser menu, select Automate>Picture Package. Unless
you first selected a specific image, the first image listed in the File Browser,
or the first in a group of selected images is used.

Clicking the Content
drop-down arrow lets
you select a source for
labels.

Clicking the Layout
drop-down arrow lets
you select from a
number of layouts.

To change any image in
the layout, click it in the
preview and select a
new image.

TIP

■ You can create
your own layouts. If
interested, search
help or the user
guide for “custom-
izing picture
package layouts.”

PRINTING PICTURE PACKAGES
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CREATING A WEB PHOTO GALLERY

If you have access to a Web site, possibly through the company that provides
you with Internet access, you can quickly generate Web pages that display
thumbnails of your images. When you upload the gallery files to your Web
site (or even burn them to a CD), visitors can view these pages with a Web
browser and click any thumbnail to display a page with a larger version of the
image. The pages also contain links visitors use to navigate the pages.

To create a Web gallery, begin by choosing the Web Photo Gallery command
listed on the main File>Automate menu or on the File Browser’s Automate
menu to display the Web Photo Gallery dialog box with the following set-
tings:

TIPS

■ After creating a
photo gallery, you
can modify or fine-
tune the pages with
any Web page
authoring program.

■ When creating a
gallery from
images in the File
Browser, images
are presented in
the order in which
they’re displayed in
the file browser.
You may want to
change the order
before selecting the
Web Photo Gallery
command.

■ Styles drop-down arrow displays a list of gallery styles. When you select a
style, a thumbnail preview of its home page is displayed to the right.

■ E-mail text box is where you enter your e-mail address if you want a link to
it on gallery pages. (Not all gallery styles display e-mail addresses.)

■ Source Images section:

● Use drop-down arrow lets you select Folder or Selected Images From
File Browser to include all images in the selected folder or just individu-
ally selected images. If you select Folder the Browse button lets you select
the folder containing the images you want in the gallery. Turn on the
Include All Subfolders check box to include images in any subfolders.

● Destination drop-down arrow lets you specify the folder where you want
the finished gallery files placed. Click the Make New Folder button to
make a new one.

■ Options drop-down arrow lets you format the elements of your site as
described in section “Designing Your Gallery” on the next page.

■ Extension drop-down arrow lets you specify .HTM (the default) or .HTML

Some of the styles
available from the
Styles drop-down menu
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as the extension used for gallery pages. In most cases the choice doesn’t
matter but some Web hosts may prefer one over the other. There are also
other check boxes in this section that you can turn on or off.

■ OK creates the gallery and displays the home page in your browser so you
can try out your site locally before uploading it to a server. The following files
are stored in your destination folder:

● A home page for your gallery named index.htm or index.html. Open this
file in any Web browser to preview your gallery.

● JPEG images inside an images folder.

● HTML pages inside a pages folder.

● JPEG thumbnail images inside a thumbnails folder.

● Additional files for some gallery styles.

DESIGNING YOUR GALLERY
The Options section of the Web Photo Gallery dialog box has a drop-down
arrow you click to select elements of the site that you want to design. (For
some styles, some options may be dimmed, or unavailable.) As you select
elements, the dialog box changes to display the settings that apply specifi-
cally to that element. Here are details about each choice:

■ Banner options format the banner displayed at the top of every gallery
page.

● Site Name is the title of the gallery that appears at the top of every page
and in the browser’s title bar.

● Photographer is the name of the photographer.

● Contact Info provides a way for a viewer to contact the photographer—
perhaps an address, phone number, or e-mail address.

● Date specifies a date that appears on every gallery page. The default
setting is the current date.

● Font and Font Size drop-down arrows format the banner text.

TIP

■ Once your
gallery is finished,
you upload all of
the files to your
Web site. To do
this, you use an ftp
program such as
CuteFtp.

The Options drop-down
arrow displays a list of
the elements you can
design.

CREATING A WEB PHOTO GALLERY
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■ Large Images designs the gallery pages that appear when a visitor clicks a
thumbnail.

● Size drop-down arrow or text box specifies the size of thumbnails.

● Columns/Rows lays out the thumbnails in the specified grid. This
option doesn’t apply to galleries using the Horizontal Frame Style or
Vertical Frame Style.

● Border Size specifies the width, in pixels, of the border around each
image.

● Titles Use (see same section under Large Images above).

● Font and Font Size drop-down arrows format the titles.

● Resize Images drop-down arrow or text box specifies the size of large
images. To keep the width and height proportional, choose Both from the
Constrain menu; to resize only one dimension choose Width or Height.
To set JPEG Quality, choose an option from the menu, enter a value
between 0 and 12, or drag the File Size slider (higher values produce
better image quality but increase file sizes).

● Border Size specifies the width, in pixels, of the border around each
image.

● Titles Use check boxes specify what labels are displayed for each
image. Choose from Filename, Title, Description, Copyright and Credits.
(The information is taken from the image’s metadata—page 31.)

● Font and Font Size drop-down arrows format the label text.

■ Thumbnails designs the home page displaying thumbnails.

HTTP://WWW.PHOTOCOURSE.COM
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■ Custom Colors displays color swatches for various gallery elements. To
change a color of a particular element, click its color swatch to display the
color picker and select a new color. The Background option lets you change
the background color of each page. The Banner option lets you change the
background color of the banner.

■ Security superimposes copyright information over the full-sized images,
much like a watermark. The Content drop-down arrow displays choices. To
add your own text, select Custom Text. To format the security text use the
Font, Font Size, Color, Opacity, Position, and Rotate drop-down arrows. You
might find you need a very large type, rotated slightly and with a low opacity
or contrasting color. To choose a custom color, click the Color swatch or
drop-down arrow.

A finished Web Gallery
home page with
thumbnails on the left
and the large image for
the selected thumbnail
on the right.

CREATING A WEB PHOTO GALLERY

The Security options
Content choices.
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MERGING IMAGES INTO A PANORAMA

Although panoramic photographs have been taken in sections and pasted
together for years, it was the development of computer software that made
seamless panoramas possible with a digital camera. To create a seamless
panorama, you begin by capturing a series of overlapping images. You then
stitch these images together with the Create Photomerge command.

CREATING A PHOTOMERGE COMPOSITION
Although you can merge images in a variety of way, we recommend the
following approach to make things as predictable and easy as possible.

To begin, open the File Browser and select the folder that contains the
images you want to use. If there are also other images in the folder, individu-
ally select the ones you want to use. When ready, choose Automate>
Photomerge from the File Browser’s menu and the images in the folder or the
selected images are automatically merged and displayed in the Photomerge
dialog box. (If you select unmergable images, or a folder containing no
mergable images, the Photomerge command is dimmed and unavailable.) If
any image can’t be merged it is displayed on the lightbox at the top of the
dialog box.

With the panorama displayed in the Photomerge dialog box, you can adjust
individual pictures using tools for manipulating the composition, a lightbox
for storing images that are not currently included in the panorama, a work
area for assembling the panorama, and options for viewing and editing the
panorama.

■ The lightbox is the narrow strip at the top of the dialog box where you drag
images you are not using at the moment. You can drag images between the
lightbox and work area, or double-click an image in the lightbox to add it to
the panorama.

■ Tools in the upperleft corner of the dialog box include the following:

● Select Image tool selects images in the panorama so you can drag them.

● Rotate Image tool rotates the selected image. To do so, point outside of
the bounding box so the pointer turns into a curved arrow, and drag.

● Set Vanishing Point tool, only active when the Perspective option

Here the images have
been merged but you
can see serious banding
where the images were
joined.

The tools include (from
the top down), Select
Image, Rotate Image,
Set Vanishing Point,
Zoom, and Move View
tool.

TIP

■ Capturing
panoramic images
is discussed in
detail in The
Textbook of Digital
Photography and
that lengthy
discussion is not
repeated here.
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button is on, makes the image you click the vanishing point in the pan-
orama. The vanishing point image, originally the middle image, has a blue
border around it when selected.

● Zoom tool zooms the image when you click it or unzooms it when you
Alt+click.

● Hand tool drags in the work area to move the panorama. (You can also
use the scroll bars or navigator.)

■ OK creates the final merge using the settings you have made and displays
the panorama in a new window so you can save it.

■ Cancel closes the dialog box. When you hold down Alt the button changes
to Reset so you can return all settings to their defaults. All of the images
automatically move to the lightbox.

■ Save Composition As button saves the panorama in its current state so you
can continue editing it later. It doesn’t complete the merge process as does
clicking the OK button.

■ Navigator scrolls and zooms the panorama. The red view box represents
the boundaries of the work area.

● To scroll the panorama, drag the view box or the scroll bars.

● To zoom the panorama drag the slider, or click the zoom in or zoom out
buttons below the Navigator (or use the zoom tool).

■ Settings option buttons let you change the image’s vanishing point:

● Normal (the default) sets the vanishing point to the middle image in the
panorama. When selected, the image is surrounded by a blue border.

● Perspective activates the Set vanishing point tool so you can click any
image to make it the vanishing point. When on, perspective correction
works up to an approximately 120° angle of view. If you captured a wider
angle of view, click the Normal option button to turn off Perspective.

■ Composition Settings section controls distortion and blending:

● Cylindrical Mapping check box, when on, reduces the “bow tie” distor-
tion that occurs when you apply perspective correction. To use this option,
the Perspective option button must be on.

● Advanced Blending check box, when on, reduces banding caused by
merging images that were exposed differently. It does so by blending
colors that appear in broad areas, such as the sky, over a large area, while
blending smaller details over a smaller area.

● Preview button applies the settings to the image so you can check their
effects. To return to edit mode, click Exit Preview.

■ Snap to Image, check box, when on, ensures overlapping images snap into
position when the program recognizes common elements.

■ Keep as Layers check box, when on, preserves layers in the merged
panorama.

MERGING IMAGES INTO A PANORAMA

The Navigator and
Settings sections in the
Photomerge dialog box.
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CREATING A PDF PRESENTATION

Newer versions of Adobe’s Acrobat Reader can play high-quality slide shows
that you create with Photoshop. Since this reader is free and already installed
on so many computers, it offers a great way to distribute slide shows to
friends, family, and others. If they don’t have already have it on their system,
or they have an older version, they can download the latest version for free
from www.adobe.com.

Although you create a PDF presentation in a variety of way, we recommend
the following approach to make things as predictable and easy as possible. To
begin, open the File Browser and select the folder that contains the images
you want to include. If there are also other images in the folder, individually
select the ones you want to include. When ready, choose Automate>PDF
Presentation from the File Browser menu to display the PDF Presentation
dialog box with the following choices:

■ Source Files section selects the images to be in the slide show. The images
appear in the show in the same order in which they appear on this list.

● Add Open Files check box, when on, adds open images to the list of
source files.

● Browse button displays the Open dialog so you can select the files to be
included in the show. Remember you can click the View Menu drop-down
arrow and click Thumbnails to visually select images. To select multiple
files see page 24. The names of the selected files are displayed on the
Source File list.

● Remove button removes a selected file from the list.

TIPS

■ On most systems
you can open a
PDF slide show just
by double-clicking
its filename.

■ You may want to
create a title slide,
and make it the
first image on the
list.

■ If the order of
the images is
important, drag
them into a new
position on the
Source Files list

■ To make the
selection of photos
easy, copy them all
into a folder of
their own so you
can just select the
folder instead of
individual images.
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■■■■■ Output Options section:

●●●●● Multi-Page Document creates a PDF document with the images on
separate pages.

●●●●● Presentation creates a PDF slide show presentation.

●●●●● View PDF After Saving check box, when on, opens the created presen-
tation in Adobe Acrobat or the Adobe Reader.

■ Presentation Options, available only if you select Presentation as the
output, specifies the basic characteristics of the slide show.

● Advance Every check box, when on, specifies that the show advances
automatically when played back. When off, you advance the show during
playback by pressing the spacebar or clicking the image. Press Esc to end
the show. Seconds text box sets the time each slide is on the screen during
automatic playback.

● Loop after last page, check box, when on specifies that the show plays
over and over again. When off, the show stops when finished.

● Transition drop-down arrow lets you select the transition that blends
one image into the next.

■ Save button displays the save dialog box so you can enter a name and click
Save to display the PDF Options dialog box with the following settings:

Be aware that people
who access your show
can extract, save, and
print the images.

● ZIP and JPEG option buttons select the format in which the show is
saved. ZIP files use lossless compression so files may be significantly larger
than when saved in JPEG format. JPEG, when on, lets you type in a
Quality setting (1–12), select if from a drop-down arrow, or set it with the
slider bar.

● Save Transparency check box, when on, preserves transparency in the
images.

● Image Interpolation check box, when on, will anti-alias the printed
appearance of a low resolution image.

CREATING A PDF PRESENTATION

HTTP://WWW.SHORTCOURSES.COM


170

CHAPTER 8. AUTOMATING TASKS

FOR INFORMATION ON CLASSROOM USE, VISIT HTTP://WWW.PHOTOCOURSE.COM

When the presentation
opens in Acrobat, there
are many options
available.

● Downgrade Color Profile check box, when on, downgrades a version 4
ICC Profile (selected in the Save dialog box) to version 2 so you can open
the file in an application that does not support version 4 profiles.

● PDF Security specifies security options such as password protection
and restricted access to a file’s content. Choose 40-bit or 128-bit RC4
encryption for a lower or higher level of security.

● Include Vector Data preserves any vector graphics (such as shapes and
type) as resolution-independent objects, ensuring smoother output.

● OK closes the PDF options dialog box and generates the slide show
using the files and settings you have selected. If you turned on the View
PDF after Saving check box (page 169) the PDF is displayed. The file has
the name and location you specified in the Output File section.

● Cancel cancels the procedure and returns you to the PDF Slideshow
dialog box.
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BATCH RENAMING FILES

Batch Rename lets you quickly rename a group, or batch of files and even
choose the same settings for all the selected files. To begin, select the files you
want to rename, or select a folder in the Folders palette. Then, choose
Automate> Batch Rename to display the Batch Rename dialog box and set
the following options, then click OK.

The Batch Rename file
naming choices.

■■■■■ Destination Folder specifies whether the renamed files are placed in the
same folder or in a different folder. If you select Move to New Folder, click
Browse to select a different folder.

■■■■■ File Naming section has drop-down arrows used to select the elements you
want to combine to create your new filenames. You must include one of the
document name, serial number, or serial letter choices so each file has a
unique name.

■■■■■ Starting serial # is the number you want sequential numbers to start from.

■■■■■ Compatibility check boxes, select the operating systems with which you
want renamed files to be compatible. The current operating system is se-
lected by default, and you cannot deselect it.

BATCH RENAMING FILES
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CREATING AND USING ACTIONS

If you have a Web blog or Web site, create slide shows, convert RAW files, or
perform many other tasks with your photos, you find yourself performing the
same routine procedures over and over again. When this happens, it’s time to
automate the process using an action—a recorded sequence of commands
that you play back to adjust a single file or a batch of files. Although
Photoshop includes some actions that you can use as is, or customize to
better meet your needs, you’ll probably want to create your own. To do so you
turn on record mode, adjust one image the way you want it—perhaps change
its pixel dimensions or file format, then turn off record mode. The proce-
dures you recorded can now be played back on other images with the click of
a button.

USING THE ACTIONS PALETTE
When creating and using actions, the Actions palette is your control center.
To display the palette choose Window>Actions. The palette is initially in its
default list mode so you can click triangle icons to expand and collapse
folder-like sets used to organize and store actions, actions, and even the
individual commands that make up actions.

■■■■■ To expand or collapse a set, action, or command, click the triangle icon to
its left. Alt+click the triangle to expand or collapse all actions in a set or all
commands in an action.

■■■■■ To select an action, click its name. You can also Shift+click to select
multiple, contiguous actions that run one after another, and Ctrl+click to
select multiple, discontiguous actions.

■■■■■ To toggle between list and button mode, choose Button Mode from the
Actions palette menu. In button mode clicking an action plays it straight
through, but you cannot view sets or the individual commands that make up
actions.

■■■■■ To create a new set in which to store your own actions, click the Create
new set button or select New Set from the palette’s menu to display the New
Set dialog box. Enter the name of the new set and click OK. (When creating
the first action for a new set, if you create and name the set first it will be
displayed in the New Set dialog box so you can add the new action to it. You
can also drag it into the set later on the Actions palette.)

■■■■■ To toggle a command on or off, click the check mark icon in the first
column of the palette. When the command has a check mark it runs when
you run the action.

■■■■■ To toggle dialog boxes on or off during playback, click the icon in the
second column of the palette. When you expand an action to see it’s com-
mands, some may have blue dialog box icons that indicate a dialog box will
be displayed at that point in the action and require you to take an action.

● Red icons indicate that dialog boxes associated with commands hidden
so they are not displayed when you run the action. Click a red icon to
display the hidden icons for those commands. When all are displayed, the
icon for the title is blue. If you click this blue icon, you hide all of the
dialog icons in the action or command and it changes to red.

● To prevent a dialog box from being displayed when you run the action,
click it’s icon so it is hidden. Normally you don’t want dialog boxes dis-

Buttons on the Actions
palette include (left to
right), Stop playing/
recording, Begin
recording, Play
selection, New set,
Create new action, and
Delete.

Arrowheads in the
Actions palette indicate
whether sets, actions,
or commands are
collapsed (left) or
expanded (right).

The Actions palette and
palette menu.

The Toggle item on/off
(left) and Toggle dialog
on/off (right) buttons.

The New Set dialog box.
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played because they stop the action at that point until you do something. If
you are processing a large number of files with the action in a batch
command (page 176) you are forced to sit there so you can respond to each
dialog box that appears.

■■■■■ To move sets or actions in list mode, drag them so a horizontal line indi-
cates where you want to move them and drop them.

■■■■■ To rename a selected set of actions, choose Set Options from the palette’s
menu to display the Set Options dialog box, enter the name of the set, and
click OK.

RECORDING ACTIONS
Recording actions is no more complicated that turning on record mode,
doing what you normally do to edit an image, then turning off record mode.
Along the way you give the action a name so you can play it back later.

You’ll find that you can record most commands and tool operations. When
you encounter places where you can’t do so, you can insert a stop that pauses
the action so you can perform a task that can’t be recorded, such as using a
painting tool, then click Play to resume.

In this introduction, we can’t get into all of the complexities of actions. At
their most advanced level, they become a form of programming. To start, we
recommend the following:

■■■■■ Use actions that work on the entire image, perhaps changing an image’s
size, sharpening it, or converting it into another format. It’s also easy to
record adjustments such as white balance correction or exposure adjust-
ments when you want to process a group of photos taken under the same
lighting conditions.

■■■■■ Record the complete cycle from opening the image file, editing it, saving it
and then closing it. This ensures that you can later batch process a group of
files unattended. Ideally, change the image’s format to PSD so the processed
copy has the same name as the original, and is easy to track, but has a
different extension so it can be moved into the same folder as the original.

■■■■■ Always have the action save the processed image in a new folder so you
don’t risk overwriting your working copies.

To create a new action just follow these steps:

1. Create a new folder in which the processed files will be stored. Don’t make
it a subfolder of the folder the source files are in.

2. Create a new set in which to store your actions by clicking the Create new
set button on the Actions palette to display the New Set dialog box. Type a
descriptive name for the set and click OK.

3. Open one of the image files you want to adjust and click the Create new
action button in the Actions palette or choose New Action from the palette’s
menu to display the New Action dialog box (page 174). (You can also access
this dialog box later by selecting the action and then choosing Action Options
from the Actions palette menu.)

4. Name the action, specify the set it’s to be saved in, and attach it to short-
cut keys if you want.

5. Begin recording by clicking the Record button and adjust the image the
same way you want to adjust the others.

The Actions palette
displayed in list (top)
and button (bottom)
modes.

CREATING AND USING ACTIONS

TIP

■■■■■ You can record
operations that you
perform with the
Marquee, Move,
Polygon, Lasso,
Magic Wand, Crop,
Slice, Magic Eraser,
Gradient, Paint
Bucket, Type,
Shape, Notes,
Eyedropper, and
Color Sampler
tools—as well as
those that you
perform in the
History, Swatches,
Color, Paths,
Channels, Layers,
Styles, and Actions
palettes.
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6. Save the adjusted image using the File>Save As command, but don’t
change the file’s name. If you do so, Photoshop records the new filename and
uses it each time you run the action, renaming each file you use it on. If you
follow our advice and save processed images in a separate folder, or if the
action changes the file’s format, you have no need to specify a new filename.

7. Stop recording by clicking the Stop button, choosing Stop Recording from
the Actions palette menu, or pressing the Escape key. To resume recording in
the same action, choose Start Recording from the Actions palette menu.

The New Action dialog box offers you the following settings:

■■■■■ Name text box is where you enter a descriptive name for the action.

■■■■■ Set lists the current set but you can click the drop-down arrows to select
another set in which you want the action stored.

■■■■■ Function Key drop-down arrow lets you assign a keyboard shortcut to the
action. You first choose a function key F2–F12 and then specify if you hold
down Shift, Ctrl, or both to execute the command—for example,
Ctrl+Shift+F3. Some keys may be dimmed because not all combinations are
available.

■■■■■ Color assigns a color for the button in button mode.

■■■■■ Record button starts recording the action and as long as you are recording,
the palette’s Begin recording button is displayed in red.

INSERTING STOPS
You can include stops in your action that let you perform a task that cannot
be recorded or when you want to make custom changes to each image as it’s
processed. For example, you can stop the action at the point where you want
to use a painting tool or change the foreground color. Once you’ve completed
the task, click the Play selection button on the Actions palette to complete
the task. You can insert a stop when recording an action or after it has been
recorded.

To insert a stop in a previously recorded action, select the action’s name to
insert the stop at the end of the action, or select a command to insert it after
the command. When ready, choose Insert Stop from the Actions palette
menu to display the Record Stop Dialog box with the following settings:

TIPS

■■■■■ To be sure you
can undo an entire
action, take a
snapshot in the
History palette
before you play it,
and then select the
snapshot to undo
the action.

■■■■■ Since dialog
boxes often retain
their settings check
to be sure they are
what you want to
record.
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■■■■■ Message text box is where you enter a message that you want displayed
when the action reaches the stop. It should be a reminder of what you’re to
do at that point.

■■■■■ Allow Continue check box, when on, includes a Continue button in the
message box so you can click it to resume if nothing needs to be done.

■■■■■ OK enters the stop.

PLAYING ACTIONS
After an action has been recorded, you can play back the entire action or
individual commands within it. (In button mode, clicking a button executes
the entire action—though commands previously excluded by clicking the
Toggle item on/off icon are not executed.)

■■■■■ To specify which file the action is played on, select it in the File Browser or
open it and make it the active image. (Using the Batch command you can
play it on multiple files—page 176.)

■■■■■ To play an action on a file, do one of the following:

● To play an entire action, select the action name, and click the Play
button in the Actions palette, or choose Play from the palette menu.

● If you assigned a key combination to the action, press that combination
to play the action automatically.

● To play part of an action, select the command from which you want to
start playing, and click the Play button in the Actions palette, or choose
Play from the palette menu.

■■■■■ To play a single command in an action, select the command you want to
play and do one of the following:

● Ctrl+click the Play button in the Actions palette.

● Hold down Ctrl and double-click the command.

LOADING AND MANAGING ACTIONS
You can load action sets including your own, those included with Photoshop,
and those obtained from other people or companies.

■■■■■ To load a set of actions do one of the following:

● Choose Load Actions from the Actions palette menu. Locate and select
the action set file, and then click Load. (In Windows, Photoshop action set
files have the extension .atn.)

● Select an action set from the bottom of the Actions palette menu.

■■■■■ To restore actions to the default set, choose Reset Actions from the
Actions palette menu to display the prompt Replace the current actions, and
the choices OK, Cancel, and Append. Click OK to replace the current actions
in the Actions palette with the default set, or click Append to add the set of
default actions to the current actions listed in the Actions palette.

■■■■■ In Windows XP actions are stored in the following location:

C:\Program Files\Adobe\Photoshop CS\Presets\Photoshop Actions

To find them on other systems, use your operating system’s Find or Search
command to locate the folder holding files with the extension .atn.

CREATING AND USING ACTIONS

The default set of
actions indicate those
that work only on
selections and type
layers.

Photoshop comes with
sets of actions you can
load.

Buttons on the Actions
palette include (left to
right), Stop playing/
recording, Begin
recording, Play
selection, New set,
Create new action, and
Delete.
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USING THE BATCH COMMAND

The Batch command lets you play an action on a number of images that are
in a folder, open in the work area, or selected in the File Browser. You can
even import and process images from a digital camera with a single action.

When batch-processing files, you can leave all the files open, close and save
the changes to the original files, or save modified versions of the files to a
new location (leaving the originals unchanged). If you are saving the pro-
cessed files to a new location, you may want to create a new folder for the
processed files before starting the batch.

To batch-process files using the Batch command choose File>Automate>
Batch to display the Batch dialog box with the following settings:

TIP

■■■■■ Our basic
approach to batch
processing can be
summed up as
“open and close in
the action, sup-
press and override
in the batch.” This
simply means your
action should
include the com-
plete cycle from
opening the image
to saving and
closing it. In the
batch file dialog
box you then turn
on any check box
that has to do with
overriding save or
open commands
and suppressing
dialog boxes.
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PLAY SECTION
The Play section lets you choose the action you want to use to batch process
selected images.

■■■■■ Set drop-down arrow lets you select the set containing the actions you use
to choose the set that contains the action and the action itself.

■■■■■ Action drop-down arrow lets you select any action in the selected set.

SOURCE SECTION
The Source section lets you specify which images are to be processed and
how any Open command in the action are to be handled. It also lets you
suppress dialog boxes and warnings.

■■■■■ Source drop-down arrow lets you specify what files are to be affected by the
action you play. The choices include:

● Folder, our recommended choice, plays the action on all of the images
in the selected folder. Click the Choose button to locate and select the
folder.

● Import imports and plays the action on images from a digital camera,
scanner, or PDF document.

● Opened Files plays the action on all open files. This choice is OK to use if
you planned for it and didn’t include an Open step in your action.

● File Browser plays the action on the files selected in the File Browser.

■■■■■ Override Action “Open” Commands works as follows:

● When on, the Open command in the action opens the batched files you
are processing, not the file you used to create the action. This is the
recommended option if you recorded an Open step in the action as we
recommend.

● When off, the action operates on open files, or opens the file you used to
record the action.

■■■■■ Include All Subfolders check box, when on, processes files in subfolders.

■■■■■ Suppress File Open Options Dialogs check box, when on, hides File Open
Options dialog boxes. This is useful when batching actions on camera raw
files. The default or previously specified settings will be used.

■■■■■ Suppress Color Profile Warnings check box, when on, turns off the display
of a dialog box when there are profile mismatches (page 185).

DESTINATION SECTION
The Destination section lets you specify how and where the processed images
are stored. This is straight-forward unless the selected action also has save
commands (which we recommend they have). Our recommendation is to
always save your processed files in a separate folder so you don’t inadvert-
ently overwrite the working files. (The original image files are stored sepa-
rately on a CD, aren’t they!)

USING THE BATCH COMMAND

TIPS

■■■■■ To import
images from your
digital camera the
camera may
require an acquire
plug-in module
that supports
actions. If yours
won’t work during
batch-processing
contact the plug-
in’s manufacturer
for further infor-
mation.

■■■■■ To improve
batch processing
performance,
reduce the number
of saved history
states and deselect
the Automatically
Create First
Snapshot option in
the History palette.
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■■■■■ Destination drop-down arrow lets you specify how the processed images
are saved. The choices include the following:

● None leaves the files open without saving changes (unless the action
includes a Save command). This is a safe option to use but consumes a lot
of memory if you are processing a lot of files.

● Save and Close saves the files in their current location, overwriting the
original files. Avoid this option until you have mastered batch files or you
may end up overwriting original files.

● Folder saves the processed files to the specified folder. If you select this
choice, click the Choose button to select the destination folder—preferably
one created specifically to hold processed images. This is the recom-
mended choice since you never put any image files at risk of being over-
written.

■■■■■ Override Action “Save As” Commands check box specifies how Save As
commands in an action are processed.

● When on, the processed images are saved using the format you specified
in the action, but in the folder specified in the Destination section de-
scribed above.

● When off, you can encounter problems that neither you nor I have time
to go into.

■■■■■ File naming section is used if you chose Folder as the destination to specify
a file-naming convention and select file compatibility options for the pro-
cessed files. Normally you would leave these at their default settings so
processed files have the same name as the original files, but are in a different
folder and perhaps have a different extension if the action changes the file’s
format. Retaining the original filename makes multiple versions of the same
image easier to track.

● To specify how files are named, click the drop-down arrows and select
elements from the menu or enter text into the fields to be combined into
the default names for all files. The fields let you change the order and
formatting of the filename parts. You must include at least one field that is
unique for every file (for example, filename, serial number, or serial letter)
to prevent files from overwriting each other.

● Starting serial # text box is where you enter a starting number for any
serial number fields. Serial letter fields always start with the letter “A” for
the first file.

● Compatibility check boxes let you specify which operating systems f
your filenames are compatible with. Your choices include Windows, Mac
OS, and UNIX operating systems.

ERRORS SECTION
The Errors drop-down arrow lets you specify how errors are processed.

■■■■■ Stop for Errors suspends the process until you confirm the error message.
You may want to use this choice while testing the action.

■■■■■ Log Errors to File records each error in a file without stopping the process.
If errors are logged to a file, a message appears after processing. To review
the error file, open with a text editor after the batch command has run. If you
select this choice, click the Save As button to specify a filename and folder for
the log file.

HTTP://WWW.PHOTOCOURSE.COM


179FOR INFORMATION ON DIGITAL PHOTOGRAPHY, VISIT HTTP://WWW.SHORTCOURSES.COM

Buttons on the Actions
palette include (left to
right), Stop playing/
recording, Begin
recording, Play
selection, New set,
Create new action, and
Delete.

TIP

■■■■■ When you use an
action to open a
camera RAW
image file, the
Photoshop Camera
Raw plug-in
settings are based
on the settings in
the dialog box
when the action
was recorded. You
may want to create
different actions
for opening camera
raw image files
with specific
settings.

BATCH PROCESSING CAMERA RAW IMAGE FILES—A TUTORIAL

BATCH PROCESSING CAMERA RAW IMAGE FILES—A TUTORIAL

To help you better understand actions and batch files, here is a step-by-step
tutorial that processes RAW files into Photoshop (PSD) files.

GETTING READY
When you run a batch command, you can specify where the images are to be
found (the source) and where the processed images are to be stored (the
destination). There are many possible combinations but we will use separate
folders:

1. Create a folder named actions-source for the RAW images you want
processed and copy the RAW images into it.

2. Create a folder named actions-destination where the processed images
will be saved. Saving them to a separate folder ensures processed images
won’t accidentally overwrite your original files. (RAW files can’t be overwrit-
ten, but we’re encouraging careful work habits here.)

3. Open Phosotshop, display the File Browser and select the actions-source
folder to display the RAW files you are going to convert. Doing this before we
begin recording keeps these steps from being part of the action.

CREATING THE ACTION
Follow these steps to create an action that opens camera RAW image files
and then saves them in the Photoshop (PSD) format.

1. To display the Actions palette choose Window>Actions

2. To create a new set, click the palette’s Create new set button to display the
New Set dialog box. Enter the name RAW Image Processing and click OK.

3. To begin recording an action, click the Create new action button to
display the New Action dialog box. Enter the name RAW to PSD Conversion.
check that the Set is RAW Image Processing, and click the Record button.
The palette’s Begin recording button turns red to remind you that you are in
record mode.

4. Double-click a camera raw image file to open it in the Camera Raw plug-
in (page 80). If necessary, click the Settings drop-down arrow and choose
Selected Image so that each image’s own metadata settings will be used when
playing back the action.

5. Perform the operations you want to record. If you are just using the
action to convert the files to the Photoshop format you don’t need to do
anything here. (You can insert a stop later—page 174—if you want the Cam-
era Raw plug-in to pause on the screen so you can make custom adjustments
to each image.)

6. To open the RAW image in Photoshop, click OK. If you get an Embedded
Profile Mismatch dialog box, click OK.

7. To save the file, choose File>Save As to display the Save As dialog box. Set
the Save in folder to actions-destination, the Format to Photoshop (PSD),
and click the Save button.

8. To close the file, choose File>Close. You have now recorded an entire
cycle.

TIP

■■■■■ The files for this
tutorial are on the
same CD as the
eText version of
this book in a
folder named RAW
images. If you
don’t have this CD
copy 5 or 6 of your
own RAW images
into the folder.
They will work just
as well.
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9. To stop recording, click the palette’s Stop playing/recording button. The
action you’ve created can now be used when you want to convert one or more
camera raw image files.

10. Use the File Browser to look at the contents of the actions-destination
folder and you will find the processed file there in PSD format.

CREATING THE BATCH COMMAND
Follow these steps to use the action you created to process a batch of RAW
files, saving all of them in the Photoshop (PSD) format.

1. To display the Batch dialog box, choose File>Automate>Batch from the
main menu or Automate>Batch from the File Browser menu.

2. To specify what action is to be used, be sure the Set is RAW Image
Processing and the Action is RAW to PSD Conversion. If they aren’t, use the
drop-down arrow to make these settings.

3. To specify which images are to be processed, click the Source drop-down
arrow and select Folder. Click the Choose button to display the Browse for
Folder dialog box so you can choose the folder in which your RAW images are
stored, in this case actions-source. Click OK to return to the Batch dialog
box.

4. To have Open commands in the action refer to the batched files rather
than the filenames specified in the action, turn on the Override Action
“Open” Commands check box. When a dialog box appears, read it and then
click its OK button.

5. To keep the Camera Raw dialog box from opening for each camera raw
image file being processed turn on the Suppress File Open Options Dialogs
check box.

6. To prevent color profile mismatch warnings from being displayed for
each image when its opened, turn on the Suppress Color Profile Warnings
check box.

7. To specify a destination for the processed files, click the Destination drop-
down arrow and select Folder. Click the Choose button to display the Browse
for Folder dialog box so you can choose the folder in which processed PSD
images are stored, in this case actions-destination. Click OK to return to the
Batch dialog box.

8. To ensure the processed files are stored in the format specified in the
action and the folder specified in 7 above, turn on the Override Action “Save
As” check box. When a dialog box appears, read it and then click its OK
button.

9. To process the files, click OK in the Batch dialog box. If you get an Embed-
ded Profile Mismatch dialog box for each file, you have encountered a bug in
Photoshop. Since you turned on the Suppress Color Profile Warnings check
box in step 6 this dialog box shouldn’t appear but it does. Just click OK each
time it appears. (If you don’t see it, it means Abobe fixed the bug.)

10. Use the File Browser to look at the contents of the actions-destination
folder and you will find the processed files there in PSD format.
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A droplet icon on the
desktop.

CREATING A DROPLET
A droplet applies an action to one or more images that you drag onto the
droplet icon that you have saved on the desktop or to another location on
disk. Here we use the droplet to convert RAW images but you can create
others to perform such routine tasks as resizing images for e-mailing or
posting on a Web blog.

1. To display the Create Droplet dialog box, choose File>Automate> Create
Droplet from the main menu. The dialog box is almost identical to the Batch
dialog box discussed on page 176.

2. To specify a location for the droplet, click the Choose button and select a
folder, for example, the desktop folder.

3. To have Open commands in the action refer to the batched files rather
than the filenames specified in the action, turn on the Override Action
“Open” Commands check box. When a dialog box appears, read it and then
click its OK button.

4. To prevent the Camera Raw dialog box from opening for each camera
raw image file being processed turn on the Suppress File Open Options
Dialogs check box.

5. To prevent color profile mismatch warnings from being displayed for
each image when its opened, turn on the Suppress Color Profile Warnings
check box.

6. To specify a destination for the processed files, click the Destination
drop-down arrow and select Folder. Click the Choose button to display the
Choose a Batch Folder dialog box so you can choose the folder in which your
RAW images are stored. Setting the other options in the Create Droplet
dialog box is up to your discretion.

7. To ensure the processed files are stored in the format specified in the
action and the folder specified in 7 above, turn on the Override Action “Save
As” check box. When a dialog box appears, read it and then click its OK
button.

8. To finish, click OK. You can now open single or multiple camera raw files
by dragging them onto the droplet.
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Colors in the original scene pass through a number of steps before they
finally emerge to be displayed on the screen or in a print. To ensure
that colors change as little as possible as they pass from one device to

another, you must perform at least three basic steps in Photoshop—
calibrating your monitor, customizing color settings, and creating profiles of
your equipment. Although you don’t have to do these things, you should do
so because the choices you make influence how the colors in images are
displayed and printed. The entire process is referred to as color
management and it sounds more complicated than it is. Taking the time to
color manage your system saves you much uncertainty and frustration in the
long-run, especially when capturing photos where color accuracy is
important. Much of the background of color management is discussed in
The Textbook of Digital Photography and that lengthy discussion isn’t
repeated here.

Chapter 9
Color Management

CONTENTS

■ Calibrating Your Monitor
■ Color Managing Your
Images ■ Using Profiles
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CALIBRATING YOUR MONITOR

One of the first things you should do when you start photo-editing is cali-
brate your monitor using Adobe Gamma or a third-party package of soft-
ware and hardware for even more accurate calibration. This standardizes at
least one part of your system so grays are neutral without color casts and
your prints aren’t always too dark or too light. To create a monitor profile on
a Windows system, you use the Adobe Gamma software that was installed
with Photoshop:

■ On a PC look for it first on Windows’ control panel under Appearance and
Themes. If not there, it should be stored in the Program Files/Common
Files/Adobe/Calibration folder on your hard drive. If you click Adobe
Gamma.cpl it opens the Adobe Gamma dialog box or another dialog box that
lets you also open the Wizard.

■ On a Mac you use the Display Calibrator Assistant which isn’t covered in
this book.

TIPS

■ Adobe recom-
mends that your
screen resolution
be set to at least
1024 x 768 and
colors to 24-bits
(Windows) or
Millions (Macs).

■ Before calibrat-
ing the monitor
make sure it has
been on for at least
30 minutes. Also
use the same room
lighting you
normally use and
have the monitor
in its usual posi-
tion.

■ If you do not
have a default
profile, contact
your monitor
manufacturer for
appropriate
phosphor specifica-
tions.

Selecting Custom from
the Phosphors drop-
down menu displays a
dialog box where you
can enter settings from
your monitor’s manual.

Hardware and software
from companies such as
GretagMacbeth make it
easy to profile all parts
of your system.

CALIBRATING YOUR MONITOR

HTTP://WWW.SHORTCOURSES.COM


184

CHAPTER 9. COLOR MANAGEMENT

FOR INFORMATION ON CLASSROOM USE, VISIT HTTP://WWW.PHOTOCOURSE.COM

When you start Adobe Gamma its dialog box appears on the screen with the
following settings:

■ Wizard button, in the lowerright corner of the dialog box, leads you
through the entire calibration process step-by-step with help along the way.
As you page through the steps by clicking the Next> button, you fill find the
choices below.

■ Description text box lists the name of the current monitor profile. If you
are changing settings, you can enter your own name for the new profile but
the one that’s current when you enter a new name becomes your starting
point for settings so it should be the best one available for your monitor.
Type a name you will easily identify, such as the monitor name and the date.
When you click OK at the end of the adjustment session, the Save As dialog
box opens so you can save it under its own name. The Load button displays
the Open Monitor Profile dialog box so you can load a previously saved
profile.

■ Brightness and contrast setting in the dialog box displays a checker board
pattern and a pure white section so you adjust the brightness control on your
monitor to make the alternating gray squares in the top bar as dark as
possible (but not black), while keeping the bottom bar a bright white. In the
Wizard you adjust a box within a box.

■ Phosphors drop-down arrow lets you select your monitor. If it’s not listed,
you can select Custom to display the Custom Phosphors dialog box and enter
the settings found in your monitor’s user manual.

■ Gamma sliders adjust the brightness of the middle tones and is a neces-
sary step because the range of tones displayed on a monitor is not linear. If
you graphed the brightness of all tones between white and black, they would
form a curve, not a straight line. As a result, tones in the middle get crunched
together so image gradations aren’t as smooth as they could be. Gamma
adjusts the middle tones so they more closely match a printer’s output.

When the View Single Gamma Only check box is on you adjust the overall
tones instead of the individual color channels. When off, you adjust the red,
green, and blue channels separately by dragging their sliders until the small
central square in each blends as closely as possible with the surrounding
area. The Desired drop-down arrow lets you specify if you want to adjust for
the Windows Default, Macintosh Default, or Custom environment. You
should make this choice before using the sliders to adjust the gamma.

■ Hardware White point sets the point at which red, green, and blue screen
elements create white. The Measure button displays a dialog box explaining
that when you click OK you will see three squares and you are to select the
most neutral.

■ Adjusted White Point check box should usually be left set to Same as
Hardware.

■ Before and After option buttons (on the Wizard only) let you switch
between before and after views. If you load a photo into Photoshop before
beginning the calibration, you can see what affect your adjustments have on
the way it looks as you click back and forth between the two buttons.

■ OK button complete the process and displays the Save as dialog box so you
can name and save your changes if you want to reuse them.

Clicking the Wizard
button guides you
through adjusting
gamma step by step.
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SPECIFYING COLOR SETTINGS

Access to the Color Settings dialog box is offered the first time you launch
Photoshop, but it’s also accessible any other time by choosing Edit>Color
Settings. Using this dialog box, you can choose from lists of predefined color
management settings. Although outside the scope of this book, you can also
create and save your own custom settings and even share them with other
users and other Adobe applications that support color management.

Regardless of how you got there, when you display the Color Settings dialog
box you have the following choices:

TIP

■ It is important to
use the same color
settings in other
color-managed
applications so
your color is
consistent between
the applications.
However, even
then, colors will
probably not
match between
color-managed
applications and
non-color-man-
aged applications.

The first time you start
Photoshop after
installing it or restoring
its default settings
(page 8), a dialog box
appears asking if you
want to customize color
settings.

■ Settings displays the currently selected preset. You can click the drop-
down arrow to select another setting and some choices to consider include
the following:

● North American General Purpose Defaults (the default setting in North
America) uses general purpose color settings for consistent color handling
across Adobe software products in North America. If you live in another
area, select an equivalent setting for your region. (Other choices include
Japan and Europe.)

● U.S. Prepress Defaults manages color for printing on a printing press at
a commercial printer in the U.S.

● Web Graphics Defaults manages color that will be published on the
World Wide Web.

● Color Management Off is not a good choice when working mostly with
digital camera images that are tagged with color profiles.

SPECIFYING COLOR SETTINGS
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The Setting you choose has accompanying Working Spaces and Color
Management Policies so when you change the Setting to another preset,
others areas of the dialog box change to reflect that choice. However, you
can still go to these other sections and make changes. If you do so, the
Setting changes to Custom. If you do make changes and want to reuse them,
you can click the Save and Load buttons. Here are the other settings you can
change:

■ Advanced Mode check box, when on, displays additional choices outside
the scope of this book.

■ Working Spaces section let’s you choose a working space—the default
profile that defines the color space in which you edit an image. Your choices
include sRGB, Monitor RGB, Adobe RGB, Apple RGB, and Color Match
RGB.

■ Color Management Policies section specifies what Photoshop does when
you open an image with a color profile that differs from the one you have
specified in the Working Spaces section above. The three image types—RGB,
CMYK, and Gray scale—can be set to one of the following settings using the
drop-down arrows:

● Off does not color manage new, imported, or opened color data.

● Preserve Embedded Profiles is best when you work with both color-
managed and non-color-managed images, or with images that use differ-
ent profiles within the same color mode.

● Convert to Working Space is best when you want to force all images to
use the current working space.

The check boxes in this section specify if messages are to be displayed when
there is a profile mismatch. Initially you might want to turn all of these on.
You can always turn them off later. When on, you will be given the option to
override the policy’s default behavior.

If your camera has
applied a different color
space than Photoshop is
set for in the Color
Settings dialog box, the
Embedded Profile
Mismatch dialog box
appears.

TIP

■ A word you may
encounter in color
management is
metamerism. This
refers to how print
colors look differ-
ent under different
light sources such
as tungsten light-
ing and natural
sunlight.

■ Description section displays descriptions of the options when you position
the pointer over a section heading or menu item.
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USING PROFILES

One problem digital photographers have to cope with is the way the colors
and tones in our images look different on different devices. This becomes
especially apparent when we print an image and it doesn’t look the same as it
does on the screen. What is the point of making an image look perfect on the
screen if it looks different on other screens, or if prints made from it are too
light or dark or have color casts? To keep colors and tones as consistent as
possible, we use a process called color management. The basic idea is to
attach a profile to each image that describes what colors the image contains—
technically called a color space. Many cameras use a color space called sRGB
when capturing an image and then attach a profile for sRGB colors so other
devices will know what color space was used. A few cameras let you choose a
color space. If so, one called Adobe RGB has a wider range of colors—called a
gamut. Attaching a profile to an image is only the first step. To give it value,
other devices such as monitors and printers must be able to interpret the
profile so they can accurately display or print the colors it contains. This is
done by assigning each device its own profile that acts much like a transla-
tion table when the image is printed or displayed on a monitor. The process
goes something like this:

1. The printer or monitor looks at the image’s attached profile to see what
color space it uses and then sets its profile to the same color space. It’s as if a
tour guide meets two tourists and asks “What language do you speak?” If one
responds “English” and the other “Deutsch” the guide knows how to interpret
between the two.

2. As each pixel now arrives from the image, the printer or monitor checks its
color value and then looks up that color in its profile to see how to print or
display it. Without profiles to translate between devices, the devices would
just be able to display a fixed set of unadjusted colors.

To make this system of profiles as universal as possible, a group called the
International Color Consortium writes the rules, so many profiles are identi-
fied as ICC profiles.

When you open an image, you can check to see what color profile is attached,
and then leave it as is, or change it. You would change the profile to better
match the colors to the device you are planning to output it to. For example,
if you are going to display an image on the Web, you can let an sRGB profile
attached by the camera manage the image, or if the camera attached an
Adobe RGB profile, you can replace it with an sRGB profile.

■ To see which, if any, color space the camera used to capture your image,
select File>File Info and then click the Camera Data 2 heading. It’s listed
next to the heading Color Space. You can also see what color profile is
attached using the File Browser’s Metadata tab where it is listed under File
Properties. It’s also displayed when using the File>Save As (page 35) and
File>Print with Preview (page 39) commands.

■ To change the color profile attached to the image, select Image>Mode>
Assign Profile to display the Assign Profile dialog box. Click the Profile radio
button and then the drop-down arrow to select a new profile.

■ To convert an image to another profile, choose Image>Mode>Convert to
Profile to display the Convert to Profile dialog box.

TIP

■ Profiles are
discussed in detail
in The Textbook of
Digital Photogra-
phy and that
lengthy discussion
is not repeated
here.

Sony’s Artisan Color
Reference System has
integrated profiling
hardware and software.

The colors of prints
depend on the light
under which you view
them. Many
photographers are using
Solux bulbs and lamps
to evaluate their prints
because they so closely
approximate daylight.
Courtesy of Solux
(http://www.solux.net).

USING PROFILES
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