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This guide is designed to introduce you to using Macromedia Dreamweaver MX if you’re unfamiliar with any major aspect of it. The lessons in this guide lead you through the process of creating a simple but functional website. 

The Basics:

A web site, simply put, is collection of images and a series of files written in the HTML language that represent web pages. 

HTML (“Hyper Text Markup Language”), the language in which almost all web pages are written, was designed to allow people to graphically mock up and position blocks of text. It differs from actual programming language in this way – html is used to position text, links and graphics on a web page.

Using Macromedia Dreamweaver MX:

Macromedia Dreamweaver MX is a professional HTML editor for designing, coding, and developing websites, web pages, and web applications. Using a combination of icons, “Wizards”, and “right click and modify” actions, Dreamweaver MX works in much the same way to create web sites as Microsoft Word does in creating text documents.

The Plan for Today’s Training Session:

#1– Modify a prexisting web page

#2– Create a new basic shell web page

#3-  Migrate a web page and corresponding images to the web server.

First Steps in Using Dreamweaver:

Before we do anything, we'll need to create a "site."  This is what Dreamweaver calls the workspace in which you'll be creating your site. 

#1- At the top tool bar, click on Site and New Site

#2 - In the "Site Definition" box (part 1) , choose a Dreamweaver Test as the name for your site, hit next 

#3-  In this box (part 2), choose "No, I don't want a server technology" 

#4-  In box part 3, choose "Edit local copies on my machine, then upload to remote server (recommended)"  In the field for file location, choose C:/Dreamweaver_Tutorial - this is where you'll keep your web pages today

#5- For this box (Sharing Files), choose None for "How do you connect to your remote server" 

#6- In the final box, hit "Done"

Your Dreameaver "site" workspace has been created.  Now we'll check out the pre-made design templates Dreamweave offers you when creating a new page.
Modifying a Pre-Existing Page

#1 – Click on File > Open and navigate to your C:/Dreamweaver_Tutorial folder

#2-  Double click on “aboutus.html” to open it in Dreamweaver

We’ve received some web updates from our client, Philash Entertainment.

They would like us to do the following updates to this page:

A- Make the background image of the page have a grid design. This involves changing the background image of the page. 

#1 – Click on Modify > Page Properties in the top tool bar.

Click on Browse next to the “background image” field and navigate to “background_grid.gif” in our images folder. Double click on this file to select it as our background image of the page. Click Apply and OK.

B- Replace the “Philash Entertainment” header image at the top with one that uses red text.

Here is where the “mouse click and edit” functionality of Dreamweaver becomes apparent. Much the same as Microsoft Word, you can click on page elements (images, text, links), right click once on them and then select Properties. You can now edit the properties of the selected page item. 

For our example, right click on the “Philash Entertainment” image and then click “Source File”.  The name of the current blue-text image is called “header” but we’d like to replace this with “header_new.gif’ which has been created with red text. Type “header_new” in the field, OR you may switch to thumbnail view and navigate to the correct image. 

C- Change the references to “Philash Entertainment Group LLC” to simply “Philash Entertainment” so the company’s name in text matches the header image. Bold this text and change its color to bright red.

Similarly to how we edited the header image, we can edit the text. Right click and highlight the citations of “Philash Entertainment Group LLC” and retype “Philash Entertainment.” While the text is still highlighted, click on Text in the top tool bar, and then select “style”. Select “bold”.  Next, select Text again and this time, select color. From the palette that appears, choose bright red. 

D- The company would like the blue text area background to be grey (grey code #999999).

Left click (but DON’T DRAG) on the inner border lines of the blue text area table, but avoid clicking on any text or images (“about us”). Right click on the border line – this will open a properties palette at the bottom of your screen.

Where it has “Bg Color” is listed, click on the triangle drop down box next to the blue color. In the palette scroll the eyedropper tool until you see #999999 is visible and click to select this color. Your cell background will now change from the previous blue to grey.

E- Now that we have changed the background color of this cell, the “About Us” image’s blue background no longer matches. Luckily, we have a new “About Us” header image with a grey background to use.

Right click on the “About Us” image and then click “Source File”.  The name of the current blue-text image is called “header” but we’d like to replace this with “hdr_aboutus_new.jpg’ which has been already. Switch to thumbnail view and navigate to the correct image. 

F- Make the word “Philadelphia” a link to http://www.philadelphia.com.


Select the “Philadelphia” text – in the palette that opens at the bottom of the page, enter http://www.philadelphia.com in the “link” field. Hit return and now you’ll see “Philadelphia” is linked. 

G- We’re now done the edits we need to do to this page. Click File at the top tool bar and select Save.

Congratulations – you have just updated your first web page! You are now web developers, and are well on your way to achieving the coveted title of “web geek.”    ;-)
Some CRUCIAL Tips When Editing Web Pages:

#1 – Before editing a web page, make a backup copy. I can’t stress enough the importance of making backups. If you don’t yet have a feeling for the importance of backups, you will quickly realize it 1.5 seconds after deleting an entire web site:  You will go through three steps:


Denial – “no – I DID NOT just delete this web page.”


Anger – “%#$! I deleted it!!!!!”


More Anger – “I am such a %$!##!!*&!!”

#2-  If you make a goof while working in Dreamweaver, it allows you to click Edit and then Undo. The web developer’s mantra is “edit-undo.” 

#3- Dreamweaver may look intimidating, and the learning curve may be steeper than that of other web editor programs such as Netscape Composer. But, by opening pages from your local PC into Dreamweaver right clicking on page elements (images, links, etc) and playing around with the program it wil begin to make sense. Don’t be afraid of making mistakes or making ugly web pages while you experiment. As long as you don’t save over the good copy of the page, you’re fine. This statement could qualify as mantra #2 of web developers. 

Create and Saving a New Web Page Using Pre-made Design Templates

We'll now take a brief look at the starting page templates that Dreamweaver provides for you.

To create a new page using Dreamweaver’s pre-made page design templates: 

1. Choose File > New.
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The New Document dialog box appears.


PRIVATE "TYPE=PICT;ALT=This is a picture of the feature being described."
2. In the category list on the left, select the Page Designs category.

The list in the middle column of the dialog box is relabeled Page Designs. A list of pre-designed page designs appears. 

3. Scroll down in the Page Designs list and choose the item named Text: Article D with Navigation.

Note: There is another item with a similar name. Be careful not to choose the item named Text: Article D, which has no navigation bar.

A small preview of the page appears on the right side of the dialog box.


PRIVATE "TYPE=PICT;ALT=This is a picture of the feature being described."
4. Make sure the Document radio button is selected at the lower right of the dialog box.

5. Click Create.

A new page appears, using the layout you chose, in a new Document window. The page is filled with placeholder “Lorem ipsum” text to show how the page design will look when real text is added to it. 
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PRIVATE "TYPE=PICT;ALT=This is a picture of the feature being described."
Let's close out of this page (File > Close) and take a look at creating a blank web page ourselves, without using Dreamweaver's design templates. 

Creating A New Web Page Without Using Dreamweaver's Templates
#1- Click File > New 

#2- In the "New Document" popup, choose Basic Page and HTML 
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#3- Hit the Create button 

#4- You are now looking at the code that generates your blank page. We want to go from our "code view" to the "graphic mockup view" - Rollover the "<>" button in your top tool bar in the top left. That will say "code view" now move to the right two buttons and hover over that button. It should say "Design View". Click on that. 

NOTE- you can hover over all the icons in Dreamweaver and it will display the icon's function.

#5- Now that we're in "Design View", we can now graphically build the page 

#6- Click on "Insert" at the top and then in the drop down list provided, click table 

#7- I'd like my web page to resemble the Rutgers site, so I am going to chose a table with 1 Row, 2 Columns and a Width of 700 pixels wide. 

NOTE: you must change the units of width from "Percent (of screen)" to "Pixels".

#8- Hit OK. 

Now you'll see a very basic two column table. I'd like to spruce up that shell table.

#1- Hover your mouse over the border of the table on the left side until the cursor goes from a four-directional arrow to a one directional arrow. Click your mouse to highlight the left cell. 

#2- In the palette below, next to the W (width), enter 150 (we want this navigation cell to be 150 pixels wide) and hit return 

#3- Now change the background of this cell by clicking on the black triangle in the grey color palette box thats found next to "Bg". Once you click this triangle, a color palette will appear. Pick a color for your left cell's background. 

#4- Now click inside the right table cell.  Start typing "My Home Page" 

#5- You can highlight this text, click text in the toolbar above and then modify the color and size of the text as you wish. 

#6- Back to the left cell now - we want to add links: 

        
Type "home" then return, "about me" then return. 

Highlight each of these words and right click - in the drop-down list that appears choose "make link" and select where you want the link to go. For

example, the link for "home" should probably go to "home.html" etc.  Link "about" me in the same way. 

#7- If you'd like to add images to your page, click inside the right cell and then click on insert in the top tool bar and then choose "Image". From there, select what image you want to go in your page. You can move the image around and position it by clicking on it and then chosing different alignments. Play around with it - it will soon make sense. 

  Thats a basic page created from scratch.  You can also use Dreamweaver's already-made templates, as I've illustrated earlier in this handout. 

The Last Step:  Migrating a Web Page and Images to a Remote Web Server
Now that we’ve updated our web page stored on our desktop computer, we want to move this page and its constituent images from our local drive to the web, so everyone can see it. We do this by using another program called SSH Secure File Transfer Client
#1- On your desktop, launch SSH Secure Shell File Transfer

#2- Click “Quick Connect” button in the top left

#3- Enter “crab.rutgers.edu” for hostname

#4- Enter your crab email name for user name

#5- At the prompt, enter your crab password

This will bring you to your home directory.

#6- Click on “html” or “public-html” to get into the proper folder for your site

#7- Select a file in the left panel (your local drive), right click, and select upload

#8- After uploading files, always check the live site on the Internet to confirm your files were migrated successfully.  Stay connected to SSH.

#9- If given “You don’t have permission” error, right click on the file in the “remote server” (right side) panel on SSH.

#10 - After right clicking, click “properties” to view the file’s permissions.

The file should have permission code “755” which allows you (the “owner”) to read, write to, and execute the file. Everyone else (“group” and “other”) should only have “read” and “execute” permissions.

Glossary
a- Internet:  A network of millions of computers linked together that allows users to send and receive information (graphics, text, video, audio etc) 24-hours a day. The Internet comprises several subgroups, including the graphically-enriched and most popular World Wide Web that most people are familiar with.

b- Server:  A large computer that hosts web sites. This computer can allow multiple users to access it and "surf" the site.

c- Browser: A computer program that receives web site code and reformats it into images, text and links, thus presenting the viewer a complete "site"

d- HTML-  "Hypertext Markup Language" - the language in which most websites are written. 

e- Website Publishing- The act of taking the files that compose a website from your desktop computer and putting them on a public server computer, so everyone on the Web can access your site.

f- Web Editor-  A program that allows users to build a website as if they were using a Word Processor-type program. Paragraphs and tables can be highlighted, dragged and dropped, changed etc. A Web Editor spares the user from writing HTML code by hand.

g- Directories-  Also know as "folders", directories simplify the file structure of a site, so not every file is grouped with every other one. For example, a site's image files are commonly put in a directory (or folder) called "images." 

h- Tables- Used very commonly on web pages, tables are structured like a chessboard and separate content on a web page. The most common table format is a table of two columns, in which one column holds the navigation links and the other column (usually much wider) holds the text content.

i- FTP - "File Transfer Protocol" - a method commonly used to "migrate" or "publish" (move) files from a computer sitting on the desktop to a publicly-accessable server on the World Wide Web.
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